5 Replies Latest reply: Apr 30, 2010 1:07 AM by Nine
joannedoj Level 1 Level 1 (5 points)
Out of nowhere, my iBook will not connect to the Internet-- wireless or when I use an ethernet cable. I have tried zapping the PRAM and resetting the power settings. Also tried removing the external battery and letting it sit 15 minutes. Nothing. Everything else works fine. Any ideas?

iBook G4, Mac OS X (10.5.8)
  • a brody Level 9 Level 9 (64,880 points)
    Is it normally connected direct to a DSL or cable modem?
    Is there a router in between?
    What wireless access point are you connecting to?
    Have you tried a coffee shop with free wireless?
  • joannedoj Level 1 Level 1 (5 points)
    It normally gets internet via a wireless connection to my FIOS router. Nothing has changed, and my Macbook Pro has no trouble connecting.... I also tried plugging in an ethernet cable, but it still won't connect. I will try a wi-fi place.

    Also, it will not keep the time/date unless the AC adapter is connected. A techie told me that the internal battery may have gone bad. I hope not. He said it is soldered on to the motherboard. Which means "sell for parts". Any thoughts?
  • a brody Level 9 Level 9 (64,880 points)
    The iBook doesn't use a battery. Rather it uses a capacitor.
    That capacitor might have gone bad too.
  • Nine Level 1 Level 1 (15 points)
    I have an iBook G4 that also stopped connecting to the Internet recently. This is bugging me, because I just bought a new hard drive and upgraded the RAM in September.

    In my network settings, I am using DHCP. Neither my router at home nor the router at work is being recognized (i.e. the field is blank), and there is only a self-assigned IP address. I have tried connecting via Airport and via Ethernet both at work and at home and neither has worked. Last Friday I tried zapping the PRAM and it worked until I shut the computer down for the weekend. Monday morning, it won't connect again and zapping PRAM doesn't work anymore.

    I have even tried manually entering the router ID and an IP address that worked for other computers on the network, and that still didn't work. I suspect that something crapped out on me.
  • Nine Level 1 Level 1 (15 points)
    Okay, so I tried to create another user account and it didn't work. Bummer.

    The System Profiler will recognize my Ethernet Card (under the Network Tab) and the Airport Card.

    I took my iBook to the Genius Bar at the local Apple Store, and they were able to Boot off their network with my machine, and they concluded that the problem must be a software error. They suggested doing an Archive and Install reinstallation of the System Software, which I did. I chose the option to preserve users and network settings, and once I rebooted after the installation, everything worked as it had in the past. I was hoping to figure out what the actual problem was. All I know for sure is that it was software/settings related.

    Thanks for all of the help.