9 Replies Latest reply: Mar 2, 2010 9:07 AM by anhedonic
anhedonic Level 1 Level 1 (0 points)
Hello,

i want to control my macmini with my macbook pro. I enabled in Preferences > Sharing the Screen Sharing and searched in Safari for "vnc://macmini" ... but then told me the "Screen Sharing" Process: "not responding" every time i tried to connnect.

Thx for help.

MacBook Pro, Mac OS X (10.6.2)
  • KolinH Level 1 Level 1 (30 points)
    Check your Mini for its firewall settings as well. System Preferences -> Security -> Firewall. If it shows as being on, click on the "Advanced..." button on the dialog. You should see Screen Sharing listed at the top of the screen with it indicating "Allow Incoming Connections."
  • anhedonic Level 1 Level 1 (0 points)
    Thx, but didn't help me, even if i turn the firewal off. I tried it the other way round: sharing the screen from macmini to macbook pro and this was possible. Only the way from macbook to macmini won't work. Every time "not responding".
  • sig Level 8 Level 8 (35,775 points)
  • anhedonic Level 1 Level 1 (0 points)
    I don't do anything else for days. But thx.
  • KolinH Level 1 Level 1 (30 points)
    Hrm. Maybe I am misunderstanding your desired config so I'll write out what I think you are wanting to do.

    You have a Mac Mini running somewhere with screen sharing turned on and it shows as being on in the dialog (e.g., in the Sharing section, the Screen Sharing option is checked AND shows something similar to the following:

    "Other users can access your computer at vnc://192.168.1.101/ or browse for “anhedonic\'s MacMini”.

    AND when you have clicked on the "Computer Settings..." button, you have the checkbox checked that reads

    "VNC viewers ma control screen with password _______"

    And you have supplied a password. (Note, this is my setup which allows me to connect to my own MBP from ANY VNC client, even running on Linux, Windows, or Solaris. It might not be necessary for you since you only have two Macs.)

    And finally, the "Allow Access for: Administrators" is checked instead of "All Users".

    Your Firewall is off on the Mac Mini.

    And when you are sitting in front of your MBP, CMD-K brings up a dialog which allows you to enter:

    vnc://macmini

    And it doesn't work, the error popping up on your MBP indicating that the Screen Sharing process is not running.

    Is that about it?

    If I got something wrong, please advise but if correct, try to verify each of the settings as I mentioned above.

    Also, do you see a process on your Mac Mini (using Activity Monitor) that reads "AppleVNCServer"?
  • anhedonic Level 1 Level 1 (0 points)
    Yes, you're right. I did everything what you mentioned.
    Even, TeamViewer and other VNC Products are working. But Screen Sharing always freezing on MacBook. But i want to use Screen Sharing, because it wakes up the MacMIni in sleep.

    MacMini has a Process like "AppleVNCServer".
  • KolinH Level 1 Level 1 (30 points)
    And when you try to connect to the Mini using its IP address directly?

    Say you check on the Mini and see that it has IP address of 192.168.1.23, so you should try entering the following:

    vnc://192.168.1.23

    See if that produces anything different.
  • Meherally Level 4 Level 4 (1,115 points)
    Hi anhedonic,

    As I can see, you are using SAFARI to reach vnc://192.xxxx.xxx.x

    Try this, in Finder, choose the menu Go>connect to server... or hit cmd-K in Finder. In this window type vnc://192.xxx and see if it helps.

    Also, all connected servers should show up in the finder window sidebar and when you click on the shared computer, say 'macmini', then the window will show you option to 'share screen'.

    If it is not showing in the finder window sidebar, check Finder>preferences>sidebar>check the 'connected server' checkbox under 'shared'

    Message was edited by: Meherally
  • anhedonic Level 1 Level 1 (0 points)
    First, thanks all for the help, but i don't think it's a matter of connection. Both are working: Connecting over Safari and over Finder, too. I think to blame is the Application "Screen Sharing" or the configuration of the remote server macmini, but the MacMini is new, only just bought.

    MacMini -> MBP = no problem.
    MBP -> MacMini = "Screen Sharing" MPB is not responding and black screen. I don't know why.

    ...perpexedly.