Previous 1 2 Next 24 Replies Latest reply: Sep 29, 2013 1:56 PM by Stephan_DC
foggyclear Level 1 Level 1 (0 points)
I just got a new 27 in iMac, and am attempting to use the SD Card slot. I was able to mount 2 or 3 SD cards, but then my computer stopped recognizing them. After this point, it seems that the only way I can mount SD cards is to restart my computer with a card in the slot... any following attempts to read SD cards fail until the next restart. Is this a known issue?

In the day or so that I've owned this computer, I've actually had similar problems mounting either a digital camera via USB, or an iPhone... but checking for and loading software updates for Snow Leopard or other apps seemed to fix this. Unfortunately, all my available software updates have been installed... any more suggestions for dealing with this SD card issue would be appreciated.

iMac 27 inch Intel, Mac OS X (10.6.2)
  • setjockey Level 1 Level 1 (0 points)
    I'm looking for the answer to this as well. This is my first Mac, but it can't be right to have to restart every time I need to mount an SD Card.
  • Peter G Taylor Level 1 Level 1 (0 points)
    Yes, I have the same problem. I reported to apple and they had no solution. Next step is a repair solution. Will let you know if that works. But I think it is in OS or Bios - always works on reboot with SD card in slot.
  • Kevin Macdonald Level 1 Level 1 (5 points)
    Adding my name to the list of people who are having issues with the SD slot on new IMac. I have the 21 inch running 10.6.3. Having to restart to mount a SD card is getting old quick. Hopefully this will get addressed quickly. Will be putting a call into Applecare in the am with hopes of getting fix/answer.
  • Kevin Macdonald Level 1 Level 1 (5 points)
    Update - Worked with Applecare and identified the issue was hardware. Took a technician a couple of minutes to swap out the faulty component and everything is working as expected.
  • sergio sider Level 1 Level 1 (0 points)
    What do you mean "hardware"?... It sounds like firmware or software problem. My iMac has the same problem... after a dozen good "mounts", now the sd card is not accessible anymore.

    Still looking for a solution...

    Regards,
    Sergio.
  • sergio sider Level 1 Level 1 (0 points)
    Just for completeness.. the problem is the same... the card works, but it's only recognized if the card is mounted on a boot/restart. After you remove it (unmount) , the cards are not mounted again.

    If I use a generic $5 dolar USB sd-card adapter, the cards are mounted ok, so it looks like a firmware/sofrware issue that cannot auto-mount the card in the internal adapter.

    I can't believe this is a hardware problem. I am just running away from Windows and crappy hardware..

    Waiting for a solution,
    Regards,
    SERgio.
  • Hare Murare Level 1 Level 1 (10 points)
    Has this issue been resolved yet? I am finding that it is quite frustrating, surely there would be an SD card reader firmware update or something on a website we could use to get it working!!!!

    Any success stories with this guys?
  • Andrealobo Level 1 Level 1 (0 points)
    I have exactly the same issue, I'm a photographer and is a big deal have to restart the system to read a secure digital every time. I have no problem with compact flash and an external reader, but also the same reader won't mount any SD unless I restart.
  • Rod Chan Level 1 Level 1 (0 points)
    Seems like I am not the only one who get this problem...I just got this 27 inch iMac for about a month, at first it recognize the SD card every time I put it into the card slot, but when I try to import some files from the SD card few days ago, I've found the same problem with all of you...

    Yes, you guys are right, I want to have an answer before I ring to those non-polite representatives...are there any official solution now? The first post of this forum was on Feb 28...

    I haven't try the "restart with SD card mounted" solution, thank God, at least I can still import files without via the SD card usb adaptor...

    Message was edited by: Rod Chan
  • Kenneth Shiu Level 1 Level 1 (0 points)
    Add me to the list. I also have the same problem. Have called applecare and they ask me to unplug the main and repair the hardisk, but it doesn't help. Next would be to reinstalled the OS........I won't do so for such silly problem, pls help fix. BTW is it a hardware or software problem? does anyone konw?
  • eurisko2000 Level 1 Level 1 (0 points)
    Indeed, add me to the list too. I have 2 external card readers - Dazzle and a Sony and neither will mount an SD card when inserted. The Dazzle LED lights up for a while whilst the card is initially read but then extinguishes without anything happening.

    So for now, I can't mount any SD cards on my Mac.

    I use TechTools to keep the system in trim. I have to say this is one of the only major problems I have experienced in all the OS X updates.
  • elmac Level 5 Level 5 (4,230 points)
    Hi, my suggestions as follows:- 1st go the SMC route..
    Then after reboot Turn Off the Mac..connect the external card reader & reboot once rebooted insert the sd card into the reader,,sometimes when I put the card into the ECR and then plug it into the Mac it does not read, why I do not kno" - So now I plug in the ECR & then insert the sd card, works every time...I recommend a direct connection ECR -> computer USB socket (no Hub)...L
  • Yiguang Level 1 Level 1 (0 points)
    My problem is: my new 27" iMac's SD built-in reader didn't work at all- not even one time. Called Apple Care, went through two levels of advisor's, 15 minutes later, secured an appointment at a local Apple store... faulty card reader! They were going to swap the faulty part, but ran out of time. They gave me another brand new iMac to take home instead.

    I didn't want to take a chance - check out the SD reader in the store before heading home - yes, the SD reader worked.

    My suggestion is: call Apple and then pay the Apple Store a visit. Yes, it is a pain to haul the big box to the store, but it ends up saving you time and aggravation. Good luck!
  • Andi172 Level 1 Level 1 (0 points)
    Hello,

    I had the same problem with my iMac 21.5" (Mid 2010) which I own since one month.
    At the beginning the SD cards were mounted without problems but suddenly they have only been recognised after reboot.

    After wasting several hours with SMC reset and checking for software problems I remembered that most of the readers have a switch inside the slot which "tells" the OS that a card has been inserted. Seems that it failed to work due to dust or it simply got stuck.
    In my iMac the switch is located in the upmost back corner of the slot. Carefully moving it slightly several times with a toothpick helped. Now the cards are mounted immediately again.
    So this is definitely a hardware problem! Stop waiting for a software fix which will never come. Better ask AppleCare to replace the reader.
    If you want to fix it like me, be warned: There is a high risk to bend the contacts which makes the reader completely unusable and maybe destroy your iMac.
    Don't try it if you have no experience with electronic parts.

    After changing two iMacs before due to inacceptable quality problems I now want to wait if it fails again before I call AppleCare a third time.

    In general I get in doubt if the iMac is worth the money you have to pay for it.

    Regards
    Andi172
Previous 1 2 Next