Skip navigation
This discussion is archived

iTunes will not eject my iPod

2623 Views 4 Replies Latest reply: Apr 3, 2010 12:59 PM by atrament RSS
atrament Calculating status...
Currently Being Moderated
Feb 28, 2010 10:57 AM
every time I try to eject my iPod when I'm in iTunes, not only do I get that message that says it "contains files in use by another application" when I have no other applications running, but it also thinks I'm trying to eject a CD instead of the iPod, and I get a message saying "there is no disc in drive F, please insert a disc".
I have reset the iPod and even re-downloaded and re-installed iTunes but it's still doing the exact same thing.
160gb classic black, Windows 7
  • colz Calculating status...
    Currently Being Moderated
    Mar 6, 2010 4:21 AM (in response to atrament)
    this is happening to my ipod right now. i would eject my ipod and it would eject properly then after some time i ejected it and then the message there is no disc in drive f. poppped up. i'm not sure but the last time i ejected my ipod, i didn't eject it from itunes, just in the safely remove icon. dunno if that's the reason but that's the only thing i could think of.
    Windows XP
  • buddawave Calculating status...
    Currently Being Moderated
    Mar 6, 2010 5:41 AM (in response to colz)
    I have the same problem. I have found that i have all of my Applications folder stored in my iPod memory. Finder cannot see my iPod although it is visible on my desktop and iTunes.I cannot eject the iPod at all. I have read up on everyway possible and all has failed. I end up having to unplug it "live" and then of course the eject warning appears....

    I think i finally got the iPod to begin deleting all that is in the Trash folder belonging to it. I had to uncheck the "show message when emptying trash" in Advanced in Finder preferences. There are nearly 600,000 files to delete and it's taking forever....

    I have tried to restore the iPod also but message says again that it's in use by another application een when i have everything closed.
    I am going to try to restore again if i get the trash to delete.
    If anyone can help please do. I would appreciate it a lot. This is driving me mad.

    Thank you so much
    Macbook, Mac OS X (10.6.2), 250GB HD, 2GB RAM
  • wolfe426 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 23, 2010 10:06 AM (in response to buddawave)
    I'm getting this same error, as well.
    PC, Windows XP

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.