Previous 1 2 3 Next 31 Replies Latest reply: Mar 18, 2012 7:04 AM by · Timo · Go to original post
  • kodiak71 Level 1 Level 1 (0 points)

    I found this solution to be the easiest - I apologize ahead of time for the domain name.

     

    http://appleslut.com/blog/mobileme/ical-duplicates

     

    Good luck!

     

    Darin

  • maxintaft Level 1 Level 1 (0 points)

    So I just did something that seems to have worked.  I know this thread is old, but maybe this will helps SOMEONE.

     

    If you aren't attached to ha ving your calendar sync with MobileMe do this on your iPhone:

    Settings -> Mail, Contacts, Calendars -> MobileMe account -> Calendar Sync Off

     

    Just to make sure it gets rid of duplicates do this in iTunes:

    Plug in your iPhone -> Click on the phone in the Devices list -> Click on info at the top of the screen -> scroll to the bottom to Advance and under "Replace information on this iPhone" click calendars.

     

    Fixed the problem for me!

  • smaxfield3 Level 1 Level 1 (0 points)

    How can this problem not be fixed and addressed by Apple yet?

    It's killing me and making iPhone and home iCal unuseable.

    Had the "genius" fix it at Apple store...worked for one day and is now back with a vengance.

     

    Hundreds of repeats on random events in different calendars. Can't delete them all.

    I don't use Mobile Me even. Ready to go back to Outlook and PC. So many iMac issues keep coming up and slowing me down. Programs are not as friendly and smooth as advertised. Extremely frustrated. iCal Help is no-Help.

     

    Help.

  • NYYN1 Level 1 Level 1 (20 points)

    I noticed the same problem on my older calenders.  I tried fixing it manually only to have the problem recur with syncing.  I did a google search and found a free software, iCal Dupe Deleter.  It worked great.  I even donated 5 euros to the company in England.  Here is the link:

     

    iCal Dupe Deleter | nhoj.co.uk

  • relson Level 1 Level 1 (0 points)

    Hi Rosencrantz -- You may not even particularly remember your posting -- but I just wanted to thank you !! for it.  I noticed duplications of almost all of my iCal on iMac and iPhone -- Very annoying, yes!  I spent two hours with apple help -- two techs and a senior tech.  Nobody could solve it.  Yours worked.  I am very grateful.

    So now I'm de-dup'ed on the iMac.  They're all still Dup'ed on the iPhone.  So when I try to sync, it wants to re-add the 150 events [yuck] back to the iMac -- so far I'm simply not syncing them. This is obviously not a long-term solution.

    Then called Apple help -- and by playing with preferences, somehow mysteriously, it got solved on the iPhone.  So for the moment, all's good.

    Thanks again.

     

    I had the same problem (running snow leopard 10.6.3 on Macbook Air). Events i created on non-shared, non-synced calendars could not be deleted or if they could they'd pop up again in seconds. And send me email reminders every 10 mins. VERY ANNOYING.

     

  • StefunnyCA Level 1 Level 1 (0 points)

    Hi!

     

    I'm hoping someone can help me.

     

    I'm having the SAME troubles that you're all complaining about. But I don't know what iSync is, and when I search for it on my computer, it doesn't show up anywhere. I don't use mobileme, etc. so I'm not sure how to uses the suggestions above to fix my issue.

     

    Does anyone have any OTHER suggestions that might work? I'm on a Macbook Pro, 2.66 GHz Intel Core i7, running OS X 10.7.2.

     

    THANK YOU SO MUCH! This is starting to wreak havoc on my business. All suggestions will be greatly appreciated!!!

  • relson Level 1 Level 1 (0 points)

    If you look back to my post right before yours, what I did was to follow Rosenkrantz from May 2010. with the restart it solved the problem on the iMac [which should be the same as your Macbook Pro.  I did not use mobileme either.  I'm still on os x 10.6 but I dont think that would make any difference.

     

    iSync should be in your application folder. 

     

    I then had the remaining problem that my iPhone still had the dupes.  I called Apple help -- and although the folks I'd talked to originally hadn't been able to solve it, this rep did by playing with the preferences on my iPhone -- but it doesnt sound like you have iPhone problems, so I'm thinking you won't have to go there.

     

    Hope this helps.

  • StefunnyCA Level 1 Level 1 (0 points)

    Cool! I'll give that a try. Sorry I overlooked that response....

     

    I also read somewhere that you had to find the VERY first event to be created and repeated and that once you "kill" the parent, the others disappear too. I tried that last night and VOILA! Everything's gone AND it seems to be sticking (at least for now?)

     

    As for iSync - nope, I don't have it anywhere on my computer -- nothing in the application folder. That's odd!

     

    Has anyone else been having THIS problem though: My iCal creates new events by itself all day long. It's been doing this for weeks. When I went scouring back through many months to try to delete the root events (per my first statement above), I noticed that I have hundreds of randomly-placed blank event boxes... EVERYWHERE!

     

    One day I opened my computer and - NO JOKE - at least 300 event boxes popped up randomly (and took 15 minutes just to close all the windows). I'd LOVE to know how to stop that annoyance... Anyone have ideas with that?

     

    Thanks a MILLION to all of you for posting such great stuff. Boy, what would we do without this forum? I've been searching for WEEKS for an answer to this seemingly-simple problem.

     

    : )

  • jhydle Level 1 Level 1 (0 points)

    I have the problem with my iphone.  I had it once upon a time with my ical, but not recently.  Any thoughts on how to fix it on the iphone would be great.  Can you tell me what they did for your prefrences?

     

    I also don't use mobileme and I don't have isync on my computer.

  • lfromnanaimo Level 1 Level 1 (0 points)

    My events started duplicating the other day when I got my iphone 4 and it was infuriating!!  I suspect that they did so because iCloud doesn't work to it's full capacity if you are using an older OS on your Mac.  The new Lion operating system has iCloud controls under system preferance where MobileMe is/was and since I have an older Macbook, I cannot run Lion.  So some stuff would sync properly between my Macbook and my iPhone and not others (iCal).  You have to get the new OS on your Mac in order to properly run iCloud or turn off the iCloud sync option for iCal, delete the duplicate posts on your computer and when you manually sync everything, replace iCal events on your iphone with the ones from your Mac (a check mark option).  Worked like a charm for me.

  • ryanp. Level 1 Level 1 (0 points)

    I was having this problem as well. It would only duplicate twice though. I simply unchecked the Calendars on my mac, and left the Icloud calendars checked. It seemed to work. Hope this helps, it was simple. I am guessing there is no need to have an "on my mac" set of calendars anymore... maybe?

  • rebecca jean Level 1 Level 1 (0 points)

    I found another solution to duplicate entries.

    I found that when I looked into my ical "File" dropdown to "New Calender".  Uncheck the duplicae account and vualla!

  • Kathyfromut Level 1 Level 1 (0 points)

    Where can I find isync?  When I do a search on my computer, it doesn't show up.

  • andyvdp Level 1 Level 1 (0 points)

    Hey, in OS X Lion we don't have Isync anymore, but I found a solution for the duplicate calender events created on the iMac. This works for my Home calender on the iMac, which is not in iCloud.

     

     

    Open Ical,

    Open folder /users/library/application support/    (via Finder Go, Go to folder...)

    Delete the folder SyncServices (there is a file called ‘local’ inside it).

    Close Ical

    Reopen Ical, for me problem is solved.

  • pfizzle Level 1 Level 1 (0 points)

    For those with Lion and iCloud, this may be caused by still having the old MobileMe calendar account active in iCal preferences.

     

    Within iCal go to iCal Menu --> Preferences --> Accounts check the Accounts List to see if you have both MobileMe and iCloud accounts for the same calendar. If so, delete the MobileMe acount using the button at the bottom of the Accounts List.

     

    This ought to fix the duplication issue.

     

    For folks who are worried about the caution message that appears when you delete, you can also simply uncheck the Enable this account checkbox for the MobileMe account. This will have the same effect, and after living safely with iCloud data for a while, you can then delet the MobileMe account when you are comfortable doing so.

     

    You will end up with something like this:

     

    Screen Shot 2012-01-31 at 12.29.47 PM.png