14 Replies Latest reply: Apr 7, 2010 10:48 AM by weeber
Bradley Harley Level 1 (0 points)
For about 3 days now the iTunes store will not load. It merely reaches this point:

+One Moment Please.+
+Connecting to the iTunes Store.+
Loading

+If iTunes doesn't open, click the iTunes application icon in your Dock or Windows Task Bar.+

(note this message is not from Safari it is from the iTunes Store window in iTunes) I have looked at the FAQ on this site and it's best suggestion was to reset the keychain which I have done, and to check that I have the latest iTunes which I think I do. (iTunes 9.0.3 (15)) Yet it has not worked.

When I try to update my applications for my iTouch it comes up with a message box saying:

+Could not complete the iTunes Store request. The store may be busy.+

+Check your Internet connection or try again later+

As I said I have waited 3 days for the iTunes store not to be busy. I'm fairly new to macs so don't even really know how to go about diagnosing the issue or posting logs for you guys to look at if that would even help?

So your advice would be appreciated.

Thanks
Brad

Macbook, Mac OS X (10.6.2)
  • Jim VanLeeuwen Level 6 (18,825 points)
    iTunes 9+ uses the Safari 4.0.3 or higher engine to connect to the iTunes Store. Check if your Safari is up to date. If you need an update, get it here (be sure to tick the Snow Leopard version): http://www.apple.com/safari/download/

    Also, check in Safari > Preferences > Security and check that your cookies setting is either Always or Only from sites I visit.


    If your problem still persists, look at this document for some solutions: iTunes for Mac: Possible iTunes Store errors, http://support.apple.com/kb/HT1412
  • Jason Bracy Level 1 (55 points)
    I started getting that error today on my MacBook Pro as well. It works from my iMac, so it's not an ISP issue. My iMac is hard wired to the Airport Base Station, and my MacBook pro is connected via Airport. So it could be a base station thing. I need to do a little more trouble shooting.
  • Bradley Harley Level 1 (0 points)
    Thanks for your advice there. I did check Safari and I do have the latest version.

    I also went through the relevant details of the other link you gave me & nothing really applied.

    So I am still at a loss. You may find it helpful to know that I can't access the store through my iTouch either. (Both started at the same time) To me this would indicate that it would be a isp problem, yet I haven't changed my isp for 5 years and have been accessing the store since it existed on:
    1 my old xp machine
    2 my touch
    3 my new mac.

    But all of a sudden it just stopped.

    Any suggestions on how to diagnose this problem?
  • EJM99 Level 1 (0 points)
    I have the exact same issue ever since I tried to open a link to an Ipod APP on a film trailer website - any assistance that anyone can provide would be really helpful as I have not been able to get into ITunes store for a week now
  • Jason Bracy Level 1 (55 points)
    OK I think I figured it out. Tried another account on My MacBook Pro and it worked fine. So it's not a network or Firewall issue. I ended up deleting a bunch of preferences. Anything named "com.apple.iTunes.*" in both "~/Library/Preferences" and "~/Library/Preferences/ByHost"

    Seems to be all good now.
  • Bradley Harley Level 1 (0 points)
    Excellent thank you,

    Though a note to others that may try this. A side effect seems to be that it messes with audio books for some reason? They didn't appear in iTunes. Easy fix though, just add them again!

    Thanks a heap for your help
  • deckard97 Level 1 (0 points)
    It seems you need to trash "com.apple.iTunes.plist" which contain most of iTunes' preferences. Don't know what happened to me but I was cut off the iTunes store before I trashed that pref file.
  • NeL2ism Level 1 (0 points)
    Where can i find the bunch of preferences i need to delete? I have the same problem of my iTunes store not loading. and my iPod touch seem to be unable to sync or be detected by the iTunes, which is weird. Please help. Thanks
  • Wellington Ferreira Level 1 (0 points)
    That worked for me, thanks!
    The easiest way to find that line is using Spotlight. Just highlight the com.apple.iTunes.plist, click with your right click option (or copy and paste on spotlight). It will find it, u ask to find in on Finder and delete it.
    Done. Itunes store came to life again!
    Thanks deckard97.
  • it's silver and pretty Level 1 (0 points)
    I am having the exact same problem. I have I have disable the parental controls and can only get on to iTunes U which is of no use to me what so ever. Then when I try to log in it says 'error 11556'. I have no idea what to do. Can anyone help?
  • KSparks Level 1 (0 points)
    Let me guess, was it Hot Tub Time Machine? B/c that's when my problems started, when I followed the link on that movie's website for their album on iTunes! I haven't been able to get into the store since, and the store won't even pull up the movie's soundtrack.

    I just get the "One Moment Please..." screen.

    I saw the fix below about trashing the iTunes profile, but if I'm on a PC, how do I do that? Guess I could just search for the file?
  • clarclar Level 1 (0 points)
    Mac OS X:

    Quit iTunes.
    Open Terminal (found in your Applications folder).
    At the command prompt, type:
    defaults delete com.apple.iTunes storefront

    Press return.

    seems to work...
  • JRowing Level 1 (0 points)
    Thank you very much.

    deleting the com.apple.iTunes storefront via command worked like a charm
  • weeber Level 1 (0 points)
    I have Windows 7, but my problem was old proxy settings in IE(I use FireFox).
    Now iTunes store load and I can activating my iPhone.