6 Replies Latest reply: Jun 12, 2010 4:26 PM by bolsen007
cmmagnon Level 1 Level 1 (0 points)
My macbook has suddenly stopped letting me click on anything with both the trackpad and physical button. I can still move the mouse around the screen, I just can't click anywhere. I tried using a USB mouse and got the same response, so I think it must be a software problem. I reset the PRAM and SMC - does anyone have any other ideas?

macbook, Mac OS X (10.4.11)
  • iyacyas Level 4 Level 4 (1,535 points)
    Will it not let you click or can you not open things that require a double click?

    What mouse are you using? Is it bluetooth or USB?

    Make sure that in system prefs/mouse & trackpad you uncheck the ignore trackpad when mouse is present.
  • cmmagnon Level 1 Level 1 (0 points)
    It won't let me click on anything. The mouse that I tried to use was a USB mouse. I'll try to change those preferences, I just have to figure out how to do it without a mouse.
  • iyacyas Level 4 Level 4 (1,535 points)
    Try a safeboot into safemode and see if the mouse and/or trackpad works there.

    http://support.apple.com/kb/HT1455
  • elzzz Level 1 Level 1 (0 points)
    I have the same problem on my MacBook. Weirdly, the right mouse button will work on a USB mouse, but nothing else. The trackpad button won't work. I started in safe mode, and the problem is still there. I started from the Install disk, and the problem was still there. Could this be some bizarre motherboard issue? This happened after plugging in a new mouse (Kensington Ci20 optical) for the first time.
  • Go1di Level 1 Level 1 (0 points)
    I have the same issue. It started mid-session. I can also use a usb mouse for right-clicking only, which is useless. Does anyone have insight as to the cause? I'd noticed recently that the trackpad would seem to freeze for a few seconds every now and then. Did you have this before it went down completely?
  • bolsen007 Level 1 Level 1 (0 points)
    I have the same issue. The cursor will move, but it won't click and when I plug in a usb mouse the cursor moves and the right click work, but the left click won't work. I was wondering if it is a software or hardware issue so I did screen sharing with my iMac. The mouse works fine so I think it is a hardware issue, but that is all I know.