Skip navigation
This discussion is archived

MAC address and wifi

4988 Views 14 Replies Latest reply: Mar 15, 2010 8:03 PM by William Kucharski RSS
Bluephish Calculating status...
Currently Being Moderated
Mar 8, 2010 10:17 AM
I just bought a MacBook Pro. It was set up at the shop.

When I brought it home, the MAC address showed up as f8:1e:df:e2:d6:71

My Dlink router says it is an invalid address. I've never had the problem with my other Macs and iPod Touches on my home network.

Any idea how I can make it a valid address?
MacBook Pro, Mac OS X (10.6)
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Mar 8, 2010 12:20 PM (in response to Bluephish)
    Re-power the router. Turn it off, let it sit for a minute and then power it back on. Post back the results.
     MacBook Pro 2.8 Ghz 15" / 4 Gb Ram, Mac OS X (10.5.8), iPhone 3GS
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Mar 8, 2010 5:31 PM (in response to Bluephish)
    Are you connecting via ethernet or airport?
     MacBook Pro 2.8 Ghz 15" / 4 Gb Ram, Mac OS X (10.5.8), iPhone 3GS
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Mar 8, 2010 5:56 PM (in response to Bluephish)
    So you are having issues connecting to the router?
     MacBook Pro 2.8 Ghz 15" / 4 Gb Ram, Mac OS X (10.5.8), iPhone 3GS
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Mar 9, 2010 2:57 AM (in response to Bluephish)
    "When I go to my Dlink page to allow MAC address, it says my MAC address is invalid and will not allow me to add. "

    You should need to do this unless you are set up to deny access to every MAC address except what you choose. Why are you set up that way?
     MacBook Pro 2.8 Ghz 15" / 4 Gb Ram, Mac OS X (10.5.8), iPhone 3GS
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    Mar 9, 2010 2:58 AM (in response to Bluephish)
    "Does it also matter that is says my Airport has a self assigned IP address? And will not be able to connect to the internet"

    It means you are not connected to the router or any network. You need to reconfigure the router. Is there a setting to bring it back to factory settings?
     MacBook Pro 2.8 Ghz 15" / 4 Gb Ram, Mac OS X (10.5.8), iPhone 3GS
  • Retired Engineer Level 4 Level 4 (2,710 points)
    Currently Being Moderated
    Mar 9, 2010 4:08 AM (in response to Bluephish)
    You can determine your Airport ethernet MAC address from System Preferences -> Network.
    f8 in the first field seems suspicious. The first two or three fields specify the manufacturer of the hardware circuitry that was installed in the MBP. (Apple is not the manufacturer).
    Macbook Pro, Mac OS X (10.5.8), 15", 2 GHZ Core Duo CPU, 2 GB RAM, 100 GB Hard Disk
  • Duane Level 10 Level 10 (117,955 points)
    Currently Being Moderated
    Mar 9, 2010 8:27 PM (in response to Bluephish)
    The best thing is to disable MAC address filtering. It adds no security to your wireless connection. The MAC addresses of connected clients are easily captured and cloned. The best wireless security is WPA2 with a long non-dictionary password.

    If you are unable or unwilling to disable MAC address filtering, ensure that you are NOT entering the colons (':') when you enter the MAC address. You should only be entering f81edfe2d671 NOT f8:1e:df:e2:d6:71
    MacBook Pro 2.8 GHz 15" 4GB, Mac OS X (10.6.2), iMac Alu C2D 2.4 GHz 24" 4GB and 20" 2GB, iBook G4 14" 1.42 [1.5GB]
  • Duane Level 10 Level 10 (117,955 points)
    Currently Being Moderated
    Mar 9, 2010 8:29 PM (in response to Retired Engineer)
    f8 in the first field seems suspicious.


    It is the same for my MacBook Pro.
    MacBook Pro 2.8 GHz 15" 4GB, Mac OS X (10.6.2), iMac Alu C2D 2.4 GHz 24" 4GB and 20" 2GB, iBook G4 14" 1.42 [1.5GB]
  • William Kucharski Level 6 Level 6 (14,425 points)
    Currently Being Moderated
    Mar 15, 2010 8:03 PM (in response to Bluephish)
    It's likely the D-Link firmware has a bug.

    For some reason, many manufacturers "assumed" that MAC addresses needed to start with "00." That's very wrong.

    You can see the manufacturer/MAC address mappings for yourself here.

    Of note:

    <pre>
    F8-1E-DF (hex) Apple, Inc
    F81EDF (base 16) Apple, Inc
    1 Infinite Loop
    Cupertino CA 95014
    UNITED STATES</pre>
    Quad 2.5 GHz G5, 5 GB | 15" 2.6 GHz MBP Penryn, 4 GB | 1 TB Dual-Band TC, Mac OS X (10.6.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.