Previous 1 2 Next 18 Replies Latest reply: Mar 15, 2010 6:07 AM by janne
janne Level 1 Level 1 (0 points)
Hello,

Opening of tabs is very slow despite high speed broadband (actual downloading speed >50 Mbit/s). First page opens relatively quick but the other ones take minutes. It even happens that they don't open at all with the message "can't find the page". If I try to open such a page directly it opens at once (no problem). I have the same problem with Firefox. I have tryed the following:

reset Safari
reinstall Safari
reinstall Snow Leopard

I have an iMac 2,66 Ghz intel Core 2 Duo, 2 GB internal memory, Safari 4.0.4 and Snow Leopard 10.6.2.

Any suggestions?

iMac, intel, Mac OS X (10.6.2)
  • Carolyn Samit Level 10 Level 10 (95,985 points)
    Hi and Welcome to Apple Discussions...

    Try maintenance...

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Go here for trouble shooting 3rd party plugins or input managers which might be causing the problem. Safari: Add-ons may cause Safari to unexpectedly quit or have performance issues

    Since you are running Snow Leopard, *make sure Safari is opening in 32-bit mode, not 64.* Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Also, (in that same window) *make sure Safari is NOT running in Rosetta.*

    

Web pages now include a small icon or 'favicon' which is visible in the address bar and next to bookmarks. These icons take up disk space and slow Safari down. It is possible to erase the icons from your computer and start fresh. *To delete Safari's icon cache using the Finder, open your user folder, navigate to ~/Library/Safari/ and move this file "webpageIcons.db to the Trash.*








    Carolyn
  • janne Level 1 Level 1 (0 points)
    Many thanks for your quick answer!

    Due to your suggestions I have done the following:

    1. Empty Safari Cache

    2. Reset Safari (the 5 top buttons)

    3. Removed 3rd party plug-ins

    I have kept the folowing Internet plug-ins unchanged:

    AdobePDFViewer.plugin
    Disabled Plug-Ins
    DRM Plugin.bundle
    EPPEX Plugin.plugin
    Flash Player.plugin
    flashplayer.xpt
    Flip4Mac WMV Plugin.plugin
    Flip4Mac WMV Plugin.webplugin
    iPhotoPhotocast.plugin
    JavaPluginCocoa.bundle
    Quartz Composer.webplugin
    QuickTime Plugin.plugin
    Silverlight.plugin

    PersonalPlugin.bundle
    PersonalPlugin64.bundle
    RadioURL.bundle
    RealPlayer Plugin.plugin

    Can any of these cause the problem?

    4. Changed Safari to 32-bit mode

    5. Moved "webpageicons.db" to the Trash

    After done all this and a restart, the problem is still there. Furthermore, I have the same problem with Firefox. It seems to be a common problem!?

    Thanks for your interest.
  • janne Level 1 Level 1 (0 points)
    Hello again!

    I have also tested to connect my iMac directly to Internet (not via wireless network, Airport Express) without any positive result. The problem is still there. I also tried my MacBook and it has the same problem. Finally, the problem is the same for all tested browsers (Safari, Firefox, Google Chrome).

    Very greatful for help!
  • keats2010 Level 2 Level 2 (285 points)
    Hi, try removing these plug ins

    Silverlight.plugin
    iPhotoPhotocast.plugin
    DRM Plugin.bundle
    EPPEX Plugin.plugin

    See how it goes and if it improves, then reintroduce them one by one and see if one or more are the culprits.

    Good Luck
  • janne Level 1 Level 1 (0 points)
    Hi,

    Thanks for your advice.

    I have removed the plug-ins you suggested and restarted the computer. Unfortunately, the problem is still there (the same with Safari, Firefox and Google Chrome).
  • janne Level 1 Level 1 (0 points)
    Hi again,

    I have changed DNS to Open DNS and Google DNS and the problem is still there. My actual broadband speed is >50 Mbit/s with wireless network and ca 80 Mbit/s with direct connection. Despite the high speed is the opening of tabs very slow. It often resultat in the message "the page could not be opened". The problem is the same independent of browser (Safari, Firefox, Google Chrome).

    Thanks for your help!
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Hi Janne

    have you tested in a new user account?

    Reset your modem/router?

    created a completely new network location?

    Have you any internet security software? even if it's supposedly disabled?
  • janne Level 1 Level 1 (0 points)
    Thanks for your answer!

    I have reset my modem/router without any positive result.

    I have no security software installed.

    Which user account do you mean? Mac user account or internet supplier account?

    What do you mean by "creating a completely new network location"?

    Thanks again!
  • Davis1 Level 1 Level 1 (0 points)
    I wrote a reply about 20 minutes ago but after waiting for Safari for about 10 minutes to load the page I had to shut down my computer and am now I am on my HP laptop which is now 100 times faster then my mac (can't believe I am saying that). This is very frustrating as I have the same issue with Safari, also tried Firefox and Google Chrome with the same slooooooooow results. Can't wait to here what the fix is, sure would like to use my macbook again one day.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Hi

    I meant a new user account on your mac computer - via System Preferences-Accounts.

    a new network location can be made in System Preferences-Network

    ah , and I see now you've eliminated the router/modem, since the HP computer works well.
  • janne Level 1 Level 1 (0 points)
    Hi,

    I have tested a new user account and a new network location without any positiv result. The problem is still there.

    Thanks anyhow!
  • MisterMojo Level 1 Level 1 (0 points)
    Janne, Safari has been acting that way on my iMac for months... I suspect that a Safari update is to blame but I cannot say for sure...

    The only "fix" that I have found is to click my "First Thing" bookmark as soon as I get up and then I eat breakfast. By the time I return most tabs have loaded.

    It isn't perfect but it beats wasting a bunch of time trying to fix the unfixable...
  • janne Level 1 Level 1 (0 points)
    Hi,

    I am not sure that Safari is the problem. I have the same problem with Firefox and Google Chrome.
  • andyBall_uk Level 7 Level 7 (20,495 points)
    Hi again

    ok, there are some network config files which might affect speed, but really... creating a new network location should get round that - I don't have 10.6.x but on 10.5.8 I'd try trashing

    /Library/Preferences/SystemConfiguration/com.apple.network.identification.plist

    /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist






    Did this modem/router & mac combo ever work at decent speed? have you tried any other macs on it?

    what make/model is the router/modem?

    if you run a web based speed test - do you see good results in the first tab, and not subsequent ones? What results do you see for up/down & ping?
Previous 1 2 Next