13 Replies Latest reply: Jul 10, 2010 7:40 AM by Dedalus2011
makkusu Level 1 Level 1 (0 points)
hi everybody! first of all sorry for bad english, i'm italian...

i own a macbook pro 15' late 2008 with leopard (10.5.8); my sister owns a macbook pro 13' late 2009 with snow leopard (10.6.2).
we used to connect one of our mac to the internet with a internet key and connect the other one to the first using internet sharing via airport.

it is about a week that internet sharing gives problems (neither I nor my sister have not changed the settings): the mac with the internet key works just fine, you can use internet and activate internet sharing; when you try to connect the other mac to the first by airport, it keeps the connection for about 5-10 seconds, then an exclamative mark appears on the airport icon and if you click on it there is a warning saying "no internet connection" as you can see below:
http://img203.imageshack.us/img203/5044/immagine5k.jpg
("macbook pro" is the network i created with my mac; i took the screenshot on my sister's mac after trying to connect it)

when this happened for the first time, i looked in System preferences > Network; clicking on "Airport" i could see "Airport has an autoassigned ip and may not be able to connect to the internet" (this appeared on both mac when they where connected)
when i saw it i went on "Advanced" and i set manually the ips (192.168.1.1 for my mac, 192.168.1.2 for my sister's)
after this the writing changed to "Airport is connected to macbook pro with the IP address 192.168.1.X" (the X was 1 for my mac, 2 for my sisters)

i tried almost everything, i deleted some .plist files in library/preferences/systemconfiguration as written in some thread on apple forum; i deleted the airport system preferences and re-introduced them correctly, i tried the same on my sister's mac but it still don't work.

the key can't be the problem because it always worked and it still work for the mac directly connected. i read in internet that the "exclamation mark problem" is quite common for snow leopard user and many of the thread on apple forum were recent (january-february-march 2010).

may the problem depend on some updates? i tried to update my and my sister's mac after the problem came up but it still don't work.

please, help me...!!

MacBook Pro 15' late 2008, Mac OS X (10.5.8)
  • WallStreetShari Level 1 Level 1 (0 points)
    I don't know if this is the same thing. I got a new Macbook Pro and have had the same problem with the exclamation point through the airport icon. On numerous phone calls to Apple I have been told it is a router problem. I have not yet had a chance to go out and buy a new router to see if this is correct. It is very annoying not to be able to get the internet.
  • makkusu Level 1 Level 1 (0 points)
    probably it is similar but i don't think it is the same problem. i used the internet key for about two months before happening this...! and i am sharing the connection between two mac, not connecting to a router/wifi hot spot.

    thank you for your answer, however.
  • makkusu Level 1 Level 1 (0 points)
    ...no one knows how i could solve this problem??
  • dinsky Level 1 Level 1 (10 points)
    my colleague is having the same problem. there are 3 Macs in my office, 2 macbooks and 1 macbook pro. sharing internet connection between the macbook have always been okay, but never worked with the macbook pro. we tried to restart the one that shares the internet, and the macbook pro, but still didnt work.
    until we tried these step (we dont really know what we were doing, so for those who understand, maybe the solution we offered is not so efficient, but hey... it works for us, hope will do the same for you)
    open keychain access and delete all password information of the wifi network that you want to connect to.
    make sure you are not connected to the wi-fi that you want to connect, then open system preferences>network>airport>advanced, on the preferred network delete the wifi that you want to connect.
    then still on the preferences>network>airport>advanced open the TCP/IP, change from manual to DHCP, and to make sure it'll work check the DNS in other computer within the network you want to connect to, and duplicate it but make sure to put different number on the last digit.
    okay, that's all... hope it can help
  • makkusu Level 1 Level 1 (0 points)
    i've tried most of these things separated so i don't know if it will work but thank you for the help; i will try your complete solution when i will be back home.
  • makkusu Level 1 Level 1 (0 points)
    man, i just can say that i love you!!!!! it works as two weeks ago! perfect!!!!

    thank you!!!!!!!
  • chip grabow Level 1 Level 1 (25 points)
    On what machine did you make these changes, the client computers or the computer that was sharing its internet connection?
  • Fish Party Level 1 Level 1 (0 points)
    Just chiming in to say that, while I'm not networking with other computers, the same thing is happening to me. It seems that it only happens with wireless networks that require a password, which unfortunately my home network does. Everyone else in my household can get on the network just fine, and even my older macbook has no problems, but it's only my new macbook with 10.6 that gives me the exclamation point of doom.

    Looking back through older threads, it seems this problem has been happening since last September. Has there really not been a patch or anything released yet? It seems weird that apple would let a common bug with either 10.6 or the new airport go that long without any sort of solution.

    For the record, I've tried pretty much every solution in regards to deleting the key, removing the .systemiuserver files in the preferences folder, reconfiguring the network numerous times, switching all of the network settings around. Nothing has worked so far. I'd really hate to have to return my new computer, but if this is a common bug with this generation, I'm probably best sticking with my old macbook.
  • rob_trawick Level 1 Level 1 (0 points)
    I have three computers running 10.6 that share the wifi in the house and after a period of a couple of days the computers will all get the exclamation point. The few windoze computers never get kicked off so it seems to be a software problem not a router problem. To fix it what I do is go to the router, unplug it, replug it in and everything is right with the world for a day or two until it's time to reset the router again.

    I did try using a new router that I purchased and it did the exact same thing so I returned it.....the problem is the software.
  • urmysquishy Level 1 Level 1 (0 points)
    I think I may have a simple solution...

    My problem was that all of a sudden an exclamation mark would show up in my aiport icon. Tried restarting (airport and my computer), doing the power cycle thing, restarting everything individually, resetting PRAM (I heard it worked for someone else, but i think i did it wrong so that obviously didn't work), checking my computer for updates, hooking up my computer to the ethernet and copying down the IP#, router etc... before deciding to call comcast I wanted to see what i could do with the router settings (since i could connect through the ethernet). Since I didn't know what to look for and everything seemed to be on default settings I decided that now would be a good time to switch from WEP to WPA2 simply because I was there.

    Once I beefed up my security to a WPA2, and connected to the internet it worked right away. Apparently doing so had given me a new IP address and filled in the rest of the info - [found in the network settings> advanced> TCP/IP tab using the automatic option of DCHP - where lines were previously left blank and the IP address was screwy]

    So, I hate to admit it but it may actually be a router thing. If you can change the settings of the router, like changing the passkey from a WEP to a WPA or WPA2 it may help. It worked for me!

    p.s. this may not work for very many of you but it was a random problem for me and this fixed it so it may work for someone else - especially if you own the router you are having a problem with. Oh yes, should it help I could connect to my neighbors wireless network.
  • John Allen2 Level 1 Level 1 (35 points)
    I got the Airport exclamation mark today for the first time at a wireless hotspot. I had never seen it before so I turned my airport on and off 5 or 6 times and finally everything started working.

    Running 10.6.3.
  • tenderforever Level 1 Level 1 (0 points)
    I'm having the same problem. Tried every single solutions that was offered on the forum and it's still there. Works fine anywhere else, but not at my office anymore. Other computers connect just fine. Mine used to work just great. The exclamation mark showed up after trying to set up my airport express base and i have been unable to connect ever since.

    HELP!

    Has anyone heard of an update / solution for us?

    Thanks
  • Dedalus2011 Level 1 Level 1 (0 points)
    Deleting the preferred networks in

    System preferences>network>advances worked for me
    (make sure you unlock the padlock first or they will be grayed out

    Then I changed tcp/ip configure ipv4 to "manually" and it worked
    I see now that it changed back to "using dhcp"