Previous 1 2 3 4 5 6 Next 77 Replies Latest reply: Aug 7, 2015 10:59 AM by NMMichael Go to original post
  • Marco9999 Level 1 (0 points)
    I have the same problem. Yesterday my iphone4 and my ipad were working very well
    and now it's connection to server failed. Those who have Blackberries seems to have no problems (IT supported). I hope they didn't block us out.
  • Lawrence Finch Level 8 (35,018 points)
    Marco9999 wrote:
    I have the same problem. Yesterday my iphone4 and my ipad were working very well
    and now it's connection to server failed. Those who have Blackberries seems to have no problems (IT supported). I hope they didn't block us out.

    Ask your IT department. Blackberries don't connect directly to your mail server; they connect to separate servers provided by RIM. So you cannot conclude anything from the fact that they work.
  • TenaciousIT.Sara Level 1 (0 points)
    I seem to be in the same boat here...

    I have an SBS 03 server running exchange for a small organization.

    One of my users has an iPhone and we managed to get it to sync with the exchange server no problem. It's been running fine for over a year now and we've even replaced the phone itself a few times without problems.

    Now this same user bought an iPad. I got things setup on the iPad the same way as the iPhone and NO LUCK! It will verify the exchange account every time with no problem but when I open the mail program it just says "Cannot get mail. The connection to the server failed"

    Silly me, I'm used to error messages that actually explain the error. Does anybody know what the problem with this is?

    I have tried this with and without the security certificate installed (I've reset all settings on this iPad about 5 times already just to be sure). I can access myorganization.com/OMA from the iPad. I have restarted IIS.

    The worst part is that it works fine on the iPhone but not on the iPad!

    Thank you all...
  • yang11 Level 1 (0 points)
    hi

    I just got an iphone 4, then I got this connection problem. the servers are w2008 dc and exchange 2010. there are errors logged on the server about an activesync problem.

    after searching the internet, I ticked "inherit ..." refer to xy11.blogspot.com
    then use upn as the username.

    then emails are showing up in the iphone

    hopefully this helps.

    Michael
  • Audihertz Level 1 (0 points)
    I've looked through similar problems and tried many solutions with no success. Here's the situation...

    I personally have a 2nd generation iPod Touch (iOS 4.1) that I setup email access up on for my corporate email system, running Exchange 2003 with OWA access. This worked and continues to operate as it should. Contacts, calendar, and emails sync as well as access to our Global Directory.

    Our company just purchased two, brand new iPhone 4 (iOS 4.1) devices in which the exact same setup was applied for email access, the account verifies successfully, but then the Exchange account on the iPhone 4 does not sync, pull in any emails, or allow to send any emails.

    This tells me that this must be a iPhone 4 + iOS 4.1 specific issue. They couldn't have changed anything server side as my iPod Touch continues to function normally as do previous generation iPhones that other staff members have, running the same, latest version of iOS.

    Does this give anyone else some clues as to what my solution might be or where I should be looking?

    Any help is greatly appreciated as the company also is porting me from Blackberry to an iPhone 4 in the next few days.

    Thanks!
  • oimanu Level 1 (0 points)
  • PR@Ecalpemos Level 1 (0 points)
    Sugar Boy, you sure are sweet! Did as your article said and it is working like a dream thanks
  • Crammy Level 1 (0 points)
    This worked like a charm, thank you so much!
  • moreins Level 1 (0 points)
    this worked for me!
    thanks
  • Talbragar Level 1 (0 points)

    I am having the same problem on my iPad, this worked perfectly but now will not access my email. I can still access by logging onto gmail directly. Does anyone have the solution?

  • Klstclair Level 1 (0 points)

    I am experiencing similar behavior with iPhone 3G software 4.2.1. I disabled the Wi-Fi network that I have been using to sync with my Exchange 2010 Account for a year now and using 3G I connect fine to my Exchange Inbox. I reset the network and that did not help. As soon as I disconnect the Wi-Fi, I can connect to my Exchange Inbox fine. When I reenable Wi-Fi I get the "Cannot get mail The connection to the server failed." error.

     

    Calendar and Contacts work fine using either Wi-Fi or 3G.

  • momafromoslo Level 1 (0 points)

    I'm having the exact problem 'Sugar Boy' describes above with my generation 1 Ipad. The exchange account I use for work suddely stopped working. I've tried all the 'standard' solutions and have now -after Apple Support in my home country gave up- reset the pad to its factory settings. Still no joy. The account is verified (and the IT people at work swear there's no other way of connecting to the server but using the info I have provided in the set-up), but when I want to access it I get this same error message 'Cannot get mail. The connection to the server failed'. However at work we use an exchange 2003 enterprise server, sd that doesn't seem to be the problem or solution here. Any suggestions for help will be much appreciated...

  • momafromoslo Level 1 (0 points)

    By the way - all the links provided in this string seems to have expired so I can't tell if those solutions would work. Could someone enlighten me about the content of these miracle pages?

  • degraafpothof Level 1 (0 points)

    In case you can't change anything at the server side (like me) I found two workarounds. One worked with my wifes iphone 4: in settings - mail - new data (? I have a Dutch version not sure if this is the right translation) -  go to the advanced tab and change from "push"  to "fetch". Don't know why but solved it.

    On my iphone 3gs this didn't work, but when I use a VPN the problem disappears.

    Hope this works for others too.

  • Matt Wolanski Level 6 (10,255 points)

    That inheritable permissions fixed a smiilar problem for users of an Exchange 2010 Server thta I recently installed.