1 2 3 4 5 Previous Next 74 Replies Latest reply: Apr 15, 2014 7:30 AM by BGetch Go to original post
  • 45. Re: Exchange Email - Cannot Get Mail, connection to server failed
    onthow Level 1 Level 1 (0 points)

    I moved a user mailbox from an Exchange 2003 server to an Exchange 2010 server and encountered the same problem described in the original post. I tried this great tip from Sugar Boy, but it didn't fix the problem in my case. What ended up solving the problem in my case was:

     

    1. In Exchange [2010] Management Console, go to Recipient Configuration > Mailbox and double-click the user

    2. In user Properties, go to the Mailbox Features tab and select Exchange ActiveSync

    3. With Exchange ActiveSync selected, click the Disable button and then the Apply button

    4. Still under the Mailbox Features tab with Exchange ActiveSync selected, click the Enable button and then the Apply button

    5. Refresh the Exchange mail account on the iPhone

  • 46. Re: Exchange Email - Cannot Get Mail, connection to server failed
    betterfasterstranger Level 1 Level 1 (0 points)

    Thanks for this Sugar Boy, I ended up taking myself out of domain admins and checking that tickbox and finally got to the happy place. There's a technet article with a warning about using email with domain admin accounts for anyone interested here: http://technet.microsoft.com/en-us/library/dd439375(v=exchg.80).aspx I have the administrator account so my own account doesn't need elevated permissions.

     

    I also have a second mailbox from an account that was NOT a domain admin but also refused to connect until I unchecked and rechecked that inherit box. Something must be screwing up in AD with actually applying those permissiona on account creation...

     

    Such a relief! Now I can check my queue of IT jobs wherever I am. Oh noes, why did I do that?!

  • 47. Re: Exchange Email - Cannot Get Mail, connection to server failed
    Stephen Smiroldo Level 1 Level 1 (20 points)

    Same problem as others... My experience is ditto what JayUSA123 says. I'm On iPhone 4, iOS 5.

     

    Adding Exchange account verifies, but no mail in or out.

  • 48. Re: Exchange Email - Cannot Get Mail, connection to server failed
    Zalmiakki Level 1 Level 1 (0 points)

    Maybe all these tides up to a problem that we might have too many devices linked to our Outlook exchange sync. And amount of devices might depend on your company configuration. I found out that my exchange limit was 10 devices/hw ids.

     

    So I hope this could help you too:

    https://discussions.apple.com/message/16901161#16901161

  • 49. Re: Exchange Email - Cannot Get Mail, connection to server failed
    rebootinsafemode Level 1 Level 1 (0 points)

    Setup the account on the phone. You should be able to connect to the server and all but not receive any e-mails. Restart the MS Exchange System Attendant which will also restart the MS Exchange Information Store. Then restart IIS. Wait about 5 minutes after the service restarts e-mails will start flowing to your active sync account. Also make sure your server have enough cal licenses as well. Keep in mind that each device that connects to the server will need a cal license. Working on the issue for almost 3 weeks and finally got it to work after all the other failed fixes found on the web. Exchange Server 2003 does not play well with newer IOS versions.

  • 50. Re: Exchange Email - Cannot Get Mail, connection to server failed
    PantherWreck Level 1 Level 1 (0 points)

    I have three exchange accounts: Google and two different University email accounts. Using a new iPhone 4s on Verizon. The Google account worked fine out of the gate, but the university ones were both not working with 'cannot connect to server' and insistent incorrect password prompts from one of the accounts. One sets up with a blank domain and one with a domain listed in setup. One uses the full email address in the username field and one just the info before the @ sign.

     

    I deleted iCloud, deleted the non-working exchange accounts, reset the network as described in good posts above, and rebooted phone.

     

    I added both previously non-working accounts with email sync only. The number of days to sync did not matter and cannot be edited until after the account is setup anyway. When it finally worked, I got all 'checkmarks' during the last setup screen. Even after that happened, I received error messages the first three or four times that I tried to access the mail in the mail app for the new accounts.

     

    I'm nervous about re-enabling the iCloud account...

  • 52. Re: Exchange Email - Cannot Get Mail, connection to server failed
    luvmybuca Level 1 Level 1 (0 points)

    I had the same problem and  I just went to settings..reset.....reset network settings...(this will reboot the phone's wifi).  I then went back to my yahoo account and a message came up saying that I need to have a password to verify my account.  I went to settings...mail....yahoo...account..and then updated my password.  My mail works now. I hope this helps!! The first few steps I learned from someone else who posted, so thanks to them!

  • 53. Re: Exchange Email - Cannot Get Mail, connection to server failed
    Normalhepkat Level 1 Level 1 (0 points)

    I am deploying I Phone 4s to about 60 staff members at my company.   Of the 60, I have three that cannot connect to the exchange server.   These are all new phones with the same configuration.   The email configuration is being pushed down via Mobile Iron.   Also, manually adding the email profile does not work either...     This is great discussion and I will try the suggestions here.  Seems odd that most will work and a handful will not.   Im wondering if our sales rep will give us a warranty exchange if these phones will not work?

  • 54. Re: Exchange Email - Cannot Get Mail, connection to server failed
    Brian_Ragle Level 1 Level 1 (0 points)

    I thought I would toss in my $0.02 on this since I had originally found this thread after experiencing the same problem.  It turns out I had maxed the number of mobile partnerships my Exchange account would tolerate, which turned out to be 10, in this case.  To fix it, I logged into my company's Exchange webmail, look under Options, Phones, and Mobile.  I then deleted old partnerships such as a Samsung tablet I tested out one time and an old phone I once used.  Almost immediately after existing my iPad started receiving email from the Exchange server.  Hope this helps!

  • 55. Re: Exchange Email - Cannot Get Mail, connection to server failed
    MPower Level 1 Level 1 (35 points)

    What version of Exchange are you running?  I've not heard of this limit before.

  • 56. Re: Exchange Email - Cannot Get Mail, connection to server failed
    Brian_Ragle Level 1 Level 1 (0 points)

    Exchange 2010. Apparently it has to do with how many mobile devices being pushed to.

  • 57. Re: Exchange Email - Cannot Get Mail, connection to server failed
    tw_sunnie Level 1 Level 1 (0 points)

    Thanks - your Community participation fixed my issue!! 

  • 58. Re: Exchange Email - Cannot Get Mail, connection to server failed
    Eeeyup Level 1 Level 1 (0 points)

    I've seen this happen on iPhones *and* Android with Activesync.  Seems like it happens any time you move a user's mailbox or alter it's config/security in any way.  *Especially* with Exchange 2003.

     

    Try this:

     

    • Connect to the internal network over Wi-Fi,
    • Configure the Exchange account on the phone to use the internal name of the mail server, example "Exchange" (the netbios name of your internal Exchange server).  It should refresh the certificate on the phone and allow it to connect. 
    • Then, turn off Wi-Fi and use 3G to connect--editing the Exchange account on the phone to use the EXTERNAL address for sync, ie the IP external address or external DNS name ex. "mail.contoso.com"

     

    After that, it should work.

  • 59. Re: Exchange Email - Cannot Get Mail, connection to server failed
    viorelmihaila Level 1 Level 1 (0 points)

    Hello

    I have a problem with the email accounts on my iphone 4s ios 6.1.2

    I get the message : Cannot get mail connection to the server failed

    I only get this message on 3g or edge , on wifi its working perfect.

    The mail account is from yahoo

    Any ideeas why?

     

    Message was edited by: viorelmihaila