Previous 1 2 3 4 5 Next 96 Replies Latest reply: Jan 19, 2015 2:07 PM by rockcliffepark Go to original post
  • keileenj Level 1 Level 1 (0 points)
    This worked. Thank you, thank you, thank you!!
  • Blackle Level 1 Level 1 (0 points)
    Okay.
    I had the same problem.

    I tried rebuild: all my blank emailed disappeared
    I tried library/mail/envelope Index: the rest of my blank emails disappeared.

    The question is really if the emails that disappeared are still present on the computer.
    I went to ~library/Mail. Then found the POP folders where the emails have been saved to the computer. Once that is opened. It showed "Deleted messages, Drafts, Inbox, Jun, and Sent messages" this may differ from user to user. However, I clicked on "Inbox" and all my messages were there under "messages". I could open them and read them.

    Therefore, the files are not lost.

    To repair:
    1. Quit and reopen Mail
    2. File Import Mailboxes. Select Apple Mail and continue
    3. Find the "INBOX" file. ~Library/Mail/POP..../Messages/Inbox
    4. Do not open the inbox, select it then press "Choose"
    5. Those messages will now be in your MacMail Under the "ON MY MAC" heading on the left hand pannel.
    6. under "ON MY MAIL," there will be a folder titled "Import" and the "Inbox" folder is there.
    7. select all the messages from the imported inbox. Right click. Select "Move to" and select "Inbox" .. Your inbox.
    8. Repeat steps 2-7 for "sent messages" and move imported sent messages to Your Sent messages.


    If the messages are no where to be found on your computer, then the files are likely not there, and you will need to restore some files.
  • MVBA Level 1 Level 1 (0 points)
    There certainly seems to be some issue with Apple-Mail received emails. Does anyone know if Apple has commented? I have read through this thread but solutions I read seemed to be speaking of a specific server different from what I am using. Mail is fine except when received in my CRM, Goldmine. I am using a version no longer supported by Goldmine (FrontRange) and no one on forum for this version had a solution. I am able to read body of email in preview window while mail is still on server but once picked up from server body disappears. This only happens if sender in header shows Apple-Mail 94.
  • James Frew Level 2 Level 2 (275 points)
    Hi Guys.

    I have had the same issue. I also tried rebuilding the mailbox, but this simply made matters worse.
    I have not coma across any method to restore such email issues without reimporting as Apple Mail: File>Import Mailboxes>Apple Mail.

    Ultimately I was forced to import mail from my Time Machine backup.

    The lesson is clear: *BACK UP REGULARLY* AND ALWAYS KEEP YOUR *VITAL MAIL SAFE*.
  • EHill777 Level 1 Level 1 (0 points)
    Callipygian, you're a life-saver. Thanks so much for posting the answer to a frustrating problem. Shame on Apple...kudos to you!
  • rchin01 Level 1 Level 1 (0 points)
    I also have the same problem but when I look into the mailboxes most of my messages are all GONE! I'm rebuilding the messages from a time machine backup. I don't understand where the messages went. Trying to reconstruct my mailboxes before this went crazy on me. I have back ups that look fine on 12/31/2010 but after the new year something happened. I have Norton anti-virus running - wonder if there was a happy new year virus?
  • pmarciano Level 1 Level 1 (0 points)
    This solution came to the rescue. Thank you.
  • buckster Level 4 Level 4 (2,810 points)
    Just bitten by this one myself.

    Running 10.6.7 client with (Mail.app v4.5) and an IMAP account. I have 7Gb in my Mail folder.

    In Mail.app all messages are opening comletley blank. But I can see all the mails on the IMAP server using a webmail client... they are still there.

    And I can see the messages in the local Library/Mail/IMAP- folder.

    No config changes have been made.

    I tried rebuilding a couple of mailboxes, but they end up showing no messages.

    I tried this http://docs.info.apple.com/article.html?path=Mail/4.0/en/14019.html to no avail.

    Subsequently, I restored the original envelope file and IMAP- folders to the Mail folder, opened Mail.app (same problem), closed Mail.app and tried removing the Envelope Index file.

    On next open of Mail.app, the envelope index rebuilt in about 0.5 seconds. Now all mailboxes and mailbox unread-counts are blank.

    I have backups to hand and am not worried about my data (especially since it is all on the IMAP server still).,

    However, I am an admin and would love to know the cause and fix for this problem to be able to help my users if/when it happens.

    Thanks,

    b.
  • Ernie Stamper Level 8 Level 8 (37,555 points)
    I would remove the account completely in the preferences, and set it up again. But before doing that, create a New User Account, and as that New User try to set up this IMAP account and test. If not familiar with setting up a New User Account, see:

    http://docs.info.apple.com/article.html?path=Mac/10.5/en/8235.html

    This will be a useful test, and obviously is not meant to suggest a permanent switch to the New User Account, but rather a test of all the factors outside your normal User Account. It would bypass any problems in the current User Account. Keep us posted.

    Ernie
  • Sharon Hassler Level 1 Level 1 (15 points)

    Just found this unwelcome surprise today: blank emails in 5 of my most important accounts while other accounts are fine. I checked the Library/Mail/Pop-myemailaccount folder and had only six messages in each file. Tried rebuild, still only six messages.

     

    Whatever is causing this in Apple Mail needs to fixed immediately. Haven't backed up for a month so lost a month's mail. I've been removing it after a week on the server but obviously won't do that again since I can't trust email on my computer now.

     

    Having a more recent backup would have helped some but this means I have to backup every day and worry about restoring email. I have too many clients corresponding by email to have to worry about Apple Mail failing me like this.

     

    Hey, Apple guys monitoring discussions: Fix this, please! We need help.

  • thomas_r. Level 7 Level 7 (30,410 points)
    Whatever is causing this in Apple Mail needs to fixed immediately.

    This kind of behavior is caused by some kind of corruption in your Mail data files, not a bug in Mail needing to be fixed by Apple.  This thread started more than a year ago, and some solutions have been posted in it.  If you have not read and tried any, do so.  If the problem persists, start your own topic, with full details about what you're seeing and what you have tried, rather than tacking on to the end of a very old topic.

     

    Having a more recent backup would have helped some but this means I have to backup every day

    If your data has value, you should be backing up every day.  Corruption on the hard drive - which you very well may have given your problem - could be causing data to be overwritten as we "speak."  Your hard drive could fail at any time.  Theft or fire could put your data permanently beyond the reach of possible restoration.  If you don't appropriately back up valued data, you have nobody to blame but yourself when (not if) it is lost.

  • Sharon Hassler Level 1 Level 1 (15 points)

    Followup: Ha! I've been having trouble with my Mail accounts for months. Had to rebuild several times. Plus old long-deleted phantom email accounts were trying to access the server so my host company kept blocking my IP address thinking I was a hacker. (Took new com.apple.mail.plist to fix that.) At that time (over 2 weeks ago), my hosting company suggested I update email settings on all my accounts, @ instead of the old + symbol, setting a custom port (26) instead of default, etc., and my mail had been coming through just fine. Until today. Now I find in my User/Library/Mail folder, some but not all accounts have two folders for one account, one with @ and one with + and both have been storing incoming and sent messages...until today. I also discovered I had lost (blank) messages on more than the 5 accounts as I thought earlier. Oddly enough, some of the newly created folders are NOT active. Importing did NOT work so, for each account I opened the INBOX.mbox/Messages and the Sent Messages.mbox/Messages folders and dragged those files into the account folders which were active folders (had the latest file dates). Then I deleted the inactive folders.

     

    There was one account with duplicate folders that did not have any sent messages except for today so I did lose those but other than that, I think I've recovered everything. Not sure why opening my Mail Preferences and changing settings would cause this mess. If changing settings in Mail Preferences creates two folders doe one account, that sounds like a real problem to me. (BTW, using OS 10.6.7 BTW and Mail 4.5 on MacBook Pro.)

  • Sharon Hassler Level 1 Level 1 (15 points)

    Gees, Thomas, thanks for that. I don't consider a message posted April 7, 2011, to be an old message. Also, I had tried several suggestions without success before I discovered the duplicate folders. Now I'm sorry I posted that reply when I found the problem, BEFORE I saw your post. I admit when I'm wrong but I see now I shouldn't even have voiced my earlier comment.

     

    Thanks for the warning about all the terrible things that could happen to my Mac. Yes, I should be backing up every day. Yes, Apple provides the best products in the world. I hope you don't post that response to everyone who's honest enough to admit they don't back up every day or to everyone else (there were others) who thought there might be a problem for Apple to address.

     

    Thanks for reminding me that there are other forums which are much friendlier and where I will post from now on.

  • thomas_r. Level 7 Level 7 (30,410 points)

    I don't consider a message posted April 7, 2011, to be an old message.

     

    The first message on this topic was posted March 11, 2010.  Posting on a thread like this is not the best way to get your question answered, as many folks won't even bother looking in here anymore.

     

    As to the rest of your message, I'm quite impressed with the thinness of your skin if I managed to offend you.  It would probably best if you were to avoid forums in general if you can't handle that kind of response, because you could very easily have gotten far worse.

  • Jabberwooky Level 1 Level 1 (0 points)

    Thank you callipygian!

     

    I was experiencing this problem with a few of my email. In my particular situation the messages that were originally blank were imported back and now viewable, thank you so much!

Previous 1 2 3 4 5 Next