Previous 1 2 Next 17 Replies Latest reply: Oct 16, 2015 7:22 AM by mrweather
tomlocke Level 1 (0 points)
I really really really need to change my capslock key to act as control. This works fine for the internal keyboard, but is not working at all for an external keyboard.

I've tried changing modifiers other than capslock - same story - no problem on internal keyboard, no effect on external keyboard.

I've tried with both the bluetooth keyboard (3 battery version, not the very latest one) and USB alu keyboard (the full size one with the number pad). Same story.

Help!

Thanks

Tom

Macbook Air, Mac OS X (10.6.2)
  • Russell Vaught Level 1 (10 points)
    Similar problem and it used to work until I installed a new keyboard.
  • lhmpdx Level 1 (5 points)
    I've had the same problem, but just noticed that the "Modifier Keys" section of the Keyboard System Preference requires that you select each keyboard when you modify the Caps Lock to Control. Even if you've set your internal MBP Caps Lock Key to act as a Control Key, you still have to do the same thing for every additional external keyboard you attach.
  • Pen-Pen Level 1 (0 points)
    Same here on unibody aluminum macbook with 2-battery Apple wireless keyboard.

    I've gone to the Keyboard prefpane, selected every keyboard in the dropdown menu one-by-one and configured every one of them to remap Caps Lock to Control. Not only does the key not generate a Control event on the wireless kbd, it still acts as a Caps Lock. This works fine on any other keyboard I've tried: the built-in, external apple wired keyboard (w/ and w/o num keypad), and even Dell USB keyboards.

    All I want is for this wireless keyboard to behave exactly like any other apple keyboard I've used.

    UPDATE: Just tried the same configuration with Snow Leopard Server on the new 1TB macmini, and IT WORKED. I don't have any other macs handy to test, but is this a Server vs Desktop issue or a Macbook vs Mini issue?

    Message was edited by: penryu
  • rampyre Level 1 (0 points)
    For what it's worth, I had the same problem which I resolved by turning the keyboard off then on again after changing the modifier preferences...
  • charlax Level 1 (0 points)
    I have the same problem on Max Os X 10.6.4

    Unplugging the keyboard then plugging it does not change anything.

    This has work for me:

    1. Plug in the external keyboard and set the modifier keys to work correctly with the external keyboard.
    2. Change the modifier keys back to default settings. Try the laptop keyboard to insure the modifier keys work correctly.
    3. Go back to the modifier keys section and in the "Select keyboard:" drop down pick the external keyboard.
    4. Change the modifier keys to work with the external keyboard.
    5. Test both keyboards, they should now work.

    http://discussions.info.apple.com/message.jspa?messageID=8911817

    This is a very annoying bug...
  • Beisarius Level 1 (0 points)
    To ensure the swap works, and that Snow Leopard/Leopard learns the external keyboard,

    * DO NOT USE THE EXTERNAL VIA A USB HUB. THE SET UP MUST BE DONE WITH THE APPLE KB PLUGGED DIRECTLY.

    - Unplug and do changes on internal keyboard. test
    - Reboot.
    - Plug directly external KB. Do changes in the Keyboard Settings. Select External KB. Test.
    - Now, replug your external KB via a USB hub. No more issues.
  • [macnn]milhous Level 1 (0 points)
    Beisarius NAILED it! The hub does appear to interefere with changing the modifier keys. Identifying the keyboard and changing the modifiers must be done by directly connecting to the computer first.

    Thank you!
  • squidbot Level 1 (5 points)
    I just wanted to chime in that I had the same problem, and it was due to having the keyboard plugged in to a USB hub. Once I plugged the keyboard in directly to the Mac and set the modifier keys, it then behaved properly when plugged back in to the USB hub.

    I'd be tempted to say it's the fault of the hub, but it because it a)happened with three different hubs and b) OS X recognizes the keyboard type through the USB hub (even before plugging it directly in) it does seems like a bug in OS X (10.6.6 currently.)
  • maravy Level 1 (0 points)
    I had some problem too. I have macmini + al keyboard.

    Problem is solved after change keyboard plug position in the usb ports on the back side macmini.
  • dlarimer Level 1 (0 points)

    I have the same problem with my keyboard plugged into a Tunderbolt display.   Any time I 'undock' my laptop it forgets the keyboard layout.

     

    I also have the problem that anytime I undock it seems to randomly reorder my two thunderbolt displays.

  • ewise82 Level 1 (0 points)

    confirming that the USB hub also caused problems for me. Thank you for pointing out the cause of the problem. Very annoying bug. I wonder if this is fixed in Lion?

  • Christopher Shaffer Level 1 (0 points)

    I can also confirm that a Microsoft Natural 4000 keyboard plugged in to a Thunderbolt monitor using a MacBook Air with Lion does not remember the modifier key changes.

  • lockheedbird Level 1 (0 points)

    I have a similar problem though perhaps even worse.  I have my Microsoft Natural 4000 keyboard plugged into my macpro on Lion and all I need to do is to manually make my machine go to login screen by clicking on the user icon in the top right corner and then log back in.

  • Christopher Shaffer Level 1 (0 points)

    Sorry, I found a solution in another forum (can't remember where) and never returned here to post it.  I solved the problem with KeyRemap4MacBook.

     

    http://pqrs.org/macosx/keyremap4macbook/

Previous 1 2 Next