4 Replies Latest reply: May 13, 2010 8:00 AM by captain_haddock
tburch Level 1 Level 1 (0 points)
hi ALL--

hoping someone might be able to help. I put a CD (with image files) in the drive, and my computer isn't recognizing that there's something there, and stranger still, it's refusing to eject it.
is there any way to force eject something from the drive?

help?!?!

thanks,
tom

macbook pro, Mac OS X (10.5.8)
  • 1. Re: Force eject CD?
    Niel Level 10 Level 10 (242,055 points)
    Open the Terminal in the /Applications/Utilities/ folder and run:

    drutil eject

    Alternatively, restart with the trackpad button or keyboard eject key held down.

    (50746)
  • 2. Re: Force eject CD?
    tburch Level 1 Level 1 (0 points)
    thanks!
  • 3. Re: Force eject CD?
    DrBukk Level 1 Level 1 (0 points)
    I tried both your suggestions, as I have the same problem with no CD recognized and can't eject. Neither worked, but I can hear the machinery give it a try. Should I go for a repair?
  • 4. Re: Force eject CD?
    captain_haddock Level 1 Level 1 (0 points)
    Hi
    great. The drutil eject works perfectly. Also drutil tray open and drutil tray close work.
    My problem: although Terminal can open my cd drive, the eject button on my keyboard refuses to work. There is also no fading eject sign.
    Any idea on how to get the eject button back to work?