6 Replies Latest reply: Apr 17, 2010 9:20 PM by HK09
Smita Desai Level 1 Level 1 (25 points)
I just got the iPhone and am trying to set up the wifi at home. The wifi router is not set up to give out IP addresses.
The iPhone finds the SSID, it is set up as TKIP PSK. In the wifi setup, there is a check mark next to the SSID indicating that it is connected but it is not getting IP address. There is nothing in DHCP screen of iPhone. Both my laptop and Blackberry connect to wifi without any trouble.

At home, I get very little cell signal (ATT) and in my office the signal is almost nil. But I would not think that would be necessary for wifi to work.

I have tried everything including resetting the network on iPhone but nothing seems to help. Does anyone have any ideas?

Thanks.

Windows XP Pro
  • Lawrence Finch Level 7 Level 7 (30,615 points)
    You said the router is NOT set up to give out IP addresses, so why are you surprised that it didn't give one to your iPhone? If you have fixed IP addresses for your other devices you must manually enter one for the iPhone also. You should not set it up as DHCP (which is the router server that assigns IP addresses); rather, it should be set to STATIC if your router's DHCP server is turned off.
  • Smita Desai Level 1 Level 1 (25 points)
    Because it is connected to a wired router which is a NAT/DHCP router.
  • Lawrence Finch Level 7 Level 7 (30,615 points)
    First, try rebooting the routers (both). Sometimes the DHCP daemon crashes. If that doesn't fix it update the router's firmware to the latest version.
  • Smita Desai Level 1 Level 1 (25 points)
    It works with static IP address, but cannot seem to take DHCP. My Blackberry and a laptop both work fine, so nothing wrong with the routers.
  • HK09 Level 1 Level 1 (0 points)
    I've been experiencing this same exact issue as well. It only happens at home where I have a Dlink dir 655 wifi and a Cisco 831 router. The wireless associates and I can confirm it in the logs. In fact, the Cisco even logs that an IP address was assigned. Turned on debugging on the Cisco and noticed it acknoledges the dhcp requests from the iphone and in turn sends a notification of assignment. I'll have to check the RFC on that one, not sure what a notification of assignment means for dhcp.

    Here's the real kicker, my wife has the same exact iphone and doesn't have a single problem. I have a similar setup at work (dlink dir 655 as a wifi access point to corporate network) and have no problems there.

    I'm going to try clearing that IP binding in my cisco and see if that helps the problem.
  • HK09 Level 1 Level 1 (0 points)
    Ok, I cleared the binding and it started working again. Checked on the notification of assignment in the rfc, must be an internal Cisco logging tag. Anyways, it works now. This happens time to time for me. Not sure what's fixed it in the past but now it works.