5 Replies Latest reply: Mar 17, 2010 1:05 PM by btabz
btabz Level 7 Level 7 (26,635 points)
I have been using Apple Mail for years, and I recently added a signature for all of my outgoing emails. It seems as though some clients reformat my message when it comes in and the main message font gets standardized (something like Arial 12 or Times New Roman 12).

However, my signature does not get reformatted, and is left looking huge when compared to the rest of my email. My signature is formatted something like this:

**Message Content**

--
btabz

Any ideas as to how to address this? I have tried changing the message font size and also checking and unchecking the box to format my signature as the default message font.

Thanks!
btabz

13-inch MacBook Pro; iPhone 3G, Mac OS X (10.6.2)
  • Tom Gewecke Level 9 Level 9 (74,465 points)
    some clients reformat my message when it comes in and the main message font gets standardized (something like Arial 12 or Times New Roman 12).


    Mail > Preferences does not affect the font seen at the other end for the message text -- that has to be set for each outgoing individually in the New Message pane.

    However, my signature does not get reformatted,


    An html signature should show up at the other end with the font and font size chosen for it by the sender.
  • btabz Level 7 Level 7 (26,635 points)
    Thanks, Tom.

    I am still unsure of how to get my signature font to match up with my main text of the email. If the sender gets to choose the size of the signature, then why would it not be matching up with the rest of my message. Somewhere along the way, either Apple Mail or the recipient is changing one of them, and I'm not sure how to prevent that.

    btabz
  • Tom Gewecke Level 9 Level 9 (74,465 points)
    If the sender gets to choose the size of the signature, then why would it not be matching up with the rest of my message.


    The way Mail works, the font of the "rest of your message" must be chosen by selecting that text and setting the font in the New Message pane for each outgoing message. Are you doing that?
  • btabz Level 7 Level 7 (26,635 points)
    Okay, I'll give that a try. It all looks like it's formatted the same to begin with (the "rest of my message" portion), but maybe manually changing that will make a difference.

    Thanks again,
    btabz
  • Tom Gewecke Level 9 Level 9 (74,465 points)
    Okay, I'll give that a try. It all looks like it's formatted the same to begin with (the "rest of my message" portion), but maybe manually changing that will make a difference.


    Of course it looks right on your machine, that's what Mail > Preferences are for. But unless you set it in the new message pane, no code is put in the message that tells a recipient what font should be used.

    You can see all this for yourself by doing View > Message > Raw Source on your sent messages.

    You may also need to make sure that what you choose in the New Message pane is different than what you have set in Mail > Preferences.