Skip navigation
This discussion is archived

Canon iR C3380 - Aggghhhh! Trouble again

5398 Views 8 Replies Latest reply: Mar 30, 2010 4:02 AM by sbolin RSS
sbolin Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 15, 2010 1:27 AM
After a long time trouble shooting, and much help from Pahu and others, I had got our office Canon iR C3380i printer to print. I have no idea what happened, but I get the following error every time I try now:

+Cannot find output destination. Check the printer power connection, make sure the printer is switched on, and then try again.: -3150+

The printer is fine, other Win users can print ok. Odd thing is that two Macs on the network suddenly weren't able to print, so it is something on the OS side - maybe a recent update? One of the Macs can print ok from bootcamp, so...dunno what is up. I tried deleting the old driver and other Canon detritus from the system and re-installing, and one time could actually print for a very short time (less than one day), but then it stopped again. Error is always the same, the -3150, whatever that means. If I go to the webpage for the printer I can print jpg files, but, well, we never print jpg files, so it is pretty useless, but does indicate that the computers CAN communicate with the printer, there is something up with the driver.

Sigh...10.6+Canon = disaster, as far as I am concerned. Worked ok with 10.5.x, too.
iMac Intel, Mac OS X (10.6.2)
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Mar 15, 2010 2:59 AM (in response to sbolin)
    Hi there again.

    I don't believe there was any recent updates that would have stopped this. My Mac (and others in the office) are still printing to our iR C3380, although we do have the PostScript kit in the copier so we are mainly using the Canon PPD (and I'm using the Canon PS v3.0 driver that Canon Oz posted recently for the new imageRUNNER Advanced models). But after reading your post I checked that I can still print with the UFR2 driver, which I believe you are using, and it is working fine for me.

    The 'cannot find output destination' can be a result of the backgrounder service (aka Printmonitor) not communicating with the copier. I suggest you open an application like TextEdit and select to print to the Canon. Then change the menu to Special Features. Here you will see an image of the copier and under the image will be the Printer Info button. Press this - it will open the UFR2 Printmonitor utility. I expect that this will error at some point, but before it does you can click Printer in the menubar and then click Search for Printer. This should invoke a search of the network, looking for supported Canon devices. If the Mac can 'see' the Canon, this utility should show a new window that details functions of the iRC3380.

    If this still fails, then let me know and I will get back to you tomorrow.

    Pahu
    MacBook Pro 17, Mac OS X (10.6.2), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 3G
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Mar 16, 2010 5:30 PM (in response to sbolin)
    I don't believe I have ever seen the Printmonitor application, or any application for that matter, show with a slash through it's icon. I'm not sure how that would appear. Even changing permissions on the file does not cause a slash to appear.

    Good to read you got it working again. Hopefully this doesn't occur again for you.

    Re the UFR2, I agree that Canon should have included the model in the list, rather than forcing you to use a Generic UFR2 model. But I have to say that for a machine of this size, your company should have purchased the additional PS kit. This would avoid having to use this proprietary driver and provide more options when Apple changes the print system - like they did with SL and could do again with the next big cat...

    Pahu
    MacBook Pro 17, Mac OS X (10.6.2), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 3G
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Mar 23, 2010 5:08 PM (in response to sbolin)
    sbolin wrote:
    Spoke too soon, can't print again. Extremely frustrating. I keep getting the same error (can't find the printer). Delete and re-install didn't help. I am using the 2.06 driver, I'll try to revert to 2.05 if I can find it somewhere, though not sure that will help.

    I don't think it will help either. Comparing the v2.06 to v2.05 I cannot see any major difference between the two, except that additional models have been added.

    I checked the URFII Print Monitor, sometimes it doesn't give an error, sometimes it does. If it does, search for printer doesn't do anything. Canon Thailand just told me to download the newest driver, and haven't been able to help more than that.

    For the printer not to be found, I wonder if your Mac is losing its network connection? At the time that the monitor doesn't find the copier, I would open the Network Utility and ping the IP address of the machine. This would at least show if you have a connection from the Mac to the Canon.

    We lease the printer, so not sure if the PS was available or not, I'd guess not as we normally would have PS printers. Next time they come out to service I'll ask and see if we can get PS added at some point. That said...it should still work regardless. One of our machines just upgraded to Win 7, no drivers added at the start, but it found the printer easily enough, downloaded the driver on its own, and prints fine - that is how it should work. Whether it is Apple or Canon's fault that it doesn't work this way with 10.6 is up for debate, though other printers we have worked fine out of the box without problem, only the iR C3380 has been a pain.

    Win 7 comes with a lite driver for the iRC3380, which lets you print and use some features. Would have been nice if Canon could have provided their business product drivers to Apple like they have done with their consumer products.

    I cannot remember if we previously checked for the availability of PS on this copier. If it does have PS, then you could use the Canon PPDs which I believe would avoid the errors you are getting.

    Also, Canon has released a PS driver for their new iR Advance models. I have been using this driver to our iRC3380, and it has been working fine for me.

    Can you check if you have PS on the copier. If you connect to the copier with a web browser you will see the built-in web page of the copier. On this page, select the Additional Functions button and then select Custom Settings (note that you may have to enter an ID and password). On the right side, you will see an entry of Printer Settings and under this will be the supported protocols. Hopefully you have an entry of PS.

    Pahu
    MacBook Pro 17, Mac OS X (10.6.2), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 3G
  • PAHU Level 6 Level 6 (14,400 points)
    Currently Being Moderated
    Mar 26, 2010 5:31 PM (in response to sbolin)
    Shame there is no PostScript support. At least then you would have an option for printing to the device. You may still be able to print to it using the Generic PCL Laser Driver that is included with SL. But this driver only supports b&w printing, so its not that much help with a color capable device.

    Nuking the printing system is not an easy task. There is more than one location for the system. You could resetting it but if you are printing to other network printers then I don't think this will be of any help to you.

    I would be more inclined to nuke the Canon UFR2 folder and reinstall. With previous versions of the UFR2 driver an uninstaller was included with the driver. But for the v2.05 and the latest v2.06, no uninstaller is included so you need to manually remove.

    Before trashing the UFR2 folder you will need to delete the current iRC3380 printer queue from Print & Fax. Then you can open finder and navigate to HD > Library > Printers > Canon. Here you will see the UFR2 folder which you can trash. Now, before you can empty the trash, you will need to stop the UFR2 Printmonitor service. If you open Activity Monitor, you should see "UFR II Backgrounder" in the list. If you don't see it, you may have to change the view to "All Processes, Hierarchically". With the UFR service selected you can now press the Quit Process icon in the toolbar. And when the next window appears, press Force Quit, as the Quit button doesn't always work. Now you can exit Activity Monitor.

    The next thing to delete is the plist for the backgrounder service. Using Finder, navigate to HD > Library > LaunchAgents. Here you will see "jp.co.canon.UFR2.GB.plist". Send this file to trash also.

    With the process stopped and plist removed, you can now empty your trash. Then I suggest you restart the Mac before installing the UFR2 v2.06 driver again. Hopefully now the error will not appear again. Of course, reply if it does.

    Pahu
    MacBook Pro 17, Mac OS X (10.6.2), MacPro 2x3GHz Quad-Core, Xserve G5, iPhone 3G

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.