Skip navigation
This discussion is archived

iMac won't go to sleep

7105 Views 13 Replies Latest reply: May 5, 2010 7:33 AM by hausmeista RSS
Peter R. Level 4 Level 4 (1,190 points)
Currently Being Moderated
Mar 18, 2010 4:40 AM
I set my iMac to go to sleep after an idle time of 20 mins. I won't.

What can I do?

Thank you for a good idea!
Mac OS X (10.6.2), +Please don't tell me to re-install the whole OS or to buy a new Mac+
  • macjack Level 9 Level 9 (50,445 points)
    Currently Being Moderated
    Mar 18, 2010 4:53 AM (in response to Peter R.)
    Disconnect all peripherals and test.



    -mj
    iMac 24" 2.16 GHz 3GB RAM/22" external HP display, Mac OS X (10.6), iMac G4 17" 800 MHz 768MB/ iMac 333MHz 256 MB / a gaggle of LaCie d2s/ APC-UPS
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Mar 19, 2010 6:38 PM (in response to Peter R.)
    Well, there's this....

    This is for a Mac that won't sleep.

    Here is Apple's KB article HT1776 with their tips.

    Mine follow;

    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.

    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file.
    If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.

    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password).
    If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    Hope this helps!

    P.S. One member here reported this (Michael Gleason);
    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    Dave Hamilton provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB card.

    Also, here is Apple KB article TA2469 about PCI cards and sleep.

    tomhorvat adds this; After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute.
    After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    Tristan Currier noticed this; "I have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps.
    Check the printer queue!"

    Allan Jones says "sometimes there is Network activity: launch System Preferences > Energy Saver > "Options" tab and uncheck "Wake for Ethernet network administrator access."

    One user has had success, after trying all these tips, using an App. called PleaseSleep. I've never used it though.

    Good Luck!  DALE
    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.2), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • iBrian Level 4 Level 4 (1,425 points)
    Currently Being Moderated
    Mar 20, 2010 5:58 AM (in response to Peter R.)
    start simple...
    log out/log in
    if that doesn't do it...
    reboot
    other things to try...
    change the batteries in your wireless mouse (if you have one)...
    disconnect and reconnect USB to your printer...
    clear caches (I use Onyx...http://www.titanium.free.fr/)
    mac mini 2GHz - intel, Mac OS X (10.6.2)
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Mar 21, 2010 12:18 PM (in response to Peter R.)
    Do you have a Canon scanner or an HP printer or scanner?

    Here's more with one part repeated....

    A number of sleep-related issues can appear after incremental Mac OSX updates, including the inability to properly go to sleep, problems waking from sleep, and having your display go to sleep without your Mac going to sleep. The most common culprit is Bluetooth. Try these tips to fix your sleep problems.
    WAKE UP
    In System Preferences>Bluetooth, uncheck Allow Bluetooth Devices To Wake This Computer. If you are using a Bluetooth mouse and keyboard, you'll have to wake your Mac by pressing the power button.
    FILE CORRUPTION
    Your Bluetooth preference file may be corrupt-you'll need to delete it. Turn Bluetooth off, then go to the /Users/user name/Library/Preferences folder. Look for a file called com.apple.Bluetooth.plist and trash it.The OS will create a new preference file when you enable Bluetooth again.
    ENERGY SAVER
    If you have issues with a Mac or display that goes to sleep at inappropriate times, you may have a problem with Energy Saver. Delete the following .plist files and restart:-/Library/Preferences/SystemConfiguration/com.apple.PowerManagement.pli st

    -/Users/username/Library/Preferences/com.apple.systemuiserver.plist--
    (username is your name or System Administrators name)
    -/Library/Preferences/SystemConfiguration/com.apple.AutoWake.plist
    A restart is very important after deleting these plists. After a reboot your Mac will then generate new ones.

    Some, in these forums, have had luck fixing sleep issues downloading the Combo update from this site (yours may
    be corrupt), not Software Update, disconnect all firewire + USB devices except keyboard + mouse,Repair Permissions, re-install update, Repair Permissions again + try.

    DALE

    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.2), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • cmosquera Calculating status...
    Currently Being Moderated
    Apr 4, 2010 3:28 PM (in response to Dale Weisshaar)
    I'm having the same problem on a brand new 27" I7 iMac. In order to test this, I connected a "P3 Kill-a-Watt" meter so that I could see exactly how much electricity my Mac was consuming... I suspected that it was not going into system sleep after the specified period in Energy Saver preferences. Here is my test:

    After doing all of the steps highlighted previously on this thread, such as Onyx, cleaning up the plist files, etc... I then decided to go for the jugular and reinstall SL from the 10.6.2 DVD included with the Mac on a new partition. Prior to this I ran CC Cloner to copy the boot disk to a USB drive so that I had a backup.

    on Idle the meter showed about 1.3 Amps,
    after the sleep timeout which I had set to 1 minute the screen dimmed and after it turned off the meter read .66 Amps.
    After approximately 5 mins and 30 secs (5:30) I heard the fan spin down and my energy usage went down to .11 Amps. I assumed the system has properly gone to sleep.

    I then proceeded to run this test with the program "PleaseSleep" enabled and it worked the same as above with the exception of going into the .11 Amps low power sleep mode immediately.

    I then installed 10.6.3 from the combo update and ran the test again. Everything worked the same except that the Mac went to full sleep after 2:30 which is a full 3 minutes earlier and repeated the same with "PleaseSleep" enabled.

    Assuming that everything was working perfectly and that there must have been an issue with my factory image, I ran the migration assistant to restore all my data and apps from the usb disk. After running all of the tests it is not going into the lowest power mode anymore. I have disabled all login items, tried creating a new account, disabled all sharing, unplugged all external usb & FW stuff. Nothing I try seems to work except when booting up into safe mode using the shift key.

    I know that something that I restored from the usb backup is causing this condition and I know that if it's probably in the settings that are restored when you choose "Settings" or Other Files and Folders" from the migration assistant. It would be nice to know exactly what though... Any ideas?
    iMac 27" i7 Late 2009, Mac OS X (10.6.3)
  • cmosquera Level 1 Level 1 (30 points)
    Currently Being Moderated
    Apr 5, 2010 1:07 PM (in response to cmosquera)
    Among other things, I uninstalled a preference pane called "AppTrap" and the problem has gone away.
    iMac 27" i7 Late 2009, Mac OS X (10.6.3)
  • cmosquera Level 1 Level 1 (30 points)
    Currently Being Moderated
    Apr 5, 2010 6:01 PM (in response to cmosquera)
    I take that back... next step, wipe partition, reinstall SL, and move my stuff back in without using the migration assistant.... any ideas?
    iMac 27" i7 Late 2009, Mac OS X (10.6.3)
  • Dale Weisshaar Level 6 Level 6 (15,855 points)
    Currently Being Moderated
    Apr 9, 2010 5:49 PM (in response to cmosquera)
    Have you tried the tips in my previous posts?

    Dale
    MacPro, 3.0GHz Dual C., 5 GB, X1900, 30"ACD,Airport Extreme,HP C7180 Printer,, Mac OS X (10.6.3), G4 Gigabit E. 1GHz OWC 10.4.11, 1.62MB MacBook Pro Late '08, 15", 2.4GHz, 4GB
  • iBrian Level 4 Level 4 (1,425 points)
    Currently Being Moderated
    Apr 9, 2010 6:34 PM (in response to cmosquera)
    can you glean anything from the console messages?
    mac mini 2GHz - intel, Mac OS X (10.6.3)
  • cmosquera Level 1 Level 1 (30 points)
    Currently Being Moderated
    Apr 10, 2010 8:03 PM (in response to Dale Weisshaar)
    Yes, tried pretty much everything... The only thing that makes it work properly is to install osx clean into a new partition and then do all of the updates but the moment that I use the migration assistant to bring my docs and apps it stops sleeping by itself... I've deleted plist files, cleaned caches using Onyx, done pretty much everything that everyone has suggested... My next step is to reinstall again but this time I will copy my stuff manually from my Time Machine backup and see if that does it. I also looked at all of the console messages and didn't find anything.
    iMac 27" i7 Late 2009, Mac OS X (10.6.3)
  • cmosquera Level 1 Level 1 (30 points)
    Currently Being Moderated
    Apr 13, 2010 9:48 AM (in response to Peter R.)
    It's fixed! Here's what I ended up having to do... I upgraded to an iMac i7 from a MacBook Pro 15" and I noticed that sleep would not work properly, the fans kept spinning and the system would wake up "too" quickly, I confirmed this because if I installed fresh into a clean partition on the iMac, sleep would work properly. Once again I compared using a device called a "Kill-A-Watt" that monitors exactly how much power the computer is drawing from the AC jack.

    After installing into a clean partition, I then used the Migration Assistant to copy over my Apps Documents, Settings and Other Files (I checked all four) from my original laptop drive in a USB enclosure. After I did this and rebooted the iMac, it would not go all the way into system sleep, just display sleep.

    I then proceeded to use a less invasive approach and just restoring documents and applications and leave settings and other files unchecked in the Migration Assistant, this again broke sleep.

    After trying pretty much everything that has been posted here I then decided NOT to use the Migration Assistant.

    Again, I booted from the OSX 10.6.2 DVD included with the iMac, deleted the partition on my boot drive and installed clean. I then proceeded to install my iLife apps from the included DVD and my iWork 2009, did all of the updates and sleep was working perfectly. At this point, I copied all of my documents, pictures, videos, mail from the library folder in the old user profile and music from my old drive as well as move the Applications one at a time. To my surprise and after much testing, sleep was still working.

    There must have been a setting somewhere that broke it for me when using the Migration Assistant but it's all good now. For your reference I have the following stuff plugged in:

    ACOMData Tango FW800/USB Enclosure in the FW800 port (The light on this device stays on regardless, pretty annoying)
    Seagate FreeAgent Pro 750 USB plugged into USB Port
    NextStar eSata/USB Enclosure with a 500GB Seagate drive in a USB Port
    Creative Labs Xmod USB Sound Card

    Kensington DomeHub 7 Port with the following attached:
    Brother MFC 7420 USB Printer
    Jaybird USB Headphone charger
    iMac 27" i7 Late 2009, Mac OS X (10.6.3)
  • hausmeista Calculating status...
    Currently Being Moderated
    May 5, 2010 7:33 AM (in response to cmosquera)
    Sounds like hours of fun...

    I have the same problem. If found out, that deleting the file 'com.apple.PowerManagement' solves the problem AS LONG as you don't touch the Egergy Saver and change the times. Once I do this, there's no more sleeping... isn't that curious?

    I won't touch it for now, but to be honest, 10 mins until sleep when plugged into a point is a little short...
    MacBook Pro 13,3", Mac OS X (10.6.3), 2,4 GHz, 4 GByte RAM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.