1 Reply Latest reply: Mar 18, 2010 11:06 AM by stubear10
stubear10 Level 1 Level 1 (0 points)
I have looked all over and can't find this topic. If it is already posted, I apologize. While using Safari, the delete key shortcut sends me back one page in my history. This is all well and good, except when I am typing in a text field and, for one reason or another, the text field becomes "unselected." In other words, I'll be typing, want to delete something I just typed, hit the delete key, and be sent back a page, losing everything I just typed. Does anyone know how to disable this shortcut? I know I can make other shortcuts for going back in history, but this does not disable the delete key shortcut. Any help would be great.

Unibody MacBook Pro 13" 2.26GHz 4GB Ram
  • Carolyn Samit Level 10 Level 10 (95,950 points)
    HIi,

    Please take a moment and click My Settings on the right side of this page and tell us which Mac OS X version you are running. That way you have a forum profile setup. Thanks...

    Try Resetting the PRAM Relaunch Safari and see if that made a difference. If not...

    Try maintenance..

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Go here for trouble shooting 3rd party plugins or input managers which might be causing the problem. Safari: Add-ons may cause Safari to unexpectedly quit or have performance issues

    If you are running Snow Leopard v10.6.x, make sure Safari is opening in 32-bit mode, not 64. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Also, (in that same window) make sure Safari is NOT running in Rosetta.

    

Web pages now include a small icon or 'favicon' which is visible in the address bar and next to bookmarks. These icons take up disk space and slow Safari down. It is possible to erase the icons from your computer and start fresh. *To delete Safari's icon cache using the Finder, open your user folder, navigate to ~/Library/Safari/ and move this file "webpageIcons.db to the Trash.*
    bpageIcons.db to the Trash.*

    If the delete key is still an issue at this point, go to the Safari Menu Bar, click Safari/Preferences. Make note of all the preferences under each tab. Quit Safari. Now go to ~/Library/Preferences and move this file com.apple.safari.plist to the Desktop. Relaunch Safari. If it's a successful launch, then that .plist file needs to be moved to the Trash.










    Carolyn