10 Replies Latest reply: Mar 25, 2010 9:01 PM by William Boyd, Jr.
Transini Level 1 Level 1 (135 points)
I have my ISP's cable modem feeding my Airport Extreme. My old PowerMac is connected to the AE via ethernet cable. I set up port mappings on the AE to map ports to 10.0.1.202, as I have the PowerMac en0 set up with fixed local IP 10.0.1.202. In the AE I have the DHCP autorange set from 10.0.1.2 through 10.0.1.200. This works perfectly with the PowerMac, and I can ssh/scp/ARD into it, etc, whenever I am away.

I'm now replacing my PowerMac with a new 27" iMac.

However, when I set my new iMac en0 to fixed IP 10.0.1.202 and plug in that same ethernet cable going to the AE, it doesn't work. The port shows 'active' but no network connection is established. But if I set the iMac to auto DHCP and let it dynamically choose the local IP address (like 10.0.1.3), it does give me a working ethernet connection, but of course I can't access the machine from the outside, since it's only port mapping on 10.0.1.202.

What am I doing wrong??? I'm running Airport Utility 5.4.2 and OSX 10.6.2.

27" iMac, Mac OS X (10.6.2)
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Transini wrote:
    when I set my new iMac en0 to fixed IP 10.0.1.202 and plug in that same ethernet cable going to the AE, it doesn't work.


    In the Network panel of System Preferences, Ethernet connection item, how did you set the "Configure" item? If you chose "Using DHCP", I'll guess that you didn't provide settings for "Router" and "DNS Server". Try setting that item to "Using DHCP with manual address", then put the IP address you want into the "IP Address" field.
  • Duane Level 10 Level 10 (117,955 points)
    I would second Williams's suggestion to ensure that you are setting the router and Subnet fields when setting up a manual IP address. The router field should be 10.0.1.1 and Subnet set to 255.255.255.0.
  • Transini Level 1 Level 1 (135 points)
    When I do "Using DHCP with manual address", the subnet mask, router, DNS server and search domains fields are correctly filled out -- until I click the Apply button, then they get blanked. The green indicator comes on next to "Ethernet Connected". It says "Ethernet is currently active and has the IP address 10.0.1.202", but the connection isn't usable. If I switch it to "Use DHCP", then it auto assigned something like 10.0.1.4 and the connection works fine (but I can't access it from the outside).
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Transini wrote:
    When I do "Using DHCP with manual address", the subnet mask, router, DNS server and search domains fields are correctly filled out -- until I click the Apply button, then they get blanked.


    It should work with what you already tried, but try these settings:
    - Configure: Manually
    - IP Address: 10.0.1.202
    - Subnet Mask: 255.255.255.0
    - Router: 10.0.1.1
    - DNS Server: 10.0.1.1
  • Transini Level 1 Level 1 (135 points)
    - Configure: Manually
    - IP Address: 10.0.1.202
    - Subnet Mask: 255.255.255.0
    - Router: 10.0.1.1
    - DNS Server: 10.0.1.1


    Yes, those are the settings I start with. Then I click "Apply", and the subnet mask, router, and DNS server fields go blank. After about a 1 minute wait, the subnet mask gets set to 255.0.0.0 and the other fields stay blank. The connection is marked "active" but doesn't work.
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Transini wrote:
    Yes, those are the settings I start with.


    With a "Configure" setting of "Using DHCP with manual address" or "Manually"? I'm suggesting that you use a setting of "Manually" until you can determine why the other setting doesn't work.
  • Transini Level 1 Level 1 (135 points)
    William Boyd, Jr. wrote:
    Transini wrote:
    Yes, those are the settings I start with.


    With a "Configure" setting of "Using DHCP with manual address" or "Manually"? I'm suggesting that you use a setting of "Manually" until you can determine why the other setting doesn't work.


    Yes. When choosing "Using DHCP with manual address" it doesn't allow me to set the subnet mask or router fields. They show the prefilled values 255.255.255.0 and 10.0.1.1 because they're carried over from the old "Using DHCP" connection. But clicking Apply blanks those fields as it waits to get new values for them, but only comes back after 60 secs with 255.0.0.0 for the subnet mask, and the connection doesn't work.

    The vexing thing is that this configuration works fine on my old G5, but not on the iMac.
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Transini wrote:
    William Boyd, Jr. wrote:

    With a "Configure" setting of "Using DHCP with manual address" or "Manually"?


    Yes.


    Interesting how you managed to answer an "either/or" question with a "yes."
  • Transini Level 1 Level 1 (135 points)
    Oops, sorry I misread your instructions! Yes, indeed, using the Manually setting and forcing all the fields to what they should be results in a valid en0 connection, a fixed local IP, and a static IP pathway from outside in to the machine. Thanks so much!
  • William Boyd, Jr. Level 6 Level 6 (10,515 points)
    Transini wrote:
    Yes, indeed, using the Manually setting and forcing all the fields to what they should be results in a valid en0 connection, a fixed local IP, and a static IP pathway from outside in to the machine. Thanks so much!


    At least you're on the air until some wizard can come along and show you how to make it work with "Use DHCP with a manual address".