3 Replies Latest reply: Mar 19, 2010 6:25 PM by Dale Weisshaar
mack7 Level 1 Level 1 (0 points)
My settings on Energy Saver --> Sleep are about 15 minutes. Also "Put the hard disks to sleep when possible" is checked but my computer won't go to sleep. The display goes dark but the computer still runs. I did do a software update around that time. Remedy?

Sheryl

G5, Mac OS X (10.4.11)
  • Limnos Level 8 Level 8 (44,440 points)
    What applications are left running? I have noticed that some applications keep the computer awake regardless of sleep settings.
  • WZZZ Level 6 Level 6 (12,775 points)
    In addition to what Limnos has just asked, have a look at this Apple Article on this issue
    http://support.apple.com/kb/HT1776

    Also a couple of things to try:
    - in /Library/Preferences/System Configuration move "com.apple.PowerManagement.plist" to the trash. You may be asked to give your admin password to do this and don't worry, this file will be re-built automatically. You are doing this because it may be corrupted. There are 3 Libraries; the one you want is not the System/Library or your Users (your account)/Library.
    - then go to the Energy Saver Settings in Sys Preferences again and select "Restore Defaults;" then put things back again the way you want. See if this helps. It's OK to empty the trash.
  • Dale Weisshaar Level 6 Level 6 (15,865 points)
    Here's more.....

    This is for a Mac that won't sleep.

    Here is Apple's KB article HT1776 with their tips.

    Mine follow;

    USB devices and hubs often cause Macs to not sleep or wake quickly from sleep (notably HP printers and scanners, HP all in ones, and Cannon scanners). Disconnect all USB except for keyboard and mouse and try. If it sleeps, add one back at a time testing after each one to find the culprit.

    If you've set your Mac to receive faxes, it may not be able to sleep. It might also have a damaged preferences file.
    If you use your Mac for faxing, open System Preferences. click Print & Fax, click the Faxing tab, and uncheck the Receive Faxes On This Computer box.

    If that doesn't work or you've never faxed on your Mac, go to Finder/Hard Drive /Library/Preferences/SystemConfiguration and delete the com.apple.PowerManagement.plist and com..apple.AutoWake.plist files (if your Mac asks, type your admin. password).
    If the latter file isn't present in the folder, go to user name(probably your name)/Library/Preferences, delete the com.apple.systemuiserver.plist file, and reboot your Mac.

    Hope this helps!

    P.S. One member here reported this (Michael Gleason);
    "I have had this problem with my IMac G5. It is surprisingly irritating. LaCie's Silverkeeper backup software was the cause. By default it gave itself permission to wake up the computer to check if a backup was needed. Do you have this or a similar program installed which has scheduled activities including wake-up permissions as an option?"

    Dave Hamilton provided this link, xlr8yourmac.com, to a member, which addresses failure of deep sleep with some users that updated and added new FireWire and USB card.

    Also, here is Apple KB article TA2469 about PCI cards and sleep.

    tomhorvat adds this; After few days of messing around I found out that I had desktop background (wallpaper) set to change every 1 minute.
    After unchecking "Change picture..." in system preferences (under Desktop/Screen saver), my powerbook went to sleep all by itself.

    Tristan Currier noticed this; "I have a Canon printer(shared) and my imac would not sleep. I opened up printer/fax in system prefs and noticed it said the printer was in use when it was off. Opened up the printer queue and noticed about 7 pending documents. Deleted them all and now it sleeps.
    Check the printer queue!"

    Allan Jones says "sometimes there is Network activity: launch System Preferences > Energy Saver > "Options" tab and uncheck "Wake for Ethernet network administrator access."

    One user has had success, after trying all these tips, using an App. called PleaseSleep. I've never used it though.

    Good Luck!  DALE