Skip navigation
This discussion is archived

Maxtor One Touch III not showing up on Mac OSX or Windows

3211 Views 3 Replies Latest reply: Mar 27, 2010 9:23 PM by Fortuny RSS
SynGatesFan200 Calculating status...
Currently Being Moderated
Mar 20, 2010 10:41 AM
ok so i have this Maxtor one touch III external hard drive that i used to use with my XP computer a few years ago... its 500 GB. so i plug it in to my Mac and install the software and it doesn't show up on my desktop or my disk utility. although, it does show up in my system profiler. so, it didn't work for mac... then i went onto my parallels account that has windows 7 on it and it still doesn't show up. what can i do to fix this?
iMac 24-inch, Mac OS X (10.6.2), Windows 7 Professional
  • Fortuny Level 7 Level 7 (21,415 points)
    Hi and welcome to Discussions,

    please provide some informations, like:

    connection of the Maxtor (USB; FireWire;...) ?
    which version of Parallels ?
    in which section of the System Profiler is the Maxtor shown ?
    what kind of software did you install for the Maxtor ?

    Stefan
    MacPro 2.66 (Late 2006) 8GB X1900XT, Mac OS X (10.6.2), (2006 20" iMac gone for good/bad, sniff...)
  • Fortuny Level 7 Level 7 (21,415 points)
    SynGatesFan200 wrote:
    Connection: USB
    Version of parallels: 5.0
    Section in system profiler: USB (shown as One touch III)
    Software used: maxtor installation disc for one touch III (windows), downloaded maxtor one touch 4 software (mac)


    Hi,

    all this, with the exception of the Maxtor software, should indicate a no-problem with that HD.
    Personally I have always avoided the provided software, since it is not needed for external HDs.

    If you have access to a Windows PC try connecting the HD there and see what comes up.
    And if you don't have valuable files on that HD, you might repartition it there as well.

    Could be a rare case of a 'dynamic disk' http://support.microsoft.com/kb/314343/en-us which is something that Macs can't handle.

    Regards

    Stefan

    Message was edited by: Fortuny
    MacPro 2.66 (Late 2006) 8GB X1900XT, Mac OS X (10.6.2), (2006 20" iMac gone for good/bad, sniff...)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.