8 Replies Latest reply: May 25, 2010 9:08 PM by dlt4
dlt4 Level 1 Level 1 (0 points)
I have a Qwest wireless gateway connected to the internet. I can connect my iPod to the network with no problem, but it won't stay connected. Any help would be appreciated.

20" iMac G5 iSight, Mac OS X (10.5.8), 32GB iPod touch; 20GB iPod w/color
  • Jason L Community Specialists Community Specialists (10,815 points)
    Hi,

    Make sure you have the latest updates available for the iPod touch and wireless gateway.

    If you are using WEP, you'll want to use a 5 or 13 character password as mentioned here: http://support.apple.com/kb/HT1344

    Also, does the iPod touch have a valid IP address(not 169.254.x.x)? This article: http://support.apple.com/kb/TA26003 provides more details about self-assigned IP addresses.

    -Jason
  • dlt4 Level 1 Level 1 (0 points)
    The problem appears to be solved just by doing a wi-fi reset on the iPod. I'm not sure what screwed it up, but it's been working for OK for three days now.
  • koopie Level 1 Level 1 (0 points)
    This is my first time posting to the discussion forum, so i apologize if this isn't the correct thread. I'm having the same problem as dlt4, but on a Linksys router. My iPod will connect to my home network with no problem a handful of times and then it will stop connecting. I've tried resetting network settings with no success, the only way i can reconnect is to unplug my router for thirty seconds or so and then plug it back in. My desktop is not having this problem and my iPod is recognized as a trusted device on the network.
  • DanMuller Level 1 Level 1 (55 points)
    Koopie, the bad news is: that's not at all an uncommon problem with the iPod Touch. I have the same problem at work. We have no problems at all connecting to our Wi-Fi with Dell, Sony, HP, Asus, Palm or any other devices except two: my Touch and my boss's iPhone. Apple has the most finicky Wi-Fi known to man.

    But enough ranting. The first thing you'll want to do is to check to be sure that your router's firmware is up-to-date. That may just solve your problem; it does in some cases. I've also found that turning the Touch's Wi-Fi off and on sometimes helps. You may have to do it four or five times to get a reconnect. You might also check your router's instructions to see if there is a way to reset it by going in through your web browser, which may be more convenient than pulling the plug.
  • koopie Level 1 Level 1 (0 points)
    Thanks for the help Dan, i appreciate it. I just checked and my routers firmware does need to be updated so i'll give that a go and see what happens.
  • dlt4 Level 1 Level 1 (0 points)
    You might also try doing a WiFi reset on your iPod also. That's what fixed my problem.
  • koopie Level 1 Level 1 (0 points)
    Thanks for the suggestion dlt4, is a wifi reset the same as resetting network settings? I've tried that and updating my routers firmware and it's still losing connection unfortunately.
  • dlt4 Level 1 Level 1 (0 points)
    Yes, I was referring to Network settings. I'm sorry to hear that didn't work.

    Message was edited by: dlt4