Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: Error 306, using WiFi, often on the Canon PIXMA models

I've seen the following error on numerous other boards and here on older Apple posts, too:

Error Number 306 A communication error has occurred

I thought that I had done all the correct steps to solve the problem, but it still wouldn't work. Then, I found two different posts which said similar things (one which was really close by Pahu, thank you!) that led me to the correct result. So, I wanted to lay it out in explicit detail here, in the hopes that others could solve their problem quickly & easily. The prerequisite for the steps below is that _your Canon is powered up, configured, & WiFi connected to your LAN_. Here's what I did *that worked*:

• Delete any previously installed (i.e., non-working) printers for the Canon

• Download the basic Mac installation software for your Canon model at this link, *making sure that you're installing the Canon Networking software* (it may be a separate link, or it could be bundled into their basic install - YMMV):
http://www.usa.canon.com/consumer/controller?act=SupportIndexAct

• Download the latest printer driver for your model, same link as above. Yes, you will need to download at least these two items, since the drivers in the original installation will not be the latest & greatest.

• Install the basic installation/networking software first, then update the drivers

• Go to System Preferences:Print & Fax

• Click '+' to add a new printer, select Default in the top, left corner of the Add Printer window, then wait for 15-30 seconds

• You'll see another Canon printer appear on the list, with a string of numbers after its name. *This is the one you want*, NOT the one which is already there when you first click Default. After you select that printer (do a Test Page to verify it works), you can go back and edit it, trimming the name down by cutting off the string of numbers; doing so will not affect the printer's operation.

That's it! The real trick was in selecting the networking version of the printer which is "discovered" by the network when you pull up the Default tab. Whenever I tried to use the standard version of the printer, even though I could do things like clean the heads and actually receive a printout from doing so, I could never send anything to the printer successfully. Hope this works as well for you as it did for me! 🙂

Mac Mini, Mac OS X (10.6.1), Canon Pixma MP560

Posted on

Reply
User profile for user: ..d..ecay

Question: Error 306, using WiFi, often on the Canon PIXMA models