8 Replies Latest reply: Jul 17, 2010 2:51 PM by Midville
kendellrt Level 1 Level 1 (0 points)
I have an alias on my desktop that I cannot delete. If I look for it through the finder it shows up, but if I try to access it through my MacBook using file sharing it doesn't. I cannot change permissions for it, in fact, it doesn't even have the little lock icon to click on in order to change permissions. It doesn't show up as locked, either. Because it doesn't show up via file sharing I was thinking it may not show up in target disc mode, but I haven't tried that yet; we haven't found our box of computer cables and stuff since we moved recently. When I try to move it to the trash it says that the operation cannot be completed because I don't have permission to access some of the items. It is an alias to an .m4v file created using Handbrake. I cannot find the original file anywhere, and if I double click on the alias it says it can't be opened because the original file cannot be found. It offers the choice to delete the alias, but then I get the error I mentioned before. Any ideas?

MacBook 13.3" Pre-Unibody/iMac 20" Aluminum, Mac OS X (10.6.2)
  • kendellrt Level 1 Level 1 (0 points)
    Seriously, nothing? Anybody, please?
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    You could try to remove it using the Terminal. Launch it from your Utilities folder, then type this:

    sudo rm

    hit the spacebar and drag the file from the Desktop and drop it in the Terminal window. Press the Return key. You'll be asked for your admin password. Type it carefully, because it will not appear in any way whatsoever when you are typing it. Then press return again. Your Terminal will look something like this:

    NoobiX:~ francine$ sudo rm /Users/francine/Desktop/NoPixelsError.jpg

    The file should vanish immediately. It will not appear in the Trash--it will just be gone.
    Francine


    Francine
    Schwieder
  • kendellrt Level 1 Level 1 (0 points)
    Unfortunately, that did not work. This is the message that I got after using the command you gave me and following the steps as described:

    rm: /Users/kendellrt/Desktop/PIX0NNF1.m4v: is a directory
  • Francine Schwieder Level 6 Level 6 (19,040 points)
    Well, evidently the Finder thinks it's a alias, but the lower level of the OS thinks it is a folder. That is a bit strange! You could try this command (just copy and paste):

    sudo rm -rf /Users/kendellrt/Desktop/PIX0NNF1.m4v

    That tells Terminal to temporarily assume the powers of root (the super user) to remove, recursively and forcibly, the item PIX0NNF1.m4v--see if that does it.

    I would be a bit concerned about the disagreement over exactly what the item really is, and if I were you I would start from the install disk and run Repair Disk from the Utilities menu item. See here

    http://support.apple.com/kb/TS1417

    if you aren't sure how to do that.
    Francine


    Francine
    Schwieder
  • kendellrt Level 1 Level 1 (0 points)
    None of the approaches given so far ever worked. However, I have also been having problems with the computer freezing up and needing to do a hard reboot, as well as some other strange issues. So, I decided to re-install 10.6 and see if that fixed it. I love that 10.6 allows you to re-install the OS without touching apps or user files instead of the old archive and install! I backed everything up just in case, and after the re-install I have no more problems. The alias showed up on the desktop as a folder and I was able to move it to the trash without any trouble. No more freeze ups, either! If I wanted to have a computer that froze up all the time and needed constant maintenance I would just use Windows! :0)
  • kendellrt Level 1 Level 1 (0 points)
    Thanks for the input!
  • dvscrobe Level 1 Level 1 (40 points)
    I have two aliases, which one of I can't seem to delete. The one alias shows up when I login with Internet Explorer and the other alias shows up when I login with Firefox.
  • Midville Level 1 Level 1 (0 points)
    I just had a problem very similar to that described by the original poster.

    The installer for my Japanese input method (ATOK 2010) placed an alias to a user registration program on my desktop. When I tried to trash it (either using the Command-Delete shortcut or dragging it to the trash) I got an error message telling me the operation couldn't be completed.

    Here's how I got rid of the icon:

    1. I opened a new Finder window (a folder other than the desktop).
    2. I dragged the alias to the Finder window I just opened.
    3. I tried trashing the alias again using the keyboard shortcut.

    This time it worked. Either moving the alias to a different folder prompted the system to reset whatever was causing the error, or it fixed itself by the time I got done doing the above. I can't guarantee it will work for you, but it might be worth trying.