6 Replies Latest reply: Mar 23, 2010 6:12 PM by BDAqua
Geno Bizzozero Level 1 Level 1 (0 points)
Hey all,

I've been having an issue with Google-related sites and my MacBook for about a week now, and I'm not sure what the problem is.

Maybe 80% of the time my browser won't go to Google sites. I can't get to G-mail, Google.com, even youtube.com comes up empty a lot. A lot of the time it just loads and loads and nothing happens until it times out. Some of the time, I just immediately get a message saying it was an invalid address, blah blah blah.

If I type something into the google search bar on my browser or try to go to google.com, it doesn't work. If I go to G-mail from my bookmarks or physically type in gmail.com, it doesn't work.

And it's happening on all three of my browsers: Opera, Firefox and Safari. They're all doing the same thing.

I've tried quitting the application and re-opening and it doesn't work. SOMETIMES after I re-start the computer it will work for a little, then it always reverts to these odd habits.

I haven't changed anything with/on/in my computer recently. I'm running OS 10.4.11 on a MacBook that is coming up on four years old.


Any idea what is happening or how I can figure out what is wrong? Thanks.

MacBook, Mac OS X (10.4.7)
  • 1. Re: Google-related sites not working on three browsers
    BDAqua Level 10 Level 10 (116,475 points)
    Try putting these numbers in Network>TCP/IP>DNS Servers, for the Interface you connect with...

    208.67.222.222
    208.67.220.220

    Then Apply

    DNS Servers are a bit like Phone books where you look up a name and it gives you the phone number, in our case, you put in apple.com and it comes back with 17.149.160.49 behind the scenes.

    These Servers have been patched to guard against DNS poisoning, and are faster/more reliable than most ISP's DNS Servers.
  • 2. Re: Google-related sites not working on three browsers
    Geno Bizzozero Level 1 Level 1 (0 points)
    Before I try that, what will that do? I'm a little confused. And why would I have had no problems with Google until very recently and how would this make it different?

    Also, I'm computing from school where I've had to register IP addresses and such to use the built-in ethernet. Will this cause any problems in that regard?
  • 3. Re: Google-related sites not working on three browsers
    BDAqua Level 10 Level 10 (116,475 points)
    It shouldn't cause any problems, but copy down the ones that are there now so you can out them back if need be.

    Or try this instead...

    Safe Boot from the HD, (holding Shift key down at bootup), run Disk Utility in Applications>Utilities, then highlight your drive, click on Repair Permissions, it will try to repair your Disk Directory while the spinning radian is happening, so let it go.

    In Mac OSX versions 10.5.1 and before, the command lookupd -flushcache performed the same task:

    lookupd -flushcache

    Reboot.
  • 4. Re: Google-related sites not working on three browsers
    Geno Bizzozero Level 1 Level 1 (0 points)
    Did the safeboot and Repair Permissions, and it still doesn't work.

    I'm still leery of changing the numbers for the DNS Servers. I don't quite understand yet what that will do and why that would SUDDENLY cause a problem like this.

    Any more help?
  • 5. Re: Google-related sites not working on three browsers
    BDAqua Level 10 Level 10 (116,475 points)
    I'd try pasting this into terminal then...

    lookupd -flushcache

    Press enter & reboot.
  • 6. Re: Google-related sites not working on three browsers
    K Shaffer Level 6 Level 6 (9,220 points)
    If what BD suggests does not work, you can always put the older
    original DNS addresses back into their former locations & save.

    Where are you located geographically? If you are in or near China,
    there may be some disruptions to the Google-related enterprises
    in that area since China and Google are having relationship issues.
    While some content is being routed to Hong Kong or elsewhere, a
    few of the services in the region may be slow to work or fail to do so.

    There are articles in tech news, and sometimes, you learn about them
    first hand. Hopefully you can resolve the matter or wait it out.

    Good luck & happy computing!