5 Replies Latest reply: Mar 26, 2010 2:56 PM by Uncle Otto
Uncle Otto Level 1 Level 1 (5 points)
I'm not familiar with how the Keychain thing works, so I created a "Test Keychain" just to see it. I saved it to my Desktop, but it appears in the Keychain list in Keychain Access. However, when I select the Test and click on "File", the Delete function is grayed out, and it says "Delete Keychain System Roots".

What's wrong---why won't it let me delete the Test Keychain?

iMac 24" Aug 2009, Mac OS X (10.6.2)
  • musicwind95 Level 4 Level 4 (1,280 points)
    Uncle Otto wrote:
    I'm not familiar with how the Keychain thing works, so I created a "Test Keychain" just to see it.


    For the most part, you shouldn't have to manually create a keychain. They are automatically created for you when you enter a password (for your email, on a website, etc).

    I saved it to my Desktop, but it appears in the Keychain list in Keychain Access.


    You've created a whole keychain, not an individual item, which I think was what you were going for.

    However, when I select the Test and click on "File", the Delete function is grayed out, and it says "Delete Keychain System Roots".

    What's wrong---why won't it let me delete the Test Keychain?


    I'm stumped...could you list the exact steps you tried? For me, I pressed File > New Keychain. I was prompted for a name and a location in a save sheet. I had to enter a password (twice) to secure the keychain, and then it appeared in the left under "Keychains". When I go to File, the Delete option is marked as Delete Keychain "Test". I get a confirmation prompt, and then it deletes.

    What did you try to do?
  • Uncle Otto Level 1 Level 1 (5 points)
    I created it the same way you did. But just now I went to Keychain Access>Keychain List>highlight Test Keychain>and I get the Delete grayed out and it's for System Root---not Test.
  • Uncle Otto Level 1 Level 1 (5 points)
    OK I tried it again, only this time I highlighted "Login" first---clicked on File, got the Delete for Login, then highlighted Test Keychain again, and then File again-----then it worked----I got the Delete for the Test Keychain. It's gone now. I can't figure out why it wouldn't do it before.

    Thanks for the help.
  • musicwind95 Level 4 Level 4 (1,280 points)
    It's probably just a little bug...you can file a feedback report if you'd like. There's really not much to "fix" here.
  • Uncle Otto Level 1 Level 1 (5 points)
    Thanks again. I have now submitted the report.