Previous 1 11 12 13 14 15 Next 298 Replies Latest reply: Dec 15, 2013 10:51 AM by Rackland75 Go to original post
  • PaulDorn Level 1 Level 1 (0 points)

    I have exactly the same audio issue, that has started only recently. I have successfully imported 1080/50p video from my Panasonic HDC-SD90 camera in iMovie11 after rewrapping with Alan's script on April 26. All with no audio issue what so ever. (and using an old Perian 0.5 version). I did have issues with the time code; all my clips where out of chronological sequence after shutting down and restarting iMovie. They now seem to be in order of clip lenght, although not fully consistent. But that's another story.....

     

    I first experienced the audio issue on May 8, when trying to import new footage I shot the day before. I then reinstalled Rewrap2M4V and the latest version of ClipGrab and installed the latest Perian version. Still to no avail. When browsing the system profile -> Software -> Frameworks, I did notice that the AVFoundationCF was updated on March 31 2011. I'm not a developer, but this seems to be the framework used for audio / video playback for (most) Mac OS X applications such as QuickTime, Quick Preview and iMovie11. ('he AV Foundation framework provides an Objective-C interface for managing and playing audio-visual media in your Mac OS X application.') I do suspect a version conflict between some components, but it seems the latest system file updates date from April 17 and they seem unrelated to my layman's eye. Also these dates do not match the time the audio issue has started. Maybe Alan Somers can shed some light on this subject?

     

    I really hope for a quick solution, because converting to H.264 25fps is no option for me. I really mis the smooth playback when doing this, especially when using slow motion.

  • deltaguru Level 1 Level 1 (0 points)

    Hi,

    I just found out that the creation of the iMovie thumbnails in the event folder goes wrong,
    The audio is only there disturbed with the scratching noise. The original rewrapped m4v files are okay.

    Everey attempt to recreate the thumb-movies with clean audio failed.
    Therfore I agree that either it has to do with the system update or that there is a new audio bug in iMovie 9.0.2.

     

    Let me know your experience...

  • eisber123 Level 1 Level 1 (0 points)

    Hi,

     

    Using Alan's script I can view and listen to proper audio using vlc. I have the latest version (1.2.0 or so) of peridian. I get proper audio in QuickTime before I open iMovie11. after opening iMovie I get the same screeching as everybody else in iMovie and QuickTime. I hoped that the ac3 audio gets just copied to dvd when exporting using iDVD, but I even had the screeching on the dvd when played back on a XBox 36.

    Right know I'm trying to build a ffmpeg version including libfaac support to convert the audio to 5.1 aac.

    I too am not a fan of re-encoding but using aac with a high bitrate is probably sufficient for me (given the video is untouched).

    I also tried the -newaudio option (which actually adds a 2nd stereo stream to the file) for ffmpeg suggested by a previous posting. I was able to get *almost* proper audio in iMovie, but received knick/knack every 5-10 seconds.

     

    Markus

  • Alan Somers Level 6 Level 6 (9,345 points)

    It sure sounds like Apple broke something in the last update.  There's no other reason why people running the same version of the script, ffmpeg (ClipGrab), and Perian would all of a sudden be having issues.  I'd bet VLC uses its own audio decoder, which would explain why VLC doesn't have a problem.

  • GuyHolmes Level 1 Level 1 (55 points)

    OK, nearly there !!!!!!!    I've got it working, but not sure exactly what was wrong.

     

    As Alan says, and as we were saying above - The script is fine.   I've been working on files for the last month that don't seem to play now.

     

    I tend to record things, batch them together every 2 months or so, and convert them into AIC for editing.   So I couldn't be sure when it broke, other than in the last 6/7 weeks.    After lots of trial and error and lots of perfectly good m4v's being thrown out, I eventually resorted to Time Machine (which I'm not a huge fan of).

     

    I noticed there was a system update in April to 10.6.7 so I went back to 10.6.6 and that seems to have done the trick - All files are playing normally.    I would say that was the fault, but I note that having started the new system, it was asking me if I wanted to update Perian to 1.2.2  and I wonder if that was the cause - I remember early on, Perian (or lack of it) was responsible for a few sound issues.

     

    So my advice to others ...............

     

    i) Roll back Perian to a previous version and see if that does the trick.

     

    ii)  Failing that, get your system back to 10.6.6 - I have mine currently running of a spare external hard disk.

     

    Everything is back to normal again and I can breath a sigh of relief.    I would experiment to see what the actual cause of the problem is, but having spent hours trying to get a working video system, I'm reluctant to break it again!!

  • deltaguru Level 1 Level 1 (0 points)

    Hi

     

    I got it... Guy Holmes was right.

    Uninstall first Perian from the System Preferences > Perian > General > Remove Perian. Right-Click on Perian Icon to remove it completely from the System Preferences.

    Go and download Perian 1.2.1 (not 1.2.2).

     

    Install it.

    Voilà... ;-))

     

    MACOSX rollback is not neccessary.

     

    Roland

  • PaulDorn Level 1 Level 1 (0 points)

    Roland,

     

    You have just beat me to it.

     

    Indeed I found the same solution to be working perfectly! I tested QuickTime, quick preview and iMovie11 and everything is back to normal again!

     

    Thanks everybody and especially Guy for your great support!

     

    Paul

  • tom_walters Level 1 Level 1 (0 points)

    Thanks so much for this guys, got this problem earlier today and was freaked, thought I was going to have to buy some software, but Guy's solution worked out perfectly! Thanks!

  • eisber123 Level 1 Level 1 (0 points)

    Worked fine. I had to use the remove button in Perian and rebooted.

  • timnicholson Level 1 Level 1 (0 points)

    brettf wrote:

     

    Found it!

    Out of the box QT X has issues with M4V and AC3. Google 'quicktime x ac3' for pointers to various discussions on the subject. Seems that some folks are having luck installing Perian, which is a collection of codecs for QT but may require you to run QT in 32 bit mode. I didn't install it since success is not guaranteed.

    Instead, I started playing around with the arguments to ffmpeg and discovered that this minimal command line will work (using Alan's syntax from his workflow):

    ffmpeg -i "$1" -vcodec copy "$1.m4v"

    What this does is re-encode the AC3 track into an AAC track. I couldn't exactly tell if the audio quality was affected. You can also opt to keep the original AC3 track and add a new AAC track with the following command line:

    ffmpeg -i "$1" -acodec copy -vcodec copy "$1.m4v" -newaudio

    Do either of those and you'll get your sound.

    I leave updating your copy of Alan's workflow as an exercise to the reader

    I was so excited when I saw this as I have been trying to get the AVHCD .mts files from my Windows PC over to my new MacBook Air to iMovie to create some videos from my wedding. I've read tons of posts and tried so many different pieces of conversion software and all are insanely slow and the videos look terrible. Horizontal lines all over the place whenever someone moves in the video, garbled sound, etc. This is the first solution that provides decent video quality and since it doesn't actually convert formats, its instantaneous.

     

    I say decent video quality because the horizontal lines aren't there, but it does seem a bit blurry and jerky as the camera moves around.

     

    However, both of these above suggestions for dealing with the sound do produce sound, but the quality is poor. There is a squeeky sounding background noise that interferes with the real sounds in the video. Its as if any background noise is being amplified. i.e. its mildly irritating when there isn't much background noise, but videos from say a hockey game are terrible.

     

    We are so close here I don't want to give up. Can anyone provide a couple more suggestions of audio commands that might produce clear sound?

     

    Here are the details of the video from the Inspector in QuickTime when I used the original automator script (didn't mess with the audio at all):

    Format: H.264, 1920 x 1080, Millions

                AC3, Stereo (L R), 48.000 kHz

    FPS:    59.94

    Current Size: 1384 x 780 pixels

     

    That of course won't play audio at all (haven't tried Perian, but VLC will play it but in VLC the video is terrible with the horizontal lines).

     

    Then with the two alternate command line arguments above, Quicktime shows the AAC track and it plays, but the sound is poor:

    AAC, Stereo (L R), 48.000 kHz 

     

    The fate of my wedding videos lies in the hands of you good people :-D

  • incagraphy Level 1 Level 1 (0 points)

    thanks Alan for all the efforts.

     

    ReWrap seems to work fine for me including the time stamp. However, as another person mentioned earlier, when I import the result video into FCP7, it crashes the program with a "general error" message.

     

    Has anyone got around this?

     

    Also, I have heard suggestions to shoot in Cine Mode of TM700 to get 25p still as a decent output and not forcing us to deal with interlaced video editing if we cannot find the solution to 50p's importing to FCP7. Does anyone know which setting is the Cine Mode?

     

    Any other codec I used made the original file far larger and also problematic to edit (needs rendering and takes long time).

     

    suggestions welcome.

  • incagraphy Level 1 Level 1 (0 points)

    OK. I managed to find the Cinema Mode. It's available if you're not on 1080/50p mode (PAL).

     

    I managed to bring that on to FCP7 with using Clipwrap a commercial version of Alan's convert. But it's a trial version that I have, and I would be happy to use Alan's workaround instead.

     

    Nonetheless, Alan's converts still crash the FCP giving general error.

    Am i the only one getting this crash? If so then perhaps I am doing something wrong.

    I'd appreciate if someone writes their working steps so I check where I am off track.

     

    cheers.

  • m0thr4 Level 1 Level 1 (100 points)

    I downloaded Alan's script; however, I'm having trouble with the audio - it sounds ok, but has been converted/reduced from 5.1 to 2 channel stereo during the conversion process.

     

    Is there a way to preserve the audio?

  • Jsmithnulax Level 1 Level 1 (0 points)

    Will the iMac 21.5" 2.5ghz Core I5 be sufficient enough to edit my files from my Panasonic tm-700 when shot in 60p? I am considering purchasing a new iMac but want to know if I can go for the lower price iMac and have little to no trouble editing or if the I'll have to step it up a notch?

     

    Before I can even understand this thread,which I'd like too but I've never owned a mac and this would be my first purchase, so I'd like to know which iMac would suit me best.

     

    Thanks and please pardon my ignorance

  • eisber123 Level 1 Level 1 (0 points)

    Hi,

     

    After a couple of weeks I finally managed to find a pleasing workflow. Panasonic SD909 to iMovie to iDVD. See http://www.eisber.net/blog/archives/170 for the exact steps.

     

    Markus

Previous 1 11 12 13 14 15 Next