Previous 1 16 17 18 19 20 Next 298 Replies Latest reply: Dec 15, 2013 10:51 AM by Rackland75 Go to original post
  • GuyHolmes Level 1 (55 points)

    There is the quick work around option of splitting larger clips on the camcorder. You can edit individual clips, and split them at a convenient point, then you can import the two smaller clips


    I accept this doesn't solve the problem, it merely gives you a way to work with it!

  • dirbas Level 1 (0 points)

    Thanx, splitting the clip made the it work!


    unfortunately a new problem occured: iMovie 09 does import the .m4v-files but can not cope with the time information. therefore, it fails to create the miniature films which are needed for editing...


    does anybody know about that?


    Is Final Cut Express 4 working fine with the m4v-files ..?

  • Tom Wolsky Level 10 (115,515 points)

    m4v is not a production format and should not be used in any editing application. The media should be converted to QuickTime using Compressor or MPEG Streamclip.

  • richard fujihara Level 1 (0 points)

    HI Tom,

    Please Heip. <>I use TM700 in 1080/60P and can't install into my Free Trial FCP X 10.05.

    I do not use m4v.

    Thank you.


  • Tom Wolsky Level 10 (115,515 points)

    You should try the question in FCPX forum. Describe exactly what you're doing and what happens when you do it.

  • DeSamster Level 1 (0 points)

    To anyone new to this thread (like me):


    The ( link is dead.


    If you want to figure out automator (which I didn't), deltaguru's post on page 19 seems quite helpful.


    I used Toast to convert my .MTS files, which worked great.


    Another option I've seen mentioned (only checked a few pages) is an open source app:  (didn't test this myself)


    Good luck!

  • eray96 Level 1 (0 points)


    I have the version 1.1 and Clipgrab but when i rewrap the .mts file to a .m4v i don't have a sound when I import it to iMovie. If i oppend it on Quicktime Player it has sound.
    I have OSX Mountain lion with Perian 1.2.3.
    With snow leobpard it works well.

  • deltaguru Level 1 (0 points)

    Hi eray96,


    read the thread! The solution is on page 19!

  • eray96 Level 1 (0 points)

    I read it i installed Perian 1.2.1 but i don't have sound too. why?

  • deltaguru Level 1 (0 points)

    Hi eray96,


    I think you got mountain lion, don't you?

    Here the solution from user R08 that worked for me, because I had the same problem.


    AC3 should still play under Mountain Lion in QT X so I'm assuming your problem is with QT 7 and file formats not supported by QT X.


    For me this was happening with .mkv files containing AC3 audio played through QT 7 using Perian (which as I understand it is only getting one more release which may or may not fix this issue).


    Thankfully like all things it's easy when you know how, this is what worked for me.


    Download and extract the A52Codec.component file and replace the one in your Mac's /Library/Audio/Plug-Ins/Components/ directory with it.


    Go to System Preferences > Perian and in the drop down box next to Audio Output: choose Multi-Channel Output, ignoring the warning which will be displayed.


    Close System Preferences.


    This fixed the problem for me in that I can now play my files (H.264 video & AC3 audio in the .mkv container) using QT7 and also export them with the video passed through as is and the audio transcoded to AAC for my Apple TV.


    Hope this helps...



  • deltaguru Level 1 (0 points)


  • timnicholson Level 1 (0 points)

    I've been following this thread for a long time and have pretty much every suggestion in here with varying results. Nothing has given me what I would even call satisfactory results for converting a .mts file to be readable by iMovie. I've been able to get the sound to be decent but the video quality is unnaceptable.


    My solution for finally getting my wedding videos in high quality format into iMovie was to give up on doing it on the Mac and use a PC. I know that's not what anyone wants to hear, but I'm hoping this post will save some people tons of hours of headaches.


    Follow the instructions in this post (another thread in these Apple discussion forums) and you should be all set. Basically its a freeware Windows utility that rewraps the standalone .mts file into a full AVCHD camera package as if I had retained the original camera's volume/file structure. iMovie then loads it in without a hitch... great sound and great video.

  • jonpais Level 1 (0 points)

    I'm glad I didn't read your comment a year ago when I was looking for tips on importing AVCHD into iMovie, or I might never have gotten the excellent results I've been enjoying as a result of following the helpful advice in this thread.

  • Rackland75 Level 1 (0 points)

    Well I had the issue described when I upgraded to mountain lion and fixed it using the instructions you listed. Have just upgraded to mavericks and the problem has manifested itself again.

    The files wrap fine and when double clicked they play in QuickTime and vlc fine. However during the import in iMovie 9.09 the audio is not imported. I have checked the logs and there in an error that States iMovie does not recognise the audio stream.  Files imported before I updated to mavericks, still work fine. I tried iMovie 10 but the final rendering quality is dreadful and only 25fps..


    Please help I'm tearing my hair out.

Previous 1 16 17 18 19 20 Next