12 Replies Latest reply: Apr 18, 2010 3:01 PM by sdhiggins
denkidon3 Level 1 Level 1 (0 points)
Performed a new MacOSX update and the computer restarted normally. After the Apple logo screen, the login page pops up, but it will not let me login to any account, it just goes to blue default screen then back to the login page. I'm not exactly sure what to do, I still have the OS disks, but I don't have Time Machine configured : / whoops.


Macbook Pro, Mac OS X (10.6.2)
  • denkidon3 Level 1 Level 1 (0 points)
    Ran a Disk Utility "Repair Disk" and "Repair Disk Permissions" but still nothing, it still won't load past the log in screen.

    Any ideas?!?
  • denkidon3 Level 1 Level 1 (0 points)
    Ended up reinstalling Snow Leopard, thankfully with all my data and settings intact. Booted from the disk and reinstalled from there. Even though all my information saved, I'm definately going to invest in an external hard drive, just in case.

    Now I wonder what happened in the update that caused this mess in the first place was, it was plugged in and no other application was running at the time...oh well my love/hate relationship with my MacBook Pro is skewed more toward love again.
  • edgydog Level 1 Level 1 (0 points)
    I have exactly the same problem and can't find any solution.
    I didn't made a backup so I can't reinstall everything...
    What can I do ?
  • Sailorj Level 1 Level 1 (5 points)
    OK, I had the same problem and was able to get this issue fixed. Here is what I did:

    1. Boot up with the SL DVD (Insert the DVD and hold the "C" key down).

    2. Use the utility to change my account password to blank. (No Password).

    3. Eject the DVD and reboot. (You'll probably quit the installer... etc).

    4. You will be asked three options, the one you want is to just continue. Don't create a new one, or migrate.

    5. You should log in with no problem except for one, and that's the Keychain is not not associated with your login.

    You can open the Keychain utility and run the Keychain first aid. Also you can and should create a copy of everything in your keychain if you can. My biggest complaint has been that I have a mobile me account and it didn't back up my keychain and restore it for me. I had to mess around with that utility to make it work. So far so good. But at least i'm logged in, which is what I'm sure you'd like to do without installing the OS again!

    Good luck and let me know how it goes.
  • gagsy Level 2 Level 2 (305 points)
    i had the same issue...
    after about 5 attempts i chose shutdown from my options.
    then restarted and it all worked as expected!
  • tas81685 Level 1 Level 1 (0 points)
    I am having the same problems after update I can not log in. However my problem is I am away from home for awhile and do not have my OS disk with me. Is there a solution to this without the disc?
  • nico737330 Level 1 Level 1 (0 points)
    Same here... Restart or shutdown hasn't worked for me...

    Going to try the DVD option now...
  • azmh Level 1 Level 1 (0 points)
    same thing happened with me yesterday. I had to boot from the snow leopard dvd and reinstall the OS.
  • domtom Level 1 Level 1 (0 points)
    Dear Sailorj (judd),
    Congratulations for solving the problem on your machine!
    I encountered the same problem. My iMac has several users. Just one of the users won't login, with the same behavior that has been described in the first post.
    After several unsuccessful password changes and reboots, I tried your solution to no avail.
    I did what you advised (reset psswd to no password from the DVD boot) then reboot, and in the Keychain utility reset the password to none as well.
    Well, everything is still identical. All user accounts log OK except for one (which one of the admin accounts).
    Any idea what I could have done wrong ?
    Best regards
  • nico737330 Level 1 Level 1 (0 points)
    Maybe it's time Apple makes an update to correct the previous update??
  • domtom Level 1 Level 1 (0 points)
    Dear all,
    After a number of failed attempts using DVD boots (still not willing to attempt a re-install) I tried to boot in safe mode (see "safe mode" in Apple support).
    This way I was able to login to the account that was not accessible anymore.
    There I changed or rather set the password (since I had deleted it in my previous attempts).
    Then I rebooted (normal) and voilà it worked. I still don't know why. I can't say it'll work for everyone.
    Nico, seeing this erratic behavior, I think you are right: an update is probably needed.
    Best regards
  • sdhiggins Level 1 Level 1 (0 points)
    I am having the same problem and have been since the 10.6.3 update came out. I've tried restarting in safe mode and then changing the password and it works to log me in; however, once I restart/logout/shutdown my computer, the same exact thing happens again. It's a never-ending cycle of resetting my password and it's really annoying. If anyone has any idea how I can go about fixing this problem that would be great. Thanks