Skip navigation
This discussion is archived

Installed 10.6.3 and now Photoshop CS3 won't open

41599 Views 215 Replies Latest reply: Jul 3, 2010 2:50 PM by salspix RSS
  • leeyahgrl Calculating status...
    Currently Being Moderated
    Apr 1, 2010 11:00 PM (in response to polarcoco)
    I don't think the serial number is the problem. I have 10 characters for my serial system num and it's still crashing.
    MacBook Pro 3,1, Mac OS X (10.6.3)
  • witherman Calculating status...
    Currently Being Moderated
    Apr 2, 2010 12:08 AM (in response to polarcoco)
    Sorry, but this should be the workaround: my MacBook serial number isn't correct??
    And that's the reason why my CS3 apps will not start? I think we're in the 50's or what?
    Adobe: correct this problem, please.
    I'm not having confidence to Adobe anymore........ Because every OS X system update brings problems to Adobe apps!
    MacBook Pro, Mac OS X (10.6.3)
  • MadMacMan Calculating status...
    Looks like this could be my problem as well since my serial number was reset to:

    Serial Number (system): SystemSerialNumb

    during a logic board replacement about a year ago. Now what to do about it?
    iMac Dual Core 2 Duo, Mac OS X (10.4.8)
  • tmclssns Calculating status...
    Currently Being Moderated
    Apr 2, 2010 10:49 AM (in response to polarcoco)
    I'm also affected by this issue.
    Official MacBook Pro from work, official Snow Leopard and CS3 suite from work.

    "System Serial#" is what system profiler is telling me. I don't get it - I'm not sure who's to blame but my guess is Apple since it hasn't been an issue with previous releases until I updated to their latest release.

    *This is a MAJOR concern* I'm working in the web industry and Adobe products are part of our basic stack, our tools we use EVERY DAY and we need to be able to rely on them. Sorry to see that this is no longer the case.

    We could've avoided the hassle, "if it ain't broken, don't fix it" but you'd assume Apple at least tested this since they obviously know that the video/photo and web industry is a large customer of both Apple and Adobe products. Fix it.
    MacBook Pro, Mac OS X (10.6.3)
  • Haven1000 Calculating status...
    Currently Being Moderated
    Apr 2, 2010 11:12 AM (in response to tmclssns)
    I had this same issue. 2007 Mac Pro 8-core (2,1)

    I had a logicboard replaced last year and the repair centre did not reset the Logicboard serial number.
    I took my machine down to my local Apple store today and they reset the serial in 5 minutes (for free). Hey-presto PS CS3 works again.

    Before I took the machine down I also made as series of software changes, whether they made any difference in the end I don't know.

    What I did was;
    delete Library/Preferences/FLEXnet Publisher/FLEXnet folder
    uninstall PS CS3
    run applejack clear cache; system and user
    reinstall PS CS3

    Hope this helps someone.
  • Vlade Divac Level 3 Level 3 (785 points)
    Currently Being Moderated
    Apr 2, 2010 11:22 AM (in response to polarcoco)
    I just got back from the Genius Bar and the only proven solution they have is to revert back to 10.6>10.6.2

    The serial system number and Rosetta "fixes" appear to be red herrings.

    http://kb2.adobe.com/cps/834/cpsid_83499.html

    The other fix is simply to wait for Adobe/Apple's patch, but who knows when (or if) that will be released.
    15" MacBook Pro 2.33GHz 4GB Ram, Mac OS X (10.6.3), iPhone 3G 16GB; Airport Express; Cinema HD Display
  • Sharon Goodman Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 2, 2010 11:57 AM (in response to RoryMac)
    RoryMac: Downloading combo updates has worked for me in the past - BUT - I have yet to be able to find a "10.6.3 Combo update".......found the l0.6.2 ok..... and have gone BACK to this version. Now my CS3 apps work as before. Where can I find it?
    MacMini 1.83 GHz, Mac OS X (10.6.3), 2GB DDR2 SDRAM
  • Sharon Goodman Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 2, 2010 12:20 PM (in response to blubery)
    bluberry: Did as you suggested. Reinstalled 10.6 from the cd, and updated to 10.6.2. All my CS3 apps work fine now. But THIS IS NOT the solution. I do a "clone" backup & so restarted using my System BU drive. Then went to the AppleToolbox & downloaded applejack & YASU. Tried both, they failed. Then found a link to Adobe - http://kb2.adobe.com/cps/834/cpsid_83499.html - (forgive me if I found it here, I have so many sites I've been to) which discussed the system serial number greater than 12 char....which is what I have. So I went to Apple Support & "placed a phone call back" & discussed everything with Jordan (first) and Cory (his supervisor) It seems my original SN was no longer valid due to the fact that when I originally purchased it I had problems with the board recognizing my upgraded DRAMM..so I had to sent it back & they replaced the logic board. Unfortunately who ever did this failed to "give me a new SN". The only way I can get a new SN is to go to an authorized Apple dealer or to an Apple Store. Which is hard for me to do since I'm somewhat disabled and would have to drive 70 miles to Tucson & back. Cory noted that both Adobe & Apple were working on this problem, and since this suggestion was NOT the absolute solution, I should wait a couple of weeks. So that's where I stand at this moment.
    MacMini 1.83 GHz, Mac OS X (10.6.3), 2GB DDR2 SDRAM
  • roadkill_97006 Level 1 Level 1 (5 points)
    I have an 11 digit S/N, and a very clean system as I just installed SL from scratch just before 10.6.3 came out. What I DID have that's on the list is CS3 running in Rosetta. I turned Rosetta off and now CS3 runs fine. Others seem to think that didn't work for them, although most seem to have tried to fix the problem using the "blind blunder" method. In my case, I tried various things but always restored to start from the same place, so I can categorically state that turning Rosetta off fixed MY problem (I may not have made that clear in previous posts). IF the Rosetta "fix" doesn't work on a < 12 digit S/N system then I think there's one more critter loose here than has been identified by Adobe.

    Personally, I believe Apple to be at fault here; no matter how weird the Adobe license scheme is (and it IS weird!), it did work until the update.
    Mac Pro 4-core 3GHz 12GB 8800GT, Mac OS X (10.6.3)
  • Nick Savas Level 1 Level 1 (130 points)
    All I did was have my serial number inserted in my new mother board and photo shop CS3 worked like Magic. UNBELIEVABLE, SUCH A SIMPLE FIX.
    Imac 3.06 GHz intel Core 2 Duo, Mac OS X (10.6.3), 4gb ram
  • Vlade Divac Level 3 Level 3 (785 points)
    Hey Nick -

    A) Where do you find the serial?

    B) How do you update your system with it?
    15" MacBook Pro 2.33GHz 4GB Ram, Mac OS X (10.6.3), iPhone 3G 16GB; Airport Express; Cinema HD Display
  • Nick Savas Level 1 Level 1 (130 points)
    I took the Mac to the Apple store I bought it from and the tech knew where to find it. The he boots up from a CD containing a special application just for this purpose. It took about 2 minutes. It was free for me because they replaced the mother board and forgot to insert Serial No.
    Imac 3.06 GHz intel Core 2 Duo, Mac OS X (10.6.3), 4gb ram
  • Nick Savas Level 1 Level 1 (130 points)
    on my iMac the Number is on the bottom of the STAND
    Imac 3.06 GHz intel Core 2 Duo, Mac OS X (10.6.3), 4gb ram
  • maleorderbride Calculating status...
    The Serial Number is definitely not a red-herring.

    I normally use CS4, but I just installed CS3 to check. It worked fine under 10.6.3.

    I then changed my serial number from 11 digits to 14. It crashed within 2 seconds of opening.

    I do not know if this is a bug, a poorly executed DRM setting, or what, but it is 100% completely and instantly fixed by changing to a shorter serial number. I suggest you take your Mac to the Apple Store and have them fix it right now instead of waiting for a software patch.

    If that does instantly fix it then I would assume you need to un-install, clean caches, then re-install. I just did a fresh install of CS3 in order to test this, but I already had 10.6.3 installed.

    edit:
    Oh, also, in order to simulate replacing a logic board I just deleted my serial entirely. The default OS X injects is longer than 11 digits. Thus, as the above user noted, if you had your logic board replaced but the tech did not also re-assign you a SN, then you would suffer from this bug.

    Message was edited by: maleorderbride
    Mac Pro (4,1), Mac OS X (10.6.3)
  • Nick Savas Level 1 Level 1 (130 points)
    take your mac back to the store and the techs can fix it for you in about 2 minutes
    Imac 3.06 GHz intel Core 2 Duo, Mac OS X (10.6.3), 4gb ram
1 ... 7 8 9 10 11 ... 15 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.