Previous 1 2 3 4 Next 213 Replies Latest reply: Aug 4, 2010 10:21 AM by Photoshop Prof Go to original post
  • rickyfc Level 1 Level 1 (10 points)
    Immediately following the reboot after installing 10.6.3, the keyboard & trackpad no longer function on my 2-week old MBA. The USB mouse is fine. After a cold reboot, the keyboard SOMETIMES functions for about 1-2 minutes, then goes dead with no response whatsoever from any key or the trackpad and it stays that way, never regain keyboard functionality again until the machine is turned off/on. Usually, though, it's just DOA. The login screen, though, always allows keyboard input; it's not until after the desktop draws that the keyboard dies.

    Since it's a brand new box and only 2-weeks old, I haven't installed ANY software whatsoever. Whatever software Apple preinstalled is all that is on this machine so it's not a conflict with anything I've installed.

    Rebuilt back to 10.6 and everything is OK again.
  • gtufaro Level 1 Level 1 (0 points)
    I may have come up with a solution... not sure yet, but everything seems like it's working better. I ran "Purity" and deleted every cache, etc. that Purity could possibly clean up. Since then, I haven't had any more stalling problems. It seemed like the majority of the freezes were having something to do with Safari and/or Finder/Spotlight. Since everything has been cleaned out, I haven't been having any freezes for the past 10 minutes (which is longer than I was able to go before).

    Would love to see somebody else try this and let the rest of us know if this is a potential fix.

    I'll keep you posted on if things go south
  • R_H_B Level 1 Level 1 (5 points)
    I have been having this same problem for the past 24 hours. My keyboard and cursor just freeze for 5 -10 secs and then recover on their own. It is happening every few minutes now and it has become so annoying that I am rolling back to the OS 10.6.2 backup I prepared prior to doing the 10.6.3 update.

    I have performed every system cleaning procedure I know. (Disk repair, Disk Warrior rebuild, repair permissions, Cocktail system clean, reset Pram and Power Mgr, reinstall update and Safari (web kit) in safe mode, turn off every Safari/System utility I have, delete all Logitech software, NOTHING has worked. I have been using Macs for more than 25 years and this is the the most aggravating issue I have ever had. I couldn't even complete this message without a slew of freezes and keyboard glitches.

    I will not reinstall 10.6.3 until I read that Apple has an answer for this issue. Security issues and improvements are not important to me when I can't even use my computer.
  • gtufaro Level 1 Level 1 (0 points)
    RHB... I tried everything that you are saying as well and none of those options worked.

    But, now I'm almost 45 minutes in after doing a clean through "Purity" and haven't had one mouse or keyboard freeze. I'd try it before you go through the pain of reinstalling an older backup.
  • gtufaro Level 1 Level 1 (0 points)
    Several hours have passed now and no freezing... I think problem solved! People on this thread, do yourself a favor and run Purity and then check back in. Would love to hear everybody else's results.

    (P.S. I have a MILLION things installed on my computer... Final Cut, Logic, iLife, Avid, etc... any number of things could have conflicted with the 10.6.3 install. I'm happy to say it seems like the stalling had something to do with hidden files on the computer that were being accessed for whatever reason and are now no longer there.)
  • gtufaro Level 1 Level 1 (0 points)
    ARGH!!! Just a minute ago, went to my bookmark bar in Safari and the mouse froze for a few seconds.

    ARGH. Now, as I'm typing this message, I'm have keyboard problems and the mouse has disappeared from the screen.

    Had to put the laptop to sleep and open it back up for the mouse to reappear. ;(

    Sorry for being hopeful.
  • R_H_B Level 1 Level 1 (5 points)
    Sorry to hear your "fix" has failed. I am not familiar with Purity but I had already done a deep clean of ALL caches using Snow Leopard Cache Cleaner, with no luck. In desperation I was about to try your procedure but now it looks like the only way I'm going to regain use of this computer is to roll back to 10.6.2.
  • jmschaeffer Level 1 Level 1 (0 points)
    Which options did you choose for Purity? I chose the option to delete "All Caches" and after rebooting the mouse and keyboard froze right away and it even did it as I was typing this reply. Let me know and I'll choose other options.

    Never mind, I just re-read your last reply that it didn't work. Arghh!!!

    What's weird is the trackpad will lock up, I can move my Bluetooth mouse and then it starts working again. At times like this I hate being on the cutting edge.

    Message was edited by: jmschaeffer
  • Picasosz Level 1 Level 1 (0 points)
    Having the exact same Problems Ran Purity worked for about 15 minutes the Magic Mouse Started Freezing again Mac Pro 2008 (Early Spring) Octo with 10GB of Ram
  • gtufaro Level 1 Level 1 (0 points)
    I keep going back to the problem having something to do with Safari or Spotlight... so, I had Spotlight reindex and reinstalled Safari 4.0.5.

    Seems like I'm problem free again... definitely not having the number of interruptions I was having prior to doing all of these cleanups... has to have something to do with the file system, but what? is the question.

    Keeping my fingers crossed again.
  • R_H_B Level 1 Level 1 (5 points)
    Well I'm back on 10.6.2 and everything is working normally again. My suspicion is that the changes Apple made to the USB sub system to "improve the reliability of certain third-party USB devices" is the culprit here. My only noticeable problems involved keyboard and trackpad functions which are part of that system. The lesson here is ALWAYS have a current backup handy before applying an Apple system update.
  • antekaudi Level 1 Level 1 (0 points)
    I am having the same problem. Right after update to 10.6.3 i am experiencing problems with my mouse and keyboard.

    Mouse will disappear and keyboard will start to type realllllyyy SLOW. After 1-2minutes problems fixes itself.

    It happens every few minutes.

    Anyone knows a fix for this yet ?

    If no, how do you go back to 10.6.2 ?

    Thanks
  • Doerks Level 1 Level 1 (0 points)
    Same problem here in Germany.

    Can anyone else see those errors:
    Mar 31 22:45:01 macbookpro kernel[0]: AppleUSBMultitouchDriver::_deviceGetReport - DeviceRequest returned error 0xe00002ed (interface 0, reportID 0x0)
    Mar 31 22:45:01 macbookpro kernel[0]: AppleUSBMultitouchDebug: _deviceGetReport returned an error in configurePower

    I´m doing a "tail -f /var/log/kernel.log" while the error occurs!

    regards
  • xcfmx Level 1 Level 1 (0 points)
    Not exactly the same as Doerks, but I do see an error in kernel.log

    kernel[0]: AppleUSBMultitouchDriver::validateChecksum - 18-byte packet checksum is incorrect (expected 0x2f2, checksum bytes were 0xe57)
  • Doerks Level 1 Level 1 (0 points)
    Do have this error, too.
Previous 1 2 3 4 Next