Skip navigation
This discussion is archived

TrackPad Freezes Applications when two finger swiping down to scroll

8281 Views 20 Replies Latest reply: Apr 23, 2010 5:07 PM by cater RSS
1 2 Previous Next
Jeff.Hamersly Calculating status...
Currently Being Moderated
Mar 30, 2010 11:26 PM
I have been using this mac for over 7 months with no problems. I recently purchased the snow leopard install CD and installed the OS update on both of my macbooks.

The first install on the other macbook worked fine.

However, after the second install on the second macbook a problem occurred. Everytime I opened an application it seemed to crash. The time varied from application to application, and I could not figure out why they were crashing.

After awhile of testing I found that the applications only crashed when I used the two finger swipe to scroll down the page.

I have removed all extranious preference panes, and have installed the magic mouse update in hopes that this would solve my problem.

For now I am stuck using just the magic mouse, as any normal use of the trackpad involves scrolling down, and ends up crashing my application. Whether it be Coda, BBedit, PS or Firefox

Please help.. If you need any more information please let me know.

PS. I have been searching these forums for a couple weeks now and have not found a problem similar.
MacBook Pro, Mac OS X (10.6.3)
  • alezz Calculating status...
    Hi, me too I have the same problem ("Wireless Mouse Software Update can't be installed on this disk. ERROR_VOLUME") after installing the 10.6.3 Update combo on a fresh installation of Snow Leopard. Any clue? Thanks
    iMac 8,1- 2,4 GHz - 4Gb Ram, Mac OS X (10.6.3)
  • Binh Do Calculating status...
    Hi, I also have this problem with "Wireless Mouse Software Update can't be installed on this disk. ERROR_VOLUME". I've tried and searched over the web but can't find any solution. Anybody help please!
    Macbook Pro 15", Mac OS X (10.6.3)
  • mnsink@hotmail.com Calculating status...
    i'm having the same problem with "alezz".

    after spending 2 hours downloading the mac update combo, it won't let me install the magic mouse software update. "software update can't be installed on this disk. error_volume" appears....

    so discouraging...

    any help, please?
    macbook, Mac OS X (10.6.3)
  • witchmd Calculating status...
    I'm experiencing the same problem. I'm on 10.6.3 and I'm trying to install the wireless mouse software update 1.0 for snow leopard and I get the can't be installed on this disk error_volume.
    Macbook 2.2 White 4G RAM 250GB HD, Mac OS X (10.5.3)
  • jzuberbuehler Calculating status...
    just purchased the magic mouse and I have the same issue...

    "Wireless Mouse Software Update can't be installed on this disk. ERROR_VOLUME"

    Performed a repair of disk permissions. No Joy!
    iMac, Mac OS X (10.6.3)
  • pfemmino Calculating status...
    Hi,
    I've solved the issue, but I'm not sure how (and I cannot do it again). So, I will post both the solutions, maybe someone fill find 'em useful. Be warned: You will use this solutions on your own risk, and I won't be held responsible for anything that could happen to your software, data, computer, life etc.

    Solution a) modify plist
    Edit the file (you need to use 'sudo') /System/Library/Extensions/AppleBluetoothMultitouch.kext/Contents/version.plist
    So, open a Terminal window, and use the following command:

    +sudo vi /System/Library/Extensions/AppleBluetoothMultitouch.kext/Contents/version.plist +

    You will find about 10 lines, among these:
    <key>CFBundleShortVersionString</key>
    <string>1.1.2</string>

    Simply change the "1.1.2" version string to "1.1".

    Reboot, and try to install the Wireless Mouse Update. It should install without any problem. Reboot again, and your mouse -should- be recognized correctly.

    Should this solution not work:

    Solution b) Downgrading the AppleBluetoothMultitouch.kext kernel extension.
    If you're using Time Machine, simply downgrade the /System/Library/Extensions/AppleBluetoothMultitouch.kext directory to a date earlier than the 10.6.3 upgrade. After the downgrade, reboot the machine, and install the Wireless Mouse Update. Reboot again, and you should see the Magic Mouse options in the Preferences Pane.

    Hope this helps.
    MacBook Pro, Mac OS X (10.5.1)
  • mshaver1 Calculating status...
    The first option worked fine for installing the Wireless Mouse Update, but for some reason didn't fix the issue of the mouse not being responsive even though it's connected! I did try the second option as well, but same issues.

    When I use the Mouse Preferences option, it won't pair, but the bluetooth preferences pairs the mouse fine and connects. But even when it's connected, it isn't responding.
    MacBook Pro, Mac OS X (10.6.3)
  • pfemmino Level 1 Level 1 (0 points)
    Hi,
    well, my mouse was being detected already before installing the update or any hack... it simply was detected as a "normal" mouse, no touch indeed...
    iMac 24", Mac OS X (10.6.3)
  • Mac_since_1982 Calculating status...
    Same problem. Also tried repair and no luck. Reinstalled Snow Leopard 10.6.3. No joy. Magic Mouse works as a regular one-button mouse but no added "touch" features such as scroll and zoom. Argh.
    iMac 10.1, Mac OS X (10.6.3)
  • jzuberbuehler Level 1 Level 1 (0 points)
    Well - not going to go through the hassle of reinstalling anything / hacking anything. Magic mouse returned to the magic apple store.

    FAIL!
    MBP, Mac OS X (10.5.2)
  • nearjock Calculating status...
    I am getting the same error. A new Magic Mouse from the Apple (not so Magic) Store. I would like to know why my primary (and only) drive with the OS installed is getting an error with the Snow Leopard Download for the Magic Mouse software from Apple's site: http://support.apple.com/kb/DL950

    Please fix and update the installer so I can install the Magic Mouse.

    My Magic Mouse will connect and pair with Bluetooth and identifies itself as Apple Wireless Mouse.
    Mac Mini Dual Core, Mac OS X (10.6.3), 500GB HDD, 2Gb RAM, Apple Mini-Keyboard & Mighty Mouse
  • cater Calculating status...
    well, same here. Tried to install on a 10.6.3 (upgraded from 10.5.x) but no luck, with the above hack my Magic Mouse works just like another 2 button mouse with no wheel.
    On a secondary HD (10.6.1, Snow Leo fresh installation) the Magic Mouse update works fine and the mouse does what it should do!
    On a Mac Book, 10.6.3 (Snow Leo fresh installation) again it works perfectly (apart from pointer speed a little "slow" for my needs).

    So what? Maybe something depending on having upgraded from 10.5.x to 10.6.x? Got no time to make a whole backup and reinstall everything... so c'mon Apple, we need a fix!!!
    Mac Pro 2x2.8 Quad Core, Mac OS X (10.6.2)
  • vivanzin Calculating status...
    Same problem here. Waiting for a solution...
    iMac, Mac OS X (10.6.3)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.