Previous 1 98 99 100 101 102 Next 1,733 Replies Latest reply: Jul 29, 2015 7:41 PM by retiarius Go to original post Branched to a new discussion.
  • freandc Level 1 Level 1 (0 points)

    OK, it's a little premature to say without reservation that I've got the kext fix working on Mavericks but here are the indications:

     

     

    Console messages - loaded the three old kexts with warnings but no errors

    -----

    10/28/13 12:16:09.369 PM com.apple.kextcache[562]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    10/28/13 12:16:09.670 PM com.apple.kextcache[562]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATIFramebuffer.kext"

    10/28/13 12:16:09.983 PM com.apple.kextcache[562]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATI2600Controller.kext"

     

     

    System report shows extensions as follows:

     

     

    ATI2600Controller:

     

      Version: 1.6.6

      Last Modified: 10/28/13, 11:52 AM

      Loaded: Yes

      Get Info String: ATI2600Controller 1.6.6.25 (7429)

      Obtained from: Unknown

      Kind: Intel

      Architectures: i386, x86_64

      64-Bit (Intel): Yes

      Location: /System/Library/Extensions/ATI2600Controller.kext

      Kext Version: 6.0.6

      Load Address: 18446743521834800000

      Valid: Yes

      Authentic: Yes

      Dependencies: Satisfied

      Signed by: Unknown

     

    ATIFramebuffer:

     

      Version: 1.6.6

      Last Modified: 10/28/13, 11:52 AM

      Loaded: Yes

      Get Info String: ATIFramebuffer 1.6.6.25 (7429)

      Obtained from: Unknown

      Kind: Intel

      Architectures: i386, x86_64

      64-Bit (Intel): Yes

      Location: /System/Library/Extensions/ATIFramebuffer.kext

      Kext Version: 6.0.6

      Load Address: 18446743521834700000

      Valid: Yes

      Authentic: Yes

      Dependencies: Satisfied

      Signed by: Unknown

     

    ATISupport:

     

      Version: 1.6.6

      Last Modified: 10/28/13, 11:52 AM

      Loaded: Yes

      Get Info String: ATISupport 1.6.6.25 (7429)

      Obtained from: Unknown

      Kind: Intel

      Architectures: i386, x86_64

      64-Bit (Intel): Yes

      Location: /System/Library/Extensions/ATISupport.kext

      Kext Version: 6.0.6

      Load Address: 18446743521831400000

      Valid: Yes

      Authentic: Yes

      Dependencies: Satisfied

      Signed by: Unknown

     

    And so far no freezes.

     

     

    Procedure followed:

     

     

    1. Install kexts as usual with kext_helper.

    2. Make backup copies elsewhere and then remove:

              /System/Library Extensions/AMDSupport.kext

              /System/Library/Extensions/AMDFramebuffer.kext

              /System/Library/Extensions/AMD2600Controller.kext

    3. Reboot

     

     

    My system configuration is:

      Model Name:          iMac

      Model Identifier:          iMac8,1

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          2.8 GHz

      Number of Processors:          1

      Total Number of Cores:          2

      L2 Cache:          6 MB

      Memory:          4 GB

      Bus Speed:          1.07 GHz

      Boot ROM Version:          IM81.00C1.B00

      SMC Version (system):          1.30f1

     

     

    It would be nice to understand if there has been additional functionality added to the drivers and what features of more recent OS’es won’t work (perhaps AirPlay functionality, for example) but given a choice, I’d gladly give up the new functionality for a stable machine.

     

     

    I will post again after a day or two and report if things continue to be stable.

  • SwampFoetus Level 1 Level 1 (0 points)

    Can I just confirm, freandc, that you installed the ATI kexts and removed the AMD ones;

     

    1. Install kexts as usual with kext_helper.

    2. Make backup copies elsewhere and then remove:

              /System/Library Extensions/AMDSupport.kext

              /System/Library/Extensions/AMDFramebuffer.kext

              /System/Library/Extensions/AMD2600Controller.kext

    3. Reboot

    If that's correct, what was the reason for removing the AMD kexts?  Just curious more than anything.

  • aieronimo Level 1 Level 1 (0 points)

    Thanks, freandc.  As you earlier had posted that the "kext fix" drivers were not being loaded, but now you are reporting that they are being loaded, can you clarify what you are doing differently now than in your previous try since upgrading to Mavericks?  Is it the deletion of the three kext files with "AMD" in their names?  If so, then it may be that deleting those "new" "AMD"-named drivers forces Mavericks to install the old "ATI"-named drivers.  Whereas if you don't delete the "new" drivers, then Mavericks ignores the "old" ones and just loads the "new" ones.  Does that sound right to you?

     

    Of course, I realize it is still early and we should wait a few days to see how things go with your system.  But if you are deleting "new" drivers, installing "old" ones, and the computer still is booting up without problems, it is a hopeful sign...

     

    Thanks again for posting on your experience and I am looking forward to your updates.

  • Chris J. Level 1 Level 1 (30 points)

    I tried this fix and mine has been running smoothly.  I deleted the AMD 2400 because that is the system driver I have.  I did save them in a sperate folder in case I need them. 

  • Tim Isham Level 1 Level 1 (15 points)

    I have a 7,1 iMac and have been using the kext fix with each update since 10.6.3.  I tried updating to Mavericks and without the kext fix had the screen freezing problem, so I tried the kext fix the same way and my iMac seems stable so far.  I will post again if the freezing returns, but so far it has worked the same for Mavericks as it has for every other update since 10.6.3 (prior to Mavericks I had updated every iteration up to 10.8.5 using the kext fix.)

  • freandc Level 1 Level 1 (0 points)

    SwampFoetus,

    That's correct. Removed the AMD kexts. Briefly, I think this is pretty much just a packaging issue. We've been replacing new versions of the ATI kexts until now and in Mavericks the new versions are just bundled in the AMD files. Because the hardware id of the graphics card is matched at boot, the machine will find a version and then try to satisfy all of the class dependencies. If the match is found in the AMD kext, the dependency chain gets resolved in the other AMD files. If the initial match is in the ATI files, it appears to work the way we want. I don't know whether the hardware id matching does a first come first served approach or whether it checks version numbers as well but I suppose it is conceivable that if you renamed all the ATI files AAA so that they were alphabetically earlier than the AMD files, it might work. I'd hope, however, that in addition to the hardware id's, the boot sequence checks version numbers and tries to use the latest version.

  • freandc Level 1 Level 1 (0 points)

    aieronimo,

    Yup. That's it, I think. Deleting the newer versions allows the older ones to get loaded. I'll add that, during testing, I managed to boot without either of the ATI2600 or AMD2600 driver getting loaded and it reverted to a more generic driver (with some noticeable screen glitches). Again, I don't know what the search/acceptance order for matching drivers is but this is one sure way to make sure the later drivers don't get used.

     

    As far as status goes, I've been driving my machine pretty hard today and no problems. After my initial Mavericks install, I had a freeze within 2 hours so this is looking good.

  • shaulauray Level 1 Level 1 (0 points)

    freandc: Thank you for testing this!

     

    I am also hoping that someone in this forum can find a solution to this problem when Apple doesn't want to fix the problem since OS X 10.6.3...

     

    The kext files worked fine on Mountain Lion, but they don't work on Maverics.

  • bobtibb Level 1 Level 1 (0 points)

    Hi, more to report:

     

    I loaded Mavericks on an external drive and tested whether or not it would work once I had loaded the 10.6.2 kexts with Kext Wizard and removed the AMD kexts (in my case for the 2600 card). I rebooted and loaded the system again from the external drive. It loaded and was working. So, I took the plunge and installed Mavericks onto my Mac. Installed the 10.6.2 kexts and then removed the AMD ones from the System/Library/Extensions folder. I rebooted and the Mac loaded up ok. I then did a Fix File Permissions. I have been working on the Mac, installing and updating software since then and (touch wood) it is still working. So I can confirm the earlier posts that this fix 'seems' to work. Of course, time will tell but I will let you know if it does freeze! Fingers crossed, yet again.

  • alexsader78 Level 1 Level 1 (0 points)

    I would like to report here, that since 2 days I am not having any problems whatsoever.

     

    At first I did the Kext fix, but my computer was still freezing. Then 2 days ago I repaired permissions using Disk Utility. Maybe it helped, I really don't know, but the fact is that my computer is working like a charm. (m

     

    I have an Imac 7,1 (Mid 2007) 2 GHz processor, 4 GB memory. Graphics ATI Radeon HD 2400XT 128MB.

     

    Thank you all for your help.

  • bobtibb Level 1 Level 1 (0 points)

    This was in the system log, if this helps:

    Oct 28 20:18:03 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 20:18:07 bobtibb-6 kernel[0]: OSMetaClass: Kext com.apple.kext.ATISupport class ATIController is a duplicate;kext com.apple.kext.AMDSupport already has a class by that name.

    Oct 28 20:18:07 bobtibb-6 kernel[0]: Kext com.apple.kext.ATISupport start failed (result 0xdc00400a).

    Oct 28 20:18:07 bobtibb-6 kernel[0]: Kext com.apple.kext.ATISupport failed to load (0xdc008017).

    Oct 28 20:18:07 bobtibb-6 kernel[0]: Failed to load kext com.apple.kext.ATISupport (error 0xdc008017).

    Oct 28 20:18:07 bobtibb-6.local com.apple.kextd[12]: Failed to load ATISupport.kext - (libkern/kext) kext (kmod) start/stop routine failed.

    Oct 28 20:18:07 bobtibb-6.local com.apple.kextd[12]: Load com.apple.kext.ATISupport failed; removing personalities from kernel.

    Oct 28 20:21:21 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 20:21:23 bobtibb-6 kernel[0]: OSMetaClass: Kext com.apple.kext.ATISupport class ATIController is a duplicate;kext com.apple.kext.AMDSupport already has a class by that name.

    Oct 28 20:21:23 bobtibb-6 kernel[0]: Kext com.apple.kext.ATISupport start failed (result 0xdc00400a).

    Oct 28 20:21:23 bobtibb-6 kernel[0]: Kext com.apple.kext.ATISupport failed to load (0xdc008017).

    Oct 28 20:21:23 bobtibb-6 kernel[0]: Failed to load kext com.apple.kext.ATISupport (error 0xdc008017).

    Oct 28 20:21:23 bobtibb-6.local com.apple.kextd[12]: Failed to load ATISupport.kext - (libkern/kext) kext (kmod) start/stop routine failed.

    Oct 28 20:21:23 bobtibb-6.local com.apple.kextd[12]: Load com.apple.kext.ATISupport failed; removing personalities from kernel.

    Oct 28 20:25:39 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 20:25:40 bobtibb-6 kernel[0]: OSMetaClass: Kext com.apple.kext.ATISupport class ATIController is a duplicate;kext com.apple.kext.AMDSupport already has a class by that name.

    Oct 28 20:25:40 bobtibb-6 kernel[0]: Kext com.apple.kext.ATISupport start failed (result 0xdc00400a).

    Oct 28 20:25:40 bobtibb-6 kernel[0]: Kext com.apple.kext.ATISupport failed to load (0xdc008017).

    Oct 28 20:25:40 bobtibb-6 kernel[0]: Failed to load kext com.apple.kext.ATISupport (error 0xdc008017).

    Oct 28 20:25:40 bobtibb-6.local com.apple.kextd[12]: Failed to load ATISupport.kext - (libkern/kext) kext (kmod) start/stop routine failed.

    Oct 28 20:25:40 bobtibb-6.local com.apple.kextd[12]: Load com.apple.kext.ATISupport failed; removing personalities from kernel.

    Oct 28 21:02:47 bobtibb-6.local com.apple.kextcache[846]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

  • bobtibb Level 1 Level 1 (0 points)

    I think these are the same sort of reports that 'freandc' is giving:

     

    Oct 28 20:16:54 bobtibb-6.local com.apple.kextd[12]: Cache file /System/Library/Caches/com.apple.kext.caches/Directories/System/Library/Extensi ons/KextIdentifiers.plist.gz is out of date; not using.

    Oct 28 20:16:54 bobtibb-6.local com.apple.kextd[12]: Cache file /System/Library/Caches/com.apple.kext.caches/Directories/System/Library/Extensi ons/KextIdentifiers.plist.gz is out of date; not using.

    Oct 28 20:18:03 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 20:21:21 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 20:25:39 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 20:31:09 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATI2600Controller.kext"

    Oct 28 20:31:13 bobtibb-6.local com.apple.kextd[12]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATIFramebuffer.kext"

    Oct 28 21:02:47 bobtibb-6.local com.apple.kextcache[846]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATISupport.kext"

    Oct 28 21:02:47 bobtibb-6.local com.apple.kextcache[846]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATIFramebuffer.kext"

    Oct 28 21:02:48 bobtibb-6.local com.apple.kextcache[846]: WARNING - Invalid signature -67061 0xFFFFFFFFFFFEFA0B for kext "/System/Library/Extensions/ATI2600Controller.kext"

     

    I am not sure what this really means . . . is this a 'good' sign or not?

  • bobtibb Level 1 Level 1 (0 points)

    Hi

    My System report is the same as 'freandc':

     

    ATI2600Controller:

     

      Version:    1.6.6

      Last Modified:    28/10/2013 20:21

      Loaded:    Yes

      Get Info String:    ATI2600Controller 1.6.6.25 (7429)

      Obtained from:    Unknown

      Kind:    Intel

      Architectures:    i386, x86_64

      64-Bit (Intel):    Yes

      Location:    /System/Library/Extensions/ATI2600Controller.kext

      Kext Version:    6.0.6

      Load Address:    18446743521822600000

      Valid:    Yes

      Authentic:    Yes

      Dependencies:    Satisfied

      Signed by:    Unknown

     

    ATIFramebuffer:

     

      Version:    1.6.6

      Last Modified:    28/10/2013 20:21

      Loaded:    Yes

      Get Info String:    ATIFramebuffer 1.6.6.25 (7429)

      Obtained from:    Unknown

      Kind:    Intel

      Architectures:    i386, x86_64

      64-Bit (Intel):    Yes

      Location:    /System/Library/Extensions/ATIFramebuffer.kext

      Kext Version:    6.0.6

      Load Address:    18446743521828600000

      Valid:    Yes

      Authentic:    Yes

      Dependencies:    Satisfied

      Signed by:    Unknown

    ATISupport:

     

      Version:    1.6.6

      Last Modified:    28/10/2013 20:21

      Loaded:    Yes

      Get Info String:    ATISupport 1.6.6.25 (7429)

      Obtained from:    Unknown

      Kind:    Intel

      Architectures:    i386, x86_64

      64-Bit (Intel):    Yes

      Location:    /System/Library/Extensions/ATISupport.kext

      Kext Version:    6.0.6

      Load Address:    18446743521822300000

      Valid:    Yes

      Authentic:    Yes

      Dependencies:    Satisfied

      Signed by:    Unknown

     

    Not frozen yet . .  .

  • Simon Baker Level 1 Level 1 (135 points)

    just to update - continued to have freezes with just the old kext fix - currently it seems to behave with a daily boot. Thanks for continuing to experiment everyone, will probably apply the updated work around (…hack…) when it freezes next. Console sometimes reports GPU crash, but not everytime - which is the same as ever.

     

    (I also had better stability some time ago by ramping up the fans - like I said, it is a very strange issue)

  • bobtibb Level 1 Level 1 (0 points)

    Hi

    Just to update. Since the 'fix' listed previously . . . still purring along! Mac has been in use all day. No probs . . .

    Bob