Previous 1 105 106 107 108 109 Next 1,729 Replies Latest reply: May 1, 2015 5:45 PM by DjeffreyDjevrick Go to original post Branched to a new discussion.
  • dukelukic Level 1 Level 1 (0 points)

    Hi everyone--20" iMac 7,1 ATI 2400. Running 10.9.1 since early February with Krysztof's (thank you!) fix. Just fine, not one crash. Updated to 10.9.2 yesterday (2/26/14). Update reinstalled AMD drivers, but didn't get rid of the old 10.6.2 ATI drivers--they just don't load. Was keeping my fingers crossed that Apple fixed something, because the AMD 2400 driver, frame buffer and support kexts seem to be pretty recent--dated 1/28/14 on my computer.

     

    No such luck. Classic freeze crash this morning (mouse pointer moves, nothing else responds). So I deleted the three new AMD kexts, leaving the old ATI kexts. Rebooted, OnyXed, and everything seems to be fine--the three old ATI kexts are loaded, and everything else seems fine. More on the story as we go forward...

     

    One strange thing--on this machine when I did the original kext fix last month, I noticed that there is an ATI X2000 kext that is also loading (also several related files if you look in the system/library/extensions folder). Tried deleting them when I first did the kext fix under 10.9.1, and that's a mistake. Something in there seems to be required--after deleting, video was choppy, slow, terrible--kind of like my old Powermac 7200 ;^), as if no quartz or OpenGL or whatever it may be. So if you see that those are loaded, leave them--doesn't seem to be causing any problems.

     

    Thanks to everyone who has contributed to this topic (especially Mr. Turek). New life for a 7-year-old computer--who'd believe it?

  • forevermacintoe Level 1 Level 1 (0 points)

    I've had a number of different screen issues on my iMac 24" Core 2 duo (ATI Radeon card) after the Maverick update.  Initially, the screen would simply turn off.  I thought perhaps the screen was overheating, so I installed SMCfancontrol to manually speed up the fans.  This worked for several weeks.  After the 10.9.1 update, the screen began to freeze very frequently, requireing forced reboot.  I tried the kext fix mentioned a few pages back in this thread, which seemed to work at first, but then the issue started happening again, and with more frequency.  Updating to 10.9.2 did not resolve the issue, so I ultimately did a manual download of the Maverick OS 10.9.2, and did a fresh install (which removes the kext fixes).  This *seems* to have fixed the problem (for the last 48hrs).   Previously, I was easily able to trigger the issue in minutes by playing some movies in VLC, but I can no longer reproduce the problem.

     

    Hope this saves someone else time...

  • Semih_TX Level 1 Level 1 (0 points)

    Hi, could you explain what is involved in manual download and fresh install? Do you do this through a safe boot mode, or OSX recovery mode (during startup press and hold ctrl+R), or you just go to the app store and download the Maverick OS? And does the fresh install mean wiping down the hard drive clean and start over? Thank you for your help.  My iMac is running but running very slow after the kext fix.

  • forevermacintoe Level 1 Level 1 (0 points)

    Well, it froze again today, so I'm not sure it worked....   In any case if you go to the app store, and search for Maverick OS, you'll see a download link.  It should auto-start the installer and does a fresh install.  It does not delete files, but it does reset some settings.

  • Phil_O_ Level 1 Level 1 (0 points)

    Thanks for the updates on this thread.  I gave up with my iMac after my last posts in this thread.  I did do the usual Kext updates and removed the AMD files,  but then emptied my room to do some decorating and this machine just hasn't been used at all in the 5-6 months since.  When I set my desk back up after finishing the decorating I went with a Mac Mini I had spare and switched to using that as my main machine.  I just couldn't be bothered with testing out the the iMac again after 4 years off hassle.

     

    Well today I decided to bring it out of hiding and see if either 10.9.1 or 10.9.2 had finally fixed the problem and so I fired up the iMac again. Everything was ok in 10.9.0 and I used it for a few hours updating all my apps without issue.  I then installed the 10.9.2 combo update and rebooted.   I have to say I wasn't completely surprised when my first freeze came at the login prompt straight after installing the update. 

     

    I've just been reading the last few pages since my last visit and thanks to all who have contribute, its pretty sad to see were still in the same situation.

  • autumnbliss Level 1 Level 1 (0 points)

    Sorry for the bump but no fix to this? My 20" iMac (early 2008) is having this issue since Snow Leopard came out, tried to install the official fix and nothing works.

     

    I get various screen crashes on my iMac are either the striped screen from the original poster, black screen, frozen screen with mouse pointer still working, white screen, blue pinstriped screen... It's almost impossible to work under these conditions and since I live in Brazil and everything here is insanely overpriced and there's no such thing as a Genius Bar, I wonder if I can take it to repair even if it's not under warranty anymore since it's Apple's fault, not mine (I might be wrong anyways...)

     

    Any suggestions?

  • forevermacintoe Level 1 Level 1 (0 points)

    Bump.

     

    I've heard rumors that there is a new driver in beta phase.  There was a reply posted here that was later deleted indicating that.  My iMac is literally sitting in a corner turned off until this issue is fixed and Apple is just completely tight-lipped about it. Rediculous.

     

    I tried all kinds of things, from SMC reset, to new fan software, to the kext patch, and none of them worked in the end.  I find it unbelievable that Apple wouldn't test their new OSs on their older Macs.

     

    Just goes to show that you don't always buy good service or quality when you buy from a closed provider like Apple.

  • tomasz17 Level 1 Level 1 (0 points)

    Well ...

    My iMac is freezing with this "beta phase" driver. Nothing has changed ... It is so sad :/

  • TerryBarridge Level 1 Level 1 (0 points)

    Hi everyone and thanks for a great thread

    I have a 20" iMac that I put Maverick on and doing the change over of the AMD to ATI extensions the system tells me it failed to login as root, check your password.  It refuses to budge even though I give it the admin password?

    Unfortunately I have removed the AMD extensions so I could be snookered.

    Never had trouble with authorising before

     

    Can someone help me please?

  • freandc Level 1 Level 1 (0 points)

    I'm betting you don't have a password on your user account. This will prevent you from logging in as root. Add the password to your regular login account and try again.

  • TerryBarridge Level 1 Level 1 (0 points)

    Hello  and thank you for your solution, I have trouble since installing Maverick OSX9. When I try to install ATI with your Kexthelper I get window  "we failed to login as root, check your password"

    I have admin user, standard user and disabled guest user.  Admin always authenticates everything so I don't know what to do.  Can you help?

    20"iMac Intel core 2 duo  with Graphics ATI Radeon HD 2600 PRO running OSX 10.9.2

  • tomasz17 Level 1 Level 1 (0 points)

    Hi,

    so the 10.9.3 update has landed and new verision of AMD drivers are included. :)

     

    I will check it out and report back.

     

    I would be very surprised if they fixed it ...

  • Roelof2 Level 1 Level 1 (0 points)

    Hope to Some positieve news About this update 

    Did it allready frees again.

  • LightningMike Level 1 Level 1 (0 points)

    Did the Mavericks update Friday, so far no freezes, but my iMac had been freezing about every 3rd or 4th day this past week, and I did the kex file fix about a month ago. It seemed ok for a week, then started freezing again. I'm also still having a problem where Finder will not list the Desktop or Applications in the Finder LH Column window. It's driving me bats bc I do have several handy folders on the desktop.

     

    As an aside I'm also having issues with my WD MyBookLive 2TB NAS drive. Inconsistent in trying to access it in finder since Mavericks, but it's sister WD MyCloud 3TB NAS drive is working just fine. Firmware up to date.

     

    Just another Mavericks glitch? Probably.

  • h4nds Level 1 Level 1 (0 points)

    i just updated and got an instant freeze after rebooting. i applied the kext fix (on my 2007 imac with ATI Radeon HD 2600 Pro 256 MB graphics), and it's runs like a charm once again. before updating i had a vague grey band across the middle of my screen which has dissapeared now