9 Replies Latest reply: Aug 26, 2010 9:22 AM by Spencer Waasdorp
Spencer Waasdorp Level 1 Level 1 (0 points)
My headphone jack works but theres a red light coming out of my headphone jack when its unplugged and my internal speakers will not work...anybody have an idea? Tried system preferences and says no options for selected audio and cant get any sound for my built in output speakers and my volume display in my bar is faded....HELP!

Macbook Pro, Mac OS X (10.5.8)
  • Rod Hagen Level 7 Level 7 (31,985 points)
    The port contains both an electrical and a digital output, Spencer. When the optical output is engaged then a red light appears in it. Your computer thinks there is an optical device attached on the other end and has turned off the internal speakers accordingly.

    The change is activated by a switch within the port itself, which responds to the longer plug used for optical devices. Sometimes it sticks. Often simply wiggling a regular 3.5 mm headphone jack or the like will "unstick" it. If not, try a tooth pick (make sure you don't break it off inside though!)

    If you don't want to play around with it like this, and it is still under warranty, then take it to a dealer. They may well have to replace the entire logic board if the problem persists.

    Cheers

    Rod
  • John P. Level 4 Level 4 (1,145 points)
    @Spencer

    I know this thread was marked answered but thought I should chime in since my MBP (2.66Ghz Late '08, bought May '09) started to exhibit this behavior. I was getting "No Output" greyed out speaker images and the red light coming out from the headphone jack. It's been intermittent but finally wouldn't go away so I figured I'd contact Appe.

    This afternoon I called Applecare and was advised to take it to the Apple store... no questions asked, no troubleshooting steps, just told me to take it to the store and even offered to make me an appt. I was able to get an appointment at the genius bar same day (literally 2 hours after I hung up the phone). My wife took a ride with me and we headed down there.

    When I showed the technician she tested it and then went to the back room to double check something. When she came back she told me that it was hardware related and needed to be sent in for service. I am under warranty so it was no skin off my back but I will need to be without the machine for a few days.

    I agree with Rod to take it in, esp. if you're still under warranty. I should also mention that this only started happening a few weeks ago but the red light part was rather sudden.

    Good luck!
  • coitus computor Level 1 Level 1 (0 points)
    No joy with the speaker jack, couldnt find a tooth pic, but just to say, an old cocktail stick with a pink Hawaiian umberella does the trick. Thank God, as I'm out of warrantee.

    Thanks Rod you're a star!
  • stokd Level 1 Level 1 (0 points)
    I've got the exact same problem and I've tried everything from a toothpick, q-tip, even out of curiosity I reset the SMC and PRAM to no avail.

    I tried 1 more trick I read about and sprayed a tiny small spray of WD-40 into the jack and plugged in and unplugged the headphones for a couple minutes. The headphones work every time, the internal speakers won't.

    The only thing that DID work was only momentary...I put a bit of rubbing alcohol on a q-tip and poked around inside. My speakers came to life but only for a couple minutes, the same thing happened when I tried it again on a few separate occasions.

    The startup chime still does its thing through the speakers, only after it gets to the login screen does the red light turn on. If the startup chime works, it shouldn't be a problem with the logic board, no? Is there anything else I can try?

    Mine is a Late 2006 model so it's out of warranty...any last suggestions before throwing it off my balcony would be helpful (by throw off my balcony I mean wait a few months before I buy a new one altogether).
  • allboarder900 Level 1 Level 1 (0 points)
    I am having the same problem, running a Macbook OSX 10.5

    Headphones work fine, but when unplugged the internal speakers won't work. I tried prodding around with a toothpick to turn off the light, and even when I was successful the internal speakers still would not work (same conclusion if I tried the same thing with a 3.5mm headphone jack instead of a toothpick). The volume bar is faded and grayed out, and no volume adjustments can be made to the internal speakers (besides the fact that they don't work to begin with).

    Also tried checking to see if the internal speakers were turned off in system prefs, but they don't even show up! Also tried a PRAM reset, no luck. The startup chime also still works.

    Any ideas? I'm doing my best to not have to send it in to Apple since I'm in the middle of finals now and need to study... Such a bummer!
  • jakeheat Level 1 Level 1 (0 points)
    I've got the same issue. I thought it might be something to do with recent updates, but we're all running different versions of the OS.
    BTW - the Q-Tip wriggle did it for me.
  • allievt Level 1 Level 1 (0 points)
    I just spoke to AppleCare and it said that if you do use headphone jacks and sometimes unplug them, it doesn't recognize that the headphones have been removed (red light in microphone jack). Plug a headphone jack a few seconds and voila (at least for me), my output speakers worked fine.
  • Spencer Waasdorp Level 1 Level 1 (0 points)
    Yea all I did was wiggle my headphones in the jack just a little and wah lah it worked fine! Haven't gad a problem since!