6 Replies Latest reply: Aug 19, 2010 10:42 PM by Király
Adam Ek Level 2 Level 2 (230 points)
I have a Samsung SCX-4200 Printer/Scanner. I can print to it, but I can't my computer to recognize it as scanner. It used to work in Leopard, but now doesn't work in Snow Leopard.

Mac Mini, Mac OS X (10.6.3), Mac user since 1986
  • 1. Re: Samsung SCX-4200 Scanning Problem
    alchemik1982 Level 1 Level 1 (0 points)
    Hey,

    Does anyone know if there is a way to install a driver to make the scanner on the Samsung SCX4521F work on Macs (MacBook in my case)?

    The scan driver with this printer does not work and the Samsung people says the scanner is not Mac compatible despite the manual saying it is.
  • 2. Re: Samsung SCX-4200 Scanning Problem
    Maxim Zhukov Level 1 Level 1 (0 points)
    I have installed the Samsung ScanThru (v. 3.2) on my MacBook Pro (OS X, v. 10.4.11) but I cannot make it work. When I choose File > Import > Samsung SCX-4200 Series… in my Photoshop CS3 10.0.1, I get two consecutive error messages:

    “Warning. Scanner device is not responding. Please check that it is turned on and connected to computer (OK)”

    “Adobe Photoshop. Could not complete the Import command because there is no scanner installed. (OK)”

    I know my Samsung SCX-4200 is connected to my computer. I can print to it…

    What should I do to make my scanner work?

    Maxim
  • 3. Re: Samsung SCX-4200 Scanning Problem
    dirtchem Level 1 Level 1 (0 points)
    I am having a similar problem with a Samsung SCX-4500. I get the error message that the scanner is not connected. If I turn the printer off and back on it shows up on the printer list, but often disappears shortly after. I downloaded and installed the newest drivers for both printer (3.0) and scanner (1.0), but in the printer info, it still shows the old printer driver (1.9). I have no idea where the scanner driver resides. I have tried changing the usb cable to no avail.
  • 4. Re: Samsung SCX-4200 Scanning Problem
    dirtchem Level 1 Level 1 (0 points)
    I got the new printer driver to install after uninstalling and reinstalling with the printer disconnected. The printer works fine now. I tried the same thing with the scanner, but I still get the error message that the scanner is not responding. This appears to be originating from the samsung software and keeps popping up even though I'm not trying to scan anything. Then I tried scanning via MS Word (Insert picture from camera/scanner) and although I had to hit "Retry" several times whenever the error message came up, it eventually scanned and inserted the picture. Puzzling.
  • 5. Re: Samsung SCX-4200 Scanning Problem
    designzio Level 1 Level 1 (0 points)
    I have managed to find a solution to scanning via my Samsung SCX-4826 multifunction. I plugged it in via usb directly to my Mac Pro, installed the printer and scan-thru software and expected it to just work. Printing worked the first time, however the scanning was tough. This is not the cleanest solution, but it works just fine for me. So I installed Acrobat Pro and use the Create PDF From Scanner command under File and it finds the scanner. Then it pops up the Samsung software and scans right into Acrobat. In order to scan another document, I need to quit Acrobat and restart the application for it to recognize the scanner again. If this is how it needs to work, fine with me.
  • 6. Re: Samsung SCX-4200 Scanning Problem
    Király Level 6 Level 6 (9,475 points)
    I had one heck of a time with my Epson scanner with Snow Leopard. The driver supplied by Apple did not work, nor did the "updated Snow Leopard" driver on Epson's website. Scans came out garbled, like they had gone through a shredder. Image Capture refused to use my old TWAIN driver that I had used for years with PowerPC Macs, running 10.5, 10.4, 10.3, and 10.2.

    I finally found a solution. I got GraphicConverter, and set it to open using Rosetta. It found my old PowerPC TWAIN driver and I could then scan again. Perhaps this will work for you too!