8 Replies Latest reply: Sep 27, 2010 7:43 PM by ftrobaugh
Geoff Pitts Level 1 Level 1 (5 points)

I am trying to delete a folder of Word documents from Backups on a WD HDD. I have changed all the permissions so I am now the owner, but an error message saying the folder cannot be deleted because of 'error code -8072' appears.

I have googled this and searched Apple's Knowledge base - no joy. I also saw an earlier post on this referring to the iPhoto forum, but this is not iPhoto related.

Any advice gratefully received. Thanks.

20" iMac 2008, Mac OS X (10.6.3)
  • Pondini Level 8 Level 8 (38,715 points)
    Geoff Pitts wrote:

    I am trying to delete a folder of Word documents from Backups on a WD HDD.

    What app was used to make the backups?

    If it was Time Machine, see #12 in the Frequently Asked Questions *User Tip,* also at the top of the +Time Machine+ forum.

    If it was another app, check with the maker of that app.
  • MacMastery Level 4 Level 4 (2,490 points)
    I suspect you have a file that has unusual permissions, flags or extended attributes set. These would be settings you can't generally make in the Finder.

    1. Open /Applications/Utilities/Terminal
    2. Type or paste "ls -aleO@R " (without the quotes, capitalization matters) and DON"T hit enter.
    3. Drag a single file that won't delete into the Terminal window.
    4. Hit return.

    You should see a line like this:
    localhost:~ dan$ ls -aleO@R ~/Documents/ACFA/bash\ volunteer\ schedule.rtf
    -rw-r--r--@ 1 dan staff - 703 Aug 23 2007 /Users/dan/Documents/ACFA/bash volunteer schedule.rtf

    Paste it here.
  • Geoff Pitts Level 1 Level 1 (5 points)
    Thanks for your suggestion. I followed the instructions but received the message 'illegal action' in the Terminal window.

    I tried deleting both the folder and the individual Word files within the folder. No joy.

    The folders and files are on my WD My Book disc.
  • AADD Level 1 Level 1 (0 points)
    This did not work for me. 2 unauthorized sharers have shown up on my computer. I cannot remove them following your directions. Apple is supposed to be available 24 hours a day. As you know, it is not! False advertising!
  • Ghugari Level 1 Level 1 (0 points)
    Hi there - I hit the same issue today and tried to google the error but didnt get anywhere.. finally went to terminal and forced deleted the folder and all files under it. Below are steps.. hope this helps you.

    - Open terminal (either through applications or just do a spotlight search)
    - Type "rm -rf" in the terminal window (without the quotes and dont hit enter)
    - Drag the folder you want to delete into the terminal window - the path of the folder will appear
    - Make sure there isnt an extra space at the end of the path.. delete it if there is one
    - Hit enter
    - The folder from your WD HDD will vanish!.. magic.

    Note - the above is a permanent delete option - it wont go to any trash folder.. follow the above steps only if you want to permanently delete.. good luck.

  • Alastair Riddle Level 1 Level 1 (50 points)
    Does not work for me, it says

    rm: /Users/XXX/Desktop/XX/.Spotlight-V100: Permission denied
    rm: /Users/XXX/Desktop/XX: Directory not empty

    Any ideas.

    The folder appears to be empty.
  • Lucipherous Level 1 Level 1 (0 points)
    Have you tried removing the dir as the super user i.e. using the sudo command?

    Also this is basic but are you using the -rf flag with the rm command?
  • ftrobaugh Level 1 Level 1 (0 points)
    I had a similar problem trying to get rid of an empty directory. This thread gave me some important clues to solving my problem. Perhaps my problem was the same as yours. The directory I was unable to delete with Finder contained a hidden file. Once I deleted that file, everything was hunky-dory.

    I opened the terminal window and used UNIX commands. The commands you will need are:

    "ls" - lists all files and directories in a directory
    "cd" - for "Change Directory" - this will take you to a new directory
    FYI "cd .." takes you up a directory level
    "rm" - for ReMove file

    Here is what I did:

    1) Have the directory I wanted to delete visible in Finder.
    2) Open a terminal window. (go to Spotlight and type "Terminal")
    3) type "cd " (Without the quotation marks. The extra space is crucial.)
    4) Drag the folder-I-want-to-delete to the terminal window.
    5) Hit Return key.

    You should now be in the folder you want to delete. In my case, Finder told me that the directory was empty.

    6) Type "ls" in the Terminal Window (w/o quotation marks)
    This should also suggest that the directory is empty.

    7) Type "ls -a" (which shows hidden files)
    This revealed that my supposedly empty directory contained the file ".DS_Store"

    8) Type "rm .DS_Store" and hit Return. (In your case, if you have a hidden file, you will want to type its EXACT name - file names are case-sensitive)

    9) Once the folder-I-want-to-delete was genuinely empty, I was able to use Finder to delete my folders as I wished to.

    I hope that helps.

    Good Luck.