Skip navigation
This discussion is archived

Embedded YouTube videos not working

11123 Views 18 Replies Latest reply: Jul 26, 2010 12:03 PM by direwolf8 RSS
1 2 Previous Next
Zencapop Calculating status...
Currently Being Moderated
Apr 3, 2010 5:03 AM
Hello,

Embedded YouTube videos used to work fine up until a few days ago but they have stopped working in all browsers. I use Safari, Firefox and Netscape Navigator.

I am using Mac OS X (10.6.3) and have just conducted a software update and installed a fresh version of flash. This can't be a browser problem because it is not working on any of the browsers. I am having problems viewing embedded YouTube videos on such sights as Blip.fm, Facebook, etc but they used to work fine a couple of weeks ago.

Is this a problem with flash? or Mac OS X?
13" Intel Aluminum MacBook, Mac OS X (10.6.3)
  • donkatron Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 4, 2010 6:45 AM (in response to Zencapop)
    Have you had any luck on this?

    I'm having this problem as well. For more information, this happens in NetNewsWire, Safari, and Firefox for one account on my Mac (the newest one). For the oldest account, I can view embedded YouTube videos ok. It looks like this affects new accounts because if I login using the guest account, I see the same problem. Can you try either creating a new user or using your guest account and see if the problem still happens?

    I'm using the newest version of the OS and have uninstalled and reinstalled Flash.
    MacBook Pro, Mac OS X (10.6.3)
  • Bill Gregory Calculating status...
    Currently Being Moderated
    May 21, 2010 3:53 PM (in response to Zencapop)
    Hello. I am trying to help a friend who is experiencing the same thing on his iMac running Snow Leopard. When he tries to play a YouTube embedded video, it doesn't load and says "An error occurred, please try later" in the black screen of the embedded video.

    There are two accounts on this iMac. The problem only occurs in my friend's account. The other account plays the embedded YouTube videos just fine.

    Any ideas on how to solve this? Thanks.
    iMac G5, Mac OS X (10.5)
  • cstacy Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 23, 2010 9:48 AM (in response to Bill Gregory)
    A LOT of people are reporting this issue, but I haven't seen a resolution.

    Also, if I go to the Google support forums (following links about "an error occurred, please try later", I get a very plain page that has only the Google logo and this message: "Our service encountered an unknown error. Please try again later." LOL

    I was guessing maybe it had something to do with NoScript, but all the problems happen even when that's turned off. And this problem seems very widespread.

    Message was edited by: cstacy
    various recent models, Mac OS X (10.6.3), Firefox
  • Liteyear Calculating status...
    Currently Being Moderated
    May 25, 2010 6:30 AM (in response to cstacy)
    Another me too. In particular the symptoms are this:

    + any YouTube video embedded within a webpage loads the poster frame and the controls, but after clicking the play button only shows the progress indicator briefly before showing "An error occurred, please try again later." within the video frame.
    + the same YouTube videos play fine on the YouTube site.
    + other Internet video plays fine, embedded or not.
    + when the error occurs Safari reports "One error in opening the page. For more information, choose Window > Activity".
    + the Activity window shows "forbidden" for http://v13.lscache4.c.youtube.com/videoplayback?ip=0.0.0.0&sparams=id%2Cexpire%2 Cip%2Cipbits%2Citag%2Calgorithm%2Cburst%2Cfactor%2Coc%3AU0dWSVhMVV9FSkNNNl9QRllH &fexp=900028&algorithm=throttle-factor&itag=34&ipbits=0&burst=40&sver=3&expire=1 274817600&key=yt1&signature=C15947474FA80C9A1B9DA597103C5FF7D621A478.0C1490DE456 5D519F602B0043A4E1F9D800417A0&factor=1.25&id=c3e8886e8b459334
    + the same URL downloads fine when visiting YouTube directly, except the signature value is different.

    I have tested the following:

    + the same computer worked fine a week or so ago
    + other computers on the same shared ADSL connection work fine
    + Firefox works fine (contrary to other's experiences)
    + deleting com.apple.Safari.plist doesn't help
    + disabling/enabling the "Enable Plug-ins" preference doesn't help
    + deleting Preferences/Macromedia folder doesn't help
    + reinstalling Flash doesn't help
    + empty cache doesn't help

    Tis quite perplexing.
    iMac8,1, Mac OS X (10.6.3)
  • satcomer Level 4 Level 4 (1,105 points)
    Currently Being Moderated
    May 26, 2010 7:12 AM (in response to Liteyear)
    Try remove the hidden Flash cookies with Flush and maybe this would help.
    MacBook Pro 2.16, Mac Pro Dual 2.8, 14G RAM, Mac OS X (10.6.3), iPhone 32 3GS and Time Capsule 2T
  • Liteyear Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 29, 2010 8:00 PM (in response to satcomer)
    Unfortunately Flush didn't appear to do a thing. When I run it it opens and then nothing happens. I left it open for a few hours and then quit it, but no change.
    iMac, Mac OS X (10.6.3)
  • Gazillion Calculating status...
    Currently Being Moderated
    Jun 1, 2010 4:55 AM (in response to Zencapop)
    Likewise I havent seen any solution anywhere. I'm beginning to get the feeling that this is a deliberate move by Google to migrate users to their Chrome browser which funnily enough works fine . .. May be wrong.. still looking for solution as Safari is my main browser..
    Mac Book Pro 15.4" 2.33 GHz, Mac OS X (10.6.2)
  • JanSKay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 8, 2010 11:57 AM (in response to Zencapop)
    I started having the same problem and thought there was something wrong with my system, but having read all your posts I have a feeling it's not our fault. Hope a solution is posted soon or Apple/Firefox whoever...fixes the issue!
    iMac, Mac OS X (10.6.2)
  • JanSKay Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 8, 2010 12:00 PM (in response to JanSKay)
    I should have checked before my first comment. It seems since the latest Safari update, the videos that are embedded on webpages that I can't get to start in Firefox I was just able to play without problem in Safari.
    iMac, Mac OS X (10.6.2)
  • Bill Gregory Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 11, 2010 12:08 PM (in response to Zencapop)
    The issue with my friend's computer not playing embedded videos now seems to be solved:

    We went to his ~>Library>Internet Plug-Ins folder and noticed a plug-in he didn't recognize or remember installing. We quit Safari, trashed the plug-in, restarted Safari, and now the embedded videos are playing fine.

    I hope this will help others.
    iMac G5, Mac OS X (10.5)
  • chaosal1405 Calculating status...
    Currently Being Moderated
    Jun 14, 2010 11:45 AM (in response to Zencapop)
    Just wanted to say that following the previous post, I quit safari and went to my ~>Library>Internet Plug-Ins folder and deleted the sole file in there, looked like something to do with facebook but can't be sure, after restarting safari it all works fine now =]
    MacBook Pro, Mac OS X (10.6.3)
  • dmpeters63 Calculating status...
    Currently Being Moderated
    Jun 21, 2010 12:13 PM (in response to Zencapop)
    So Video works in Safari and not on Firefox or Chrome?
    This makes no sense, this has to be a OS issue/bug.

    I tried playing video from YouTube, blip, Vimeo.

    Does anyone know how to fix this?
    Macbook Pro, Mac OS X (10.6.4)
  • dmpeters63 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 21, 2010 9:01 PM (in response to Zencapop)
    Okay - so now video works with no problem. All I did was shut down my computer and drive home from work and bam all is well again...
    I've actually had a problem with viewing video since I bought my macbook pro. This is my first time owning a mac and overall I like it a lot. And that is coming from a guy who loves Linux as well.
    Though what I do not like is the way the mac community says, see it works or it should just work. Something is weird regarding this video bug and it needs to be fixed because overall it doesn't work, its hit or miss, which is buggy.
    Does anyone have any ideas out there why video is is buggy cross browser using OSX 10.6.4?
    Macbook Pro, Mac OS X (10.6.4)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.