14 Replies Latest reply: Nov 2, 2010 8:19 AM by Ringhio
regexp Level 1 Level 1 (0 points)
I cannot connect my iPad to a wireless network running WPA2. I simply get the message back "Unable to join the network [network name]". This has been tried on an Airport Express and a Cisco wireless concentrator. Disabling WPA2 and the iPad will connect to both networks without issues. What is iPads support for WPA and WPA2? No issues with either Macs running Mac OS X or other PCs running Windows or Linux on the same network.
  • Terry Ford Level 1 Level 1 (20 points)
    The only thing I can suggest is to make sure you have the network name entered correctly, assuming you have to enter it.

    I'm currently running a Time Capsule as my router, have a hidden network with WPA2 security and my iPad had no problem joining it.
  • LeciDZ Level 1 Level 1 (0 points)
    How do you run the Time Capsule as your router? I would also like to know how to have a hidden network with WPA security. I have had trouble doing this I guess I am not savy enough to know how any help would be greatly appreciated.
  • Rick Bolton Level 4 Level 4 (1,125 points)
    Having the exact same problem. No way am I going to dummy down my network security to simply use the iPad.

    Need to do some trouble shooting I guess.....
  • Graham Outterside Level 4 Level 4 (2,910 points)
    LeciDZ wrote:
    How do you run the Time Capsule as your router?


    The Tc is just a wireless router - how else would it work ?

    Plug a computer into it and download the Airport Utility for Windows or OSX and use the autoconfig option to set up the wireless system.

    How are you using it now ?
  • Terry Ford Level 1 Level 1 (20 points)
    Start here; http://www.apple.com/support/airport/

    Don't mean to be curt but there's no realistic way of teaching you how to setup your Airport Extreme or Time Capsule via discussion board.
  • Rick Bolton Level 4 Level 4 (1,125 points)
    Got her working - went into Settings > General > Reset > Reset Network Settings.

    Also - I run a closed network - so I had to enter the wireless MAC address in Access Control (in Airport Utility)

    Apple Tech Support sorted the issue with me in about 2 minutes.

    All is now GOOD
  • SteveCWatkins Level 1 Level 1 (60 points)
    Glad it's working. I use WPA2, and the iPad connects without issue.
  • Craig Brady Level 4 Level 4 (1,790 points)
    WPA and WPA2 are both working here, as are 2.4 and 5.8 ghz.
  • greengascube Level 1 Level 1 (0 points)
    Hi, my iPad is unable to connect to my Airport Express which has WPA2 password. When try to enter the password the "JOIN" button on the keyboard becomes unresponsive and it doesnt go any further.
    I am able to connect to other wifi routers both unsecured and those with password securities. But not my own wifi router....please advice.
  • nike+runner Level 1 Level 1 (65 points)
    Try rebooting the iPad.
  • regexp Level 1 Level 1 (0 points)
    How is your comment even remotely helpful based on my question?
  • regexp Level 1 Level 1 (0 points)
    I've had time to further test this evening then the 30 minutes I had when I originally unpacked it on Saturday.

    I reset an AP and set to 802.11n using WPA (AES) and created a new public key. From 12 feet away (sitting on my couch), it detected the network, entered the key, and it immediately returned couldn't connect to network. The AP reported no activity. After some further playing around and rebooting the AP - nothing (during all this time my MacBook had no issues).

    I moved to 5 feet from the AP, it detects the network, asks me for my key, I enter it in, and within a reasonable period of time it negotiates, and then connects. I can then use apps that require the internet with no issues.

    Going back to the couch - the signal is weaker but still working. According to the AP the iPad signal is 10 to 20% weaker depending on how I hold it.

    I reset the iPad again and 3 out of 5 times I did this it would connect. But once it connected - it appeared fine.

    I used it at a bar the yesterday on an unsecured WiFi and it worked - slowly - but the signal strength indicator showed only one bar.

    Another annoyance - I restarted the iPad a number of times - and everytime it insisted upon having to enter in the shared key.

    This is when it would be nice to have better tools on the iPad itself to troubleshoot this.
  • Ed-o-san Level 1 Level 1 (10 points)
    Thank you! I encountered this issue when I switched my home network from WEP to WPA2 security. All my Mac's and PC's had no problems connecting to WPA2 - to include my iPhones.

    But my WiFi iPad could not connect until I did the "Settings > General -> Reset -> Reset Network Settings" procedure.

    All is now good now for me too!
  • Ringhio Level 1 Level 1 (0 points)
    Sorry to disagree, no need to switch from WPA to WPA 2 security settings (I don't want to believe iPAD has a "standard incompatibility").

    I suggest to leave the security protocol to WPA and set the preamble to short.

    I my case it worked perfectly.

    Please, let me know if worked for you as well.

    Ciao for now
    Ringhio