Skip navigation

iBooks crash?

103192 Views 114 Replies Latest reply: Oct 30, 2012 10:19 PM by mejudy RSS Branched to a new discussion.
  • Xperimental Calculating status...
    Currently Being Moderated
    Jul 10, 2010 4:46 PM (in response to Xperimental)
    It turns out that iBooks crashes with the same behaviour even without using the iPod app. It just takes a little longer.

    I can't work with this instability, so will be ditching iBooks and using Kindle & GoodReader until Apple sorts it out.
    iPad 64GB 3G
  • keith daniel1 Level 1 Level 1 (30 points)
    Currently Being Moderated
    Aug 29, 2010 9:25 AM (in response to Roy B)
    iBooks is suddenly crashing every time I try to load an ePub file created with the latest version of PAGES! It was working fine until I made some edits to the document and now it crashes every time. I've rebooted and synced the iPad... and deleted/re-installed iBooks. NO HELP!

    WHERE do I email the crash logs????

    This is a problem... as I am almost ready to make my ePub available to paying clients....
    macbook Pro, Mac OS X (10.6.3), iPad
  • Piano Guy Level 1 Level 1 (5 points)
    Currently Being Moderated
    Sep 3, 2010 9:54 AM (in response to Picasso25)
    +1

    I just dloaded a 24 MB pdf file and when opening in iBooks, it opened for about 5-10 secs, then crashed. Now the app will not launch without crashing.

    My guess has to do with memory allocation as it seemed to do it as it was building the tiny icons of each page across the bottom. The pdf file appears perfectly stable on my mac, both in Preview, and in Acrobat.

    Clearly a bug needing squashed
    MB Pro 2.66GHX intel Core Duo, iPad, iOS 4
  • daugav369pils Calculating status...
    Currently Being Moderated
    Sep 14, 2010 4:08 PM (in response to Tamara)
    Thanks Tamara !!!
    iBook on iPhone showed empty bookcase and not open,
    reverting to home screen. Erased app on phone AND
    iTunes app folder. Downloaded app again from store,
    installed app to phone,synced again,saw books being
    downloaded. iBook still wouldn't open ,same problem.
    Held sleep/wake button to get to power off. After
    restarting, iBook worked perfectly. Go figure.
    MacBook Pro, Mac OS X (10.6.4)
  • Kestrel11 Calculating status...
    Currently Being Moderated
    Oct 11, 2010 12:07 AM (in response to daugav369pils)
    +1

    Installed iBooks on a brand new iPad today. Can see the bookshelf briefly before it crashes back to the home screen.
    iOS 4
  • Keith Collea Calculating status...
    Currently Being Moderated
    Nov 9, 2010 1:07 PM (in response to Picasso25)
    I'm suffering from this same issue. I even deleted the culprit PDF but it still won't open, it just does the same thing it's been doing to everyone else's iBook, it tries to open, shows empty shelves for a second then crashes.

    Seems Apple's known about this issue for a while, has anyone been contacted by Apple and found a solution?
    iPad
  • Invincible Rabbit Calculating status...
    Currently Being Moderated
    Dec 16, 2010 11:42 PM (in response to Roy B)
    The very same problem here !!!!

    iBooks on my iPad is okay, but it crashes every single time when i launch it on my iPhone 4.

    Same lib.

    Help!!!!!!!
    MBP, Mac OS X (10.6.5)
  • Richard Tench Level 1 Level 1 (130 points)
    Currently Being Moderated
    Dec 26, 2010 12:08 PM (in response to Picasso25)
    Same problem here. It's fixed now, after the process described below.

    Symptom: iBooks opens with empty bookshelf, then crashes a few seconds later.

    Suspected trigger: I opened a PDF in iBooks about a week ago, from the TransLink app (our local transit service). It displayed OK when I opened it. Today I clicked on a link in Mobile Safari to open a free book download. That's when the crashing started.

    o Restarted iPhone
    o Deleted all Books in iTunes (there were only 2),
    o Re-synched
    o Restarted iPhone
    o Deleted iBooks app from iTunes and resynched (did not transfer iBooks to the Mac)
    o Restarted iPhone
    o Re-downloaded iBooks from App Store
    o Re-synched

    This time, it started OK. It then offered to automatically sync to the iTunes Store, and I chose not to do that, because I assume that's why it would still crash even after I cleared the suspected faulty PDF from my Books.
    iMac 27" (iMac11,3 Core i5 2.8 GHz, 8GB RAM), Mac OS X (10.6.5), iPhone 4, fully up-to-date
  • AliasAlreadyInUse Calculating status...
    Currently Being Moderated
    Dec 31, 2010 3:19 PM (in response to Picasso25)
    I have had the same problem for weeks with iBooks crashing after upgrading to iOS4.2 and iBooks 1.2 (308). When opening iBooks you would only see the bookshelf without books/PDFs or buttons, then it would return to the iPad home.

    I have 427 PDFs (manuals for work) some up to 24 MB which I had been using successfully before the upgrade.

    My screen is mostly locked in landscape and iBooks would crash. Then I tried portrait and was very relieved to see iBooks starting to populate the bookshelf. I can now open iBooks in both portrait and landscape.

    I can't remember which way I last used iBooks successfully before the upgrade, it may have been portrait(?).

    I don't know if the aspect has anything to do with it, or if the program needed to update all of the book and PDFs and was simply timing out. Now that I am finally in iBooks I see there are some nice new features like collections and delete.

    I have not reset or re-installed iBooks and have only synced once. I checked after the sync and iBooks didn't work. I haven't changed any other setting for iBooks or iTunes.

    I probably just got lucky, but it may be worth a try?
    iPad, iOS 4
  • Trilesy Calculating status...
    Currently Being Moderated
    Jan 8, 2011 10:33 AM (in response to Picasso25)
    I had the same problem (when I start iBooks I get an empty shelf and after about 5-10 sec it crashes to home screen). I use iPhone 4.

    Here is an easy fix for this problem:

    1) If you use email, send yourself an email with a PDF file as an attachment.
    2) Open your email, find PDF attachment and click "Open in iBooks".
    3) And voila! iBooks is now open and you can use again.

    This doesn't fix the bug though. iBooks crashed a few times on me after that, but this solution worked every time.
    iPhone 4, iOS 4
  • IBOOKS NÃO MOSTRA OS PDFS Calculating status...
    Currently Being Moderated
    Jan 26, 2011 7:09 AM (in response to Xperimental)
    Bom dia...
    Tom ...

    Muito obrigado pela sua iniciativa de tentar me ajudar, a história é a seguinte : a mais ou menos 1 mês atrás eu tinha a versão 1.1 do IBOOKS, e sempre que carregava / sincronizava via computador, tudo ocorria normalmente os novos arquivos que tinham sido adicionados na biblioteca do ITUNES,eram transferidos numa boa para o IPHONE 4.Quando fiz a atualização do IBOOKS para a versão 1.2, já aconteceu o meu 1° problema, pois quando fui fazer uso dos meu arquivos pdfs eles não estavam na estante do IBOOKS, com isso aparecia a estante vazia e sem nenhum ícone, depois de alguns segundos o aplicativo se feichava sozinho, aí então a única solução que deu certo foi restaurar o IPHONE 4 via itunes, o que levou 54 horas seguidas como já havia lhe explicado em um e - mail anterior, quando foi agora dias atrás, mas precisamente 21/01/2011 voltou a ocorrer, e novamente tive que restaurar o IPONE 4, para que eu pudesse ter acesso aos meus arquivos PDFS, que são no total de 13013 ARQUIVOS E OCUPA 3 GB NO IPHONE 4, que no meu caso é de 32 GB DE MEMÓRIA.

    Aqui vai uma breve explicação do meu entendimento que não é nada técnico nesta área : tenho a impressão de que os arquivos que já estavam no IPHONE 4 da última sicronização ( que deu certo ) são apagados e com isoo nem os arquivos que seriam adicionados ao IBBOKS/IPHONE na nova sincronização são mostrados no IPHONE 4, o que posso lhe garantir é que quando eu tinha a versão do IBOOKS 1.1 esse problema não acontecia, tá certo que esta nova versão 1.2 do IBOOKS teve uma melhoramuita significativa para mim, que é a possibilidade de enviar os arquivos pdfs via e - mail pelo IPHONE 4, isso é muito útil, mas também não posso negar que esse problema que vem ocorrendo toda vez que vou SINCRONIZAR o IPHONE 4 com a BIBLIOTECA ITUNES e assim ter os meus arquivos/ aplicativos sempre atualizados, que nada mais do que o objetivo comum de todos os usuários do IPHONE de uma forma geral, esse problema vem me tirando o sono, lhe agradeceria muito TOM, se caso me ajudadesse a encontrar uma solução definitiva para o meu problema ...

    Os arquivos PDFS, são meus sim e ficam no meu computador toda vez que acrescento novos pdfs quero também disponibilizá - los no IPHONE 4, eu consigo ter esses arquivos organizados no IBOOKS e também fazer a leitura / busca rápida desses pdfs através do IBOOKS.

    Fico no seu Aguardo....
    WINDOWS, iOS 4, WINDOWS 7
  • FelixFerdinand Calculating status...
    Currently Being Moderated
    Jan 31, 2011 12:49 PM (in response to Picasso25)
    Hi guys, I just had the same problem but I fixed it without unistalling the app and still keep my books in order.
    The problem started after I copy pdf files to the iPad. When I opened the ibooks app, I saw the empty bookshelf for few seconds and then it crashed, reverts to home screen. I try to shutdown and restart the iPad, open the ibooks app again but it didn't work.
    Then (here's the solution that works) I plug my ipad to my macbook, open it in iTunes, click on books on the left side bar of ur iPad section. You will see the whole list of your books & PDF. Then I look for the latest PDF file that I copied to my iPad (which I think is the source of problem), right click on that file and delete. Problem solved! open the ibooks app and it works just like before.

    So here are the steps:
    1. You need to know the file(s) that might be your problem (books or PDFs)
    2. Plug to your PC or Mac, open it in iTunes
    3. Click "books" on the left side bar in Ipad Section.
    4. you will see the list of your books & PDFs.
    5. look for the file(s) that might be the problem.
    6. Right Click & delete the file(s).
    7. You might should do a regular sync afterwards.
    8. Problem Solved.

    It worked for me, I hope it works for you too.
    Good Luck.
    Macbook Pro 15", Mac OS X (10.6.4)
  • joolsca50 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 17, 2011 2:13 PM (in response to Picasso25)

    I am having this problem too. I'm on 4.0.1 and I don't have any books or PDFs on the phone. When I try to open iBooks, it just crashes with the empty bookshelf to the homescreen. It did work at one time, at least I could open it...I don't use it so I haven't noticed this before...now I would like to use the app and can't. I haven't updated the OS because 4.0.1 has been so stable for me and I don't want to risk battery issues etc.

  • Rajesh Patel Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 17, 2011 2:16 PM (in response to Picasso25)

    Take Backup and restore, I think it will sure increase the loading tie

  • yahawili Calculating status...
    Currently Being Moderated
    Apr 23, 2011 8:36 AM (in response to Picasso25)

    I had the same problem. The way I fixed mine was to delete the iBooks app in iTunes running on my computer. Then do a Sync to my iPad (choose the option of not transfering the apps on iPad which will delete your iBooks installation from your iPad).

    Then I went to the AppStore directly from the iPad and installed it that way, and it is working perfectly fine now. Hope this works for you.

1 2 3 4 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.