Previous 1 2 3 4 5 Next 73 Replies Latest reply: Sep 19, 2012 1:28 PM by Robustez Go to original post
  • VS-trader Level 1 Level 1 (0 points)
    I was facing the issues whenever i was trying to connect wifi in public places like hotel or airport where you need to enter user I'd and password on a web page presented by wifi provider like btopenzone. I had to turn autofill off in safari settings and the problem was resolved. It seems there is a race condition whereby with autofill on safari tries to open a dialogue box asking to save the password while the login page is closing and that used to hang everything up. With autofill off, the problem is resolved. Typingin away from an airport lounge now to prove the point.
  • Carolbegg Level 1 Level 1 (0 points)
    A success of sorts! A reset of network settings gained me accesss to onespot - it bypassed the password request entirely and joined automatically. And toggling the safari autofill off and on got me on at Starbucks!
    Fingerscrossed for uni and library. What an odd but glorious device the iPad is.
  • bardie Level 1 Level 1 (0 points)
    I was about to post this topic when I noticed more than 4 pages of results on the same issue. No solutions that fit for me, though. I am at a hotel and cannot, for the life of me, connect to their network, while my PC connects without problems. The iPad does not connect. I just get a black "connecting" icon in the center of the screen, but it never connects. I guess this is a problem that I didn't expect with Apple. As a PC user, I was always told that Apple doesn't need all the tweaking that PC's do. Oh well!

    Can any one tell me how to clear the cache or change the settings on Safari? I can see no preferences or options anywhere. Please let me know.

    Barry
  • JimHdk Level 7 Level 7 (28,195 points)
    bardie wrote:

    Can any one tell me how to clear the cache or change the settings on Safari? I can see no preferences or options anywhere. Please let me know.

    Barry


    This is done in the Settings App. Go to Settings > Safari. You could try turning Autofill to OFF and clear the cache.
  • bardie Level 1 Level 1 (0 points)
    Yes, thanks, I figured that one out, but I still cannot connect. I have been having excellent luck all the way down from Vermont at various hotels and rest area hot spots. It's only this hotel that actually asked me to use a password (which they provided). Like I said, my PC connects via a login page that does not come up with the iPad. The iPad just tries to connect--I get a black button icon in the center of the screen, which reads, "Connecting," but it never does connect. I never get the login page where I can enter a password. Oh well, I hope they fix it eventually.

    Barry
  • iMarv Level 1 Level 1 (0 points)
    I managed to resolve this issue by deleting the network (Forget this Network) and then reconnecting to it. Hope it works for everyone.
  • howardmw@comcast.net Level 1 Level 1 (0 points)
    Here is how I fixed the problem with my iPad: Go to settings-wifi and then click on the > next to the connection you are using - under HTTP Proxy, select "Auto."

    That solved the problem for me, which was that I was connecting to the network but could not access the internet or connect to mail server. I hope this fix helps someone else.
  • Strami1234 Level 1 Level 1 (0 points)
    Did Apple help you and found a solution? I travel a lot and I have had the same problem already many times and I never can trust on my IPad. Your experience would be greatly appreciated.
  • JimHdk Level 7 Level 7 (28,195 points)
    Strami1234 wrote:
    Did Apple help you and found a solution? I travel a lot and I have had the same problem already many times and I never can trust on my IPad. Your experience would be greatly appreciated.


    If you read further in the thread you will see that romad had a very unique problem and found a solution which, unfortunately, has little chance of applying to anyone else. If you are having problems connecting to public WiFi networks (hotels, etc.) you should try turning OFF the Safari Autofill feature before you connect (Settings > Safari > Autofill). This suggestion is also given later in the thread and is known to work in many cases.

    FYI, this is the solution romad posted:

    romad wrote:
    OK, my connecting problems have been solved. After spending almost 2 hrs on the phone with an Apple Tech, we decided to see if my ISP could help shed some light on this. After about an hour with him, the problem was solved. It is probably a unique situation applying only to me but I'll spell out the background and the solution.

    My ISP is a wireless ISP; I have a "subscriber module" on my TV antenna mast pointed to "radios" on a tower that is on a mountain top and is about 15 miles line-of-sight away. OK, last year I was having problems where when I launched AirPort Utility not only did MY AirPort Base Station show up, but also those of anyone else on my "node". In order to stop this "shadowing" my ISP changed a setting in the equipment on the mountain. While changing that setting did not affect my iMacs, PowerBook, or iPhone connecting to the Internet, it apparently did for the iPad.

    OK, so what was this setting? What the ISP had done was to "NAT" the radios. Setting the radios back to the standard setting, i.e. removing the "NAT" allowed the iPad to connect to the Internet. HTH someone else.
  • vincas Level 1 Level 1 (40 points)
    I had a similar problem. My ipad connected fine on my home network, but not on my open university network. The iPad would detect the wifi network, but wouldn't connect. My solution was to simply turn it off and back on. Worked perfectly then.

    Vincent
  • BadBrummie Level 1 Level 1 (0 points)
    I just brought home a new iPad and have been unable to connect to the internet. It shows connected but won't open any pages because it's self assigning an IP address rather than picking one up via DHCP. I've tried everything a dozen times and still no luck. I've reset the network settings, renewed the certificate, rebooted the router, and it still self assigns a bogus IP address. I have had these same issues with 2 iPods and have become very frustrated. Why is it so darn difficult for Apple devices to connect to a Wi Fi???? I have 2 laptops, a desktop (iMac), and a Blackberry all wirelessly connected but these darn iPads should not be having such difficulties. If I can't resolve this, the iPad is going back to Best Buy and it will be the last Apple product I ever buy.
  • BadBrummie Level 1 Level 1 (0 points)
    Well, we returned the iPad for another unit and it's doing the exact same thing, self assigning a bogus IP address. Ask me if I was surprised! Does anyone have a suggestion on how to get this thing to get a true IP address from the router? I really don't think I should have to change any settings on the router since it works with other devices. If I can't get this to work, I'm getting my money back and Apple can kiss this customer goodbye for ever
  • JimHdk Level 7 Level 7 (28,195 points)
    Bad Brummie wrote:
    Well, we returned the iPad for another unit and it's doing the exact same thing, self assigning a bogus IP address. Ask me if I was surprised! Does anyone have a suggestion on how to get this thing to get a true IP address from the router? I really don't think I should have to change any settings on the router since it works with other devices. If I can't get this to work, I'm getting my money back and Apple can kiss this customer goodbye for ever.


    The only reason that the iPad would assign an IP address is that it did not get an IP via DHCP from your router. The fact that two iPads have had this problem indicates that there is a problem with your router or router configuration despite other devices seeming to work with it (this can and does happen). Since you have not provided much info on your router I would suggest getting a new router. These days you can get a new up-to-date quality router for $30-$40.

    By the way, what did you mean in your initial post with the phrase, "renewed the certificate"?
  • BadBrummie Level 1 Level 1 (0 points)
    Sorry, I actually meant "Renew Lease". I don't believe that there is a problem, per se, with the router or the iPad, and by "problem" I mean something broken. The router is assigning IP addresses just fine to my 4 windows-based hard wired machines and assigns one just fine to my iMac both hard wired and wireless. It also assigns an IP address just fine to my Blackberry and I have had 2 Sony TVs wirelessly connected over the past 6 weeks and also have a Samsung TV, a Sony TV, and 2 DVD players all hard wired and working fine. The fact that all these devices work and it's only the iPad and iPods that don't get an IP address would strongly suggest to me that the issue is really with the Apple devices and points to a compatibility problem or a configuration problem between these devices and the router. What frustrates me is that the only way to configure the iPad and iPod is manually. Why doesn't Apple use either a PIN or PBC for connecting anyway? Having said that, I am willing to try different settings on my router but I don't know where to start. It's using 128 bit WEP and set up for 802.11 b + g + n on wireless channel 6. If you can suggest any changes, I'll be happy to give them a try, but replacing the router because the Apple devices are the only ones that won't get an IP address doesn't seem like a reasonable solution under the circumstances. Thanks
  • APDIEB Level 1 Level 1 (0 points)
    Posted in another thread... but figured I'd post here on this "master problem thread".

    I have very similar problem. Been using mine since the day it was released back in April. For the past 4 days, it has not been able to establish a connection to an access point. I tried 4 different AP's and all Encryption settings (WPA2, WEP and None)... All respond back "Unable to connect to...." My other devices (I have several machines, iPhones, media centers, etc...) have no problems connecting. I have tried it at other locations as well.

    Most of the time it will not even see area AP's... Only when I stand practically right on top of an AP will it finally see the SSID. Regardless, however...it will not connect to it even when it does see it that close. I even tried having it connect to a cell phone via peer to peer hotspot... It will see it, and even say it's connected... However, it will not obtain a DHCP address and eventually gets the default 169.254.0.0 dummy address.

    I finally backed it up, blew the entire OS away, upgraded it to the latest 3.2.2 and there is nothing installed accept the stock out of the box configuration. It STILL will NOT find an access point unless I am a foot away and then will not connect no matter what.

    I have an appointment with the Apple Store tomorrow evening. And get this....
    Ironically, while I am trying to get the number, my Macbook Pro wireless decides to stop working until I reboot it... Then while I am talking to the Apple Store, my iPhone decided to drop the call midway through setting up the appointment.

    Apple is failing me completely over the last few days... Luckily, my wife's iMac is still working as well as several PC's...

    Annoyed and frustrated,

    Andrew