Previous 1 2 Next 22 Replies Latest reply: Apr 20, 2010 11:05 AM by ivisonbedard
PrincessJasmine Level 1 (0 points)
On my Macbook, I'm using Safari as my browser.
Everything was fine until this morning; suddenly Safari will not give me the option of opening links from one page in another tab in the same window.
For example, if I'm browsing on EBay and want to open a search result in a new tab of the same window, usually when I would right click on my track pad or magic mouse, it would say "Open link in new tab" or "Open link in new window". However, now when I right click, it just says, "Open link" "Open link in new window" and "Copy link".

I haven't changed any settings or anything on my Macbook whatsoever in the last 3 hours (at least that I'm aware of). Can anyone please tell me how to get this back to normal?

Also, it seems that when I right click anywhere on a page, I only see the options "back" and "reload" whereas before there was "view source" etc.

Please help!

xx0

Macbook Pro, Mac OS X (10.6.1)
  • Carolyn Samit Level 10 (103,365 points)
    Hi,

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Go here for trouble shooting 3rd party plugins or input managers which might be causing the problem. Safari: Add-ons may cause Safari to unexpectedly quit or have performance issues

    Since you are running Snow Leopard, *make sure Safari is opening in 32-bit mode, not 64*. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Also, (in that same window) *make sure Safari is NOT running in Rosetta.*

    

Web pages now include a small icon or 'favicon' which is visible in the address bar and next to bookmarks. These icons take up disk space and slow Safari down. It is possible to erase the icons from your computer and start fresh. *To delete Safari's icon cache using the Finder, open your user folder, navigate to ~/Library/Safari/ and move this file "webpageIcons.db to the Trash.*

    If Safari still won't let you open links in new tabs, go to the Safari Menu Bar, click Safari/Preferences. Make note of all the preferences under each tab. Quit Safari. Now go to ~/Library/Preferences and move this file com.apple.safari.plist to the Desktop. Relaunch Safari. If it's a successful launch, then that .plist file needs to be moved to the Trash.

    If your forum profile is correct (10.6.1) go to the Apple Menu/Software Updates ...
    Very important to keep your system software up to date.

    If you install the 10.6.3 update make sure and repair disk permissions.

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and restart your Mac.







    Carolyn

    Edited by: Carolyn
  • PrincessJasmine Level 1 (0 points)
    Thanks so much for that!
    I did everything up until disk utility, but still no dice.
    I am about to try the repair permissions and restart. I will come back and let you know if this resolves the issue.

    Thank you so much for your help!
  • Carolyn Samit Level 10 (103,365 points)
    Login to another user account. Launch Safari. See if you open links/tabs.

    Are you running anti virus software?






  • PrincessJasmine Level 1 (0 points)
    disk utility didnt fix it.
    no antivirus running.
    im on 10.6.3.
    about to logon to other user id.
    brb.
  • Carolyn Samit Level 10 (103,365 points)


    For eBay

    From the Safari Menu Bar click Safari/Preferences then select the Autofill tab.

    Click the Edit button next to: Other forms.

    Delete .ebay.com then click Done.

    Relaunch Safari.

    Also.. go to Safari/Preferences then select Tabs

    Make sure your preferences are set to your liking.
  • PrincessJasmine Level 1 (0 points)
    nothing on other user account either.
    perhaps i should mention also that the tab icon on the far right of safari IS there and I can click on that.
    It is the right click that is messing up. clicking on a link form one tab and not seeing "open link in new tab" is the mystery here. it just disappeared.
  • PrincessJasmine Level 1 (0 points)
    just tried that but ebay wasnt even in the other forms.
    it is like this though in all the webpages, not just ebay. apple.com, yahoo.com google.com ebay.com etc etc.
  • Carolyn Samit Level 10 (103,365 points)
    See my previous post
  • Carolyn Samit Level 10 (103,365 points)
    Try Safari/Preferences - Tabs
  • PrincessJasmine Level 1 (0 points)
    tried that. the first and third are checked.
    should i try reinstalling from applications cd?
  • Carolyn Samit Level 10 (103,365 points)
    Reinstalling Safari will more than likely cause more problems then troubleshooting the copy you have installed.

    *You are sure there aren't any third party plugins installed such as Glims ??*

    See if you can find a crash log.

    Open Finder.
    Click "Go" in the menu, then select "Go to Folder".
    Copy and paste this path into the Finder dialog:
~/Library/Logs/CrashReporter/
    Click the Go button.
    Finder opens the folder containing the crash log. Look for a the crash file with a date field that looks like the *most recent.*

    Just copy/paste into your Reply here.









    Message was edited by: Carolyn Samit
  • PrincessJasmine Level 1 (0 points)
    nothing at all in crash logs. the folder is empty.
  • Carolyn Samit Level 10 (103,365 points)
    You are certain you do not have any third party plugins installed like Glims?







  • PrincessJasmine Level 1 (0 points)
    I've never heard of Gilms :S.
    I don't believe I've installed any 3rd party apps or programs. How could check that?
Previous 1 2 Next