Previous 1 2 3 Next 196 Replies Latest reply: Jan 5, 2014 6:46 AM by CKabs
Walter Chisenski Level 2 Level 2 (485 points)
I've been using a Samsung CLP-315 with 10.6.x without issue until the 10.6.3 update. Now when attempting to print, jobs go to the queue and the printer light blinks (like it's receiving data), but nothing prints. The job does leave the print queue and is listed in the "Completed Jobs" list.

I have re-installing both the Apple Samsung Driver update and the 2.0 printer drives from the Samsung support site. I have also deleted the print queue and re-created the queue. After doing all of this, it now prints every -once in a while-, but not every time. This is also a shared printer and other 10.6.3 clients on my local network have the same issue.

Any suggestions or feedback would be great -- thanks!


iMac 20" Core Duo, MacBook Pro 15" Core Duo, PowerBook G4, PowerMac G4, Mac OS X (10.6.3), 2.0GB RAM (iMac), 2.0GB RAM (MacBook)
  • Paolo Savo Level 1 Level 1 (5 points)
    Do you have the Print Monitor installed? What does it tell during the process?
  • Walter Chisenski Level 2 Level 2 (485 points)

    Sorry for the delay in getting back with you -- I do have the Samsung Smart Panel installed. When I attempt to print a document the status of the monitor is:

    Please wait. Preparing print job. (For a few seconds)
    Printing completed.

    As mentioned, the printer light blinks for a few seconds (and if it's in sleep mode does seem to warm up), but it doesn't print most of the time. Although printing from 10.6.2 and lower continues to work without issue.

    The issue surfaced right after the 10.6.3 upgrade (maybe I will download the 10.6.3 Combo Updater and try a re-install). I haven't had much time to troubleshoot this past week, but judging from this forum there seems to be several issues with printing in 10.6.3.

    Thank you,


    Message was edited by: Walter Chisenski

    Message was edited by: Walter Chisenski
  • Duncan Brack Level 1 Level 1 (0 points)
    I have exactly the same issue with the same model of printer - precisely as Walter describes it. You can work around it by turning the printer off and on in between print jobs, or by printing a test page by pressing the big round button on the printer, but these are hardly ideal options.

    I also have another printer, an Epson Stylus Photo, and that prints fine with 10.6.3. I tested the Samsung on my backup MacBook Pro, which is running 10.5.8, and that also works fine.

    So it's reasonably clear that this is a specific problem with the Samsung printer driver and 10.6.3; can Apple fix it?


  • mr owl Level 1 Level 1 (0 points)
    Weird. I've had the identical issue. I was pleased to see the software update from Apple for samsung printers last week and assumed all was fine.

    But no the same problem. Sometimes printing is fine sometimes it appears to start printing and stops and sometimes does nothing. I've also had a go at reinstalling the original software from Samsung, downloaded the new samsun. Drivers from the samsung site, deleted and then added the printer and had a go deleting some pref files from the library. Still ne success.

    The only good thing is that now I know I'm not alone and trust someone cleverer than me can work out what to do?

    Apple these upgrades are supposed to fix issues not create new ones!

    Any suggestions most welcome.

  • laz Level 4 Level 4 (1,535 points)
    I think the CLP-300 is the older slower brother, though I see they do apparently have different drivers.

    I'm using the 1.1 CLP-300 driver, no smart panel, and the wife and I are both still printing fine after 10.6.3. Apparently Samsung is up to 3.x for the 300. I wonder what I'm missing.

    My experience with Epson and HP's panel intermediary would say try disabling the smart panel first.

    Also, see if there is any difference with direct connect (mine is shared through an Airport). If works direct, check for updates for the router.

    And last thing I got is trying to setup as a generic PCL printer. I thought I had originally set mine up using the open printer standard (the name I can't recall right now), but that might have been the B&W that preceded the color.
  • laz Level 4 Level 4 (1,535 points)
    And my last suggestion, which depends on how closely related the 300 and 315 are, would be to try and download the 300 driver and see what happens.
  • Duncan Brack Level 1 Level 1 (0 points)
    I tried a couple of those suggestions - I installed the 300 driver, and it just printed out an error page telling me to install the proper driver! So then I tried the 'generic PCL driver', which didn't work at all.

    After reinstalling the 310 series driver, it actually printed off three files in a row OK, and then reverted back to refusing to print on the fourth file. All of the first three were single-page documents; I wonder if there's some relation to the number of pages?

    My printer is connected directly by USB, by the way.

  • William Kucharski Level 6 Level 6 (14,890 points)
    Have any of you notified Apple using one of these methods?

    1) Contact AppleCare
    2) Sign up for a free developer account and file a bug report at
    3) Leave feedback here:

    We're just fellow users here and can't do anything about issues.

    Finally, has anyone contacted Samsung? Apple doesn't write the Samsung printer drivers, they just pass along what Samsung has sent them.
  • Walter Chisenski Level 2 Level 2 (485 points)

    Yes, I have submitted feedback to Apple after this happened. Although I have not sent any communication off to Samsung about the issue - which is good advice.

    Yesterday, I "Reset the Printing System" then re-added my printers. So far, things seem to be much better - I don't recall it NOT printing a job since, although I have only printed a few items.

    If anyone else can do this and retest, that would be great.


  • solidmac Level 1 Level 1 (0 points)
    I have a similar problem, but the scanner is the problem - printing works fine, but I got always an error message, if I using the scanner - and all happend after the installation of the 10.6.3 update - I'm trying some to resolve, but nothing works for this problem (reinstall of the drivers, removing of the scanner/printer). For testing I'm using a iMac 2GHz Core 2 Duo with Mac OS X 10.6.2 and the scanner works fine.

    My hardware: 2 Mac Book Pros with 10.6.3 (2GHz Core Duo & 2.33GHz Core 2 Duo)
    Samsung Printer/Scanner CLX-2160N
  • mr owl Level 1 Level 1 (0 points)
    Had a go an not sorted. Only thing that works is to turn the printer off and on between print jobs

    Any more suggestions gratefully received!


  • Steve_6 Level 1 Level 1 (0 points)
    I wanted to post about my situation, partly to add my voice, partly as a way to move on to more important and less annoying issues.

    I bought the CLP-315 about nine months ago. It worked flawlessly until about two weeks ago. I can't recall the order of events, but my problems seemed to begin when I installed the smart panel so that I could check on the number of print jobs and the estimated toner left. This may have been about the time I 1) replaced one of the toner cartridges, and 2) received the Samsung driver update.

    Sometimes it prints every other job. Sometimes it prints once after a power cycle. Sometimes the printer makes noise for about four sections as it does when it worked, but then falls silent just when I would normally hear the paper begin to move. Other times, when I try to print, I hear a simple solenoid click, then nothing.

    I wondered if it was the printer itself, until I found this discussion. Also, the printer works flawlessly if I use Bootcamp and boot into Windows XP Home.

    I have tried removing Smart Panel, using Time Machine to move the Samsung files back to a month ago, and have reset the printing system multiple times. Sometimes it seems to work a few times, but eventually it either stops working with 10.6 completely or drops every other job.

  • Walter Chisenski Level 2 Level 2 (485 points)
    Thanks to everyone else who posted their information on this issue. I have yet to find a resolution and like many of you, I have sporadic results when printing to the CLP-315 printer. Today, I even reinstalled the Mac OS X 10.6.3 Combo Installer v1.1, hoping that would resolve the issue (it didn't).

    I have left feedback on the Apple Mac OS X Feedback page and sent an email to Samsung Support with a link to this thread. Maybe they could update their driver to address the issue? I suggest everyone else having issues should also contact Samsung and point them to this forum.


  • Casho3 Level 1 Level 1 (30 points)
    Hi Laz

    It is interesting that you aren't having issues with the CLP-300. The problem I am having (which is also being experienced by at least one other user) is described below. Perhaps you haven't noticed the issue, as it only occurs when you send multiple jobs to the printer at the same time. It would be great if you could test this and report back.

    "When I print multiple jobs (of say just 1 page each) they all used to print really fast under 10.6.2. Now I've updated to 10.6.3 (and even the v1.1 combo update dated 12th April) the print queue now sits for 30 seconds between each job. This is a real pain now to print, say 15 separate pages as it can take 7 or 8 minutes. The print queue is not deleting the completed job for 30 seconds."

    Therefore, while there is no problem with single print jobs, the problem occurs when multiple jobs are sent to the printer.

    I have included the link for this thread below:
Previous 1 2 3 Next