Previous 1 7 8 9 10 11 Next 196 Replies Latest reply: Jan 5, 2014 6:46 AM by CKabs Go to original post
  • Kvargla Level 1 Level 1 (0 points)
    It doesn't help. Same behavior. Random printing. Switch off and back on or unplug and plug USB cable.
  • usutaki Level 1 Level 1 (0 points)
    Hi everyone, I contacted Samsung's support via email and here is the response I received:



    Thank you for contacting Samsung Customer Care.



    Please note, this is a compatibility issue which in the past have been resolved with a firmware upgrade patch

    with other printers. We strongly recommend to contact our support line at 1-800-SAMSUNG to request for the

    patch to be available to you.



    In case the above does not resolve the issue, then you will have to contact Apple for compatibility support.





    Thank you for contacting Samsung.

    Kind regards

    --



    Apparently, a firmware would be available for the CLP-315. I will contact Samsung and let everyone know about the outcome.



    mabui
  • idimkolis Level 1 Level 1 (0 points)
    the same problem with my macbook (with Samsung CLP 315).
    The only solution so far is to unplug the USB cable just before i hit the "print" button of
    any document and plug it back in just 1-2 seconds after it alerts me of the absence of
    the printer. And it continues normally!
    Of course, even though, I would expect Samsung find the fix for this issue.
    Waiting for info...
  • bsf357 Level 1 Level 1 (0 points)
    Creo que he encontrado la solución a los problemas de impresión de distintos documentos seguidos. Lo que hay que hacer es lo siguiente:
    -1: Ir a preferencias del sistema: Impresión y fax: seleccionar la impresora samsung clp 315 y suprimirla.
    -2: Desinstalar todo el software suministrado por samsung de la clp 315.
    -3 Reiniciar el ordenador.
    -4: Enchufar la impresora.
    -5: : Ir a preferencias del sistema: Impresión y fax: dar al botón + y esperar a que el ordenador encuentre la impresora y te diga que si quieres descargar el software de la impresora clp 315 de Apple y decir que sí. Esperar a que se descargue y ya está. NO HAY QUE DESCARGAR EL SOFTWARE DE SAMSUNG, SINO DE APPLE.
    Espero que os funcione.
  • turner1948 Level 1 Level 1 (0 points)
    Hello bsf357,

    I did as you described, your method seems to work. But still sometimes the CLP-315 does not print.
    And the SmartPanel does not work at all !
  • Kvargla Level 1 Level 1 (0 points)
    I solved my situation by buying small TP-Link WiFi print server. Now printer working flawlessly. BTW there is upgrade of Samsung drivers to 2.1 but I lost appetite to test. This added 50 € to printer price but I can print. It seems there is some problem on USB bus. Once printer is not on local USB bus with Mac it works. I know this is not solution to the problem described here but it works
  • idimkolis Level 1 Level 1 (0 points)
    Hi!
    I'm happy for you (that you finally solved your problem with the connectivity), but maybe you could provide some more info to the rest of us!
    Where exactly did you find or heard about the 2.1 Driver from Samsung for Mac OS?
    As i can see on their web site, the current driver is 2.02 since last 2009.
    Thank you in advance...
  • turner1948 Level 1 Level 1 (0 points)
    The version 2.1 of the Samsung Printer Drivers you can download from Apple
    http://support.apple.com/kb/dl905
    But these drivers does not work better then the drivers from Samsung directly!
  • credential Level 1 Level 1 (0 points)
    I have a November 2010 MBP running wirelessly with an Airport Extreme Base Station downstairs. The Samsung CL-315 is connected to the AEBS with a USB cable and I am experiencing many of these problems mentioned (printer not responding to print jobs...lights on it flashing but not actually printer, etc.). Since the MBP is upstairs and the printer is downstairs, the idea of unplugging and reconnecting the USB cable from the printer after every job isn't a (convenient) option.

    Just wondering if anyone has any suggestions? Based on the comments in this forum, is the most likely option to throw out this (relatively new) Samsung Printer and find one that is Mac friendly?

    Tks in advance.
  • arker Level 1 Level 1 (0 points)
    Hello,
    a possibility that works randomly is to deactivate airport on your computer between each impression. It seems to have the same effect than unplugging the usb cord.
    Tried with a relative succes at home.
    But still not the solution everyone hopes.
  • credential Level 1 Level 1 (0 points)
    Thanks for the reply...the idea of having to reset anything between print jobs is a bit too annoying and not a solution, but it seems that's my only option if I want to keep it.

    Had I known this, I probably would have taken advantage of the $100 off a printer when I purchased my Apple and bought one that didn't have compatibility issues.

    I've heard about Apple's quest to provide excellent customer service. Having exhausted all the options that Apple Tech Support has provided me to try and fix this issue, is anyone optimistic that I can approach them and see if they'll allow me to purchase one of their printers at $100 off (same deal had I purchased a printer back in November when I purchased this MBP?)

    Thoughts?
  • blufiresw Level 1 Level 1 (0 points)
    Hi mabui, were you able to get a firmware update fix?
    Thanks!
  • Tom George Level 1 Level 1 (10 points)
    I was having this problem. Upgraded iMac to Snow Leopard. Eventually my CLP-315 quit printing. It always displayed the red light.

    I chatted with a Samsung support person tonight. Not sure if this is what did it, but open the front cover of the printer and check the thing (I don't know what it is called) to the left of the cartridges. It is a clear plastic thing with the 4 letters printed on it. Make sure it is pushed in all the way (it doesn't seem to click into place like the printer cartridges do). When I did that, I got a green light on my printer again. Or maybe it was just a coincidence.

    Now I am back to the other problem. My printer only prints every other job. I print, it works, I print again, it fails, I print again, it works.

    When it fails, the job shows up in the queue. But after a few seconds it just disappears from the queue.

    If I disconnect/reconnect the USB cable after every job, it prints every time.

    Hope that helps someone.
  • Johan_Gu Level 1 Level 1 (0 points)
    A small usb/ethernet printserver solves the problem. Plug and play if you have already installed the printer driver. No software needed for the printserver, uses Bonjour automatically.

    Name: Deltaco Printserver 10/100 USB
    Price: 195 SEK or USD 29
    URL in Sweden: http://www.dustinhome.se/pd_5010469570.aspx

    Best of luck!
    /Johan
  • MaxRenn Level 1 Level 1 (0 points)
    Hi,

    can you give further information about the firmware update?
Previous 1 7 8 9 10 11 Next