12 Replies Latest reply: Feb 5, 2011 6:46 AM by JimHdk
mrowlinson Level 1 Level 1 (0 points)
I work at a hospital and we have a guest wifi network for patients and guests to use. To connect you choose the guest network and it connects and then that screen slides up where you would normally hit the accept box or enter a login. At our hospital you have to enter a login. Once you enter the login and hit submit it just sits there. You can see the wifi activity indicator on top of the screen showing it's doing something but it never finishes the process and moves on past this screen. It works fine on iPhones and iPod touches and I have been using it on my iPhone on a daily basis. I don't get why it doesn't work on the iPad..

Here is the screen I'm talking about on my iPhone
http://img395.imageshack.us/img395/5783/photo3t.jpg
I zoomed into the name/pass box in this one:
http://img697.imageshack.us/img697/9753/photo4hd.jpg

MacBook Pro, Mac OS X (10.6.3), iPhone 3GS, iPad 16GB
  • acid-rain Level 1 Level 1 (0 points)
    Same thing is happening at my school. We use the Cisco Clean Access Agent. After connecting it to the Student Wifi, a login screen slides up from the bottom. After filling out the username and password, the screen freezes despite the activity indicator circling. I bought the iPad for school and now I can't even use it. It's disappointing and needs to be resolved.
  • AlphaBetaOne Level 1 Level 1 (0 points)
    The authentication box there looks (although it's a little hard to truly make this determination) as though it is a flash or java app.

    If it is, that may be a problem because Flash (not sure about java) is not supported on the iPad.

    Message was edited by: AlphaBetaOne
  • blatch Level 1 Level 1 (0 points)
    Did you read the part where he said he's been using it on his iPhone?
  • hannor Level 1 Level 1 (0 points)
    Exactly the same here. Works fine on the iPhone (3.1.2) but not on the iPad (3.2).
  • JimHdk Level 7 Level 7 (28,240 points)
    mrowlinson wrote:
    I work at a hospital and we have a guest wifi network for patients and guests to use. To connect you choose the guest network and it connects and then that screen slides up where you would normally hit the accept box or enter a login. At our hospital you have to enter a login. Once you enter the login and hit submit it just sits there. You can see the wifi activity indicator on top of the screen showing it's doing something but it never finishes the process and moves on past this screen. It works fine on iPhones and iPod touches and I have been using it on my iPhone on a daily basis. I don't get why it doesn't work on the iPad..

    Here is the screen I'm talking about on my iPhone
    http://img395.imageshack.us/img395/5783/photo3t.jpg
    I zoomed into the name/pass box in this one:
    http://img697.imageshack.us/img697/9753/photo4hd.jpg


    This sort of problem has been reported here before and people have had success by turning off the Safari Autofill option.

    Go to Settings > Safari > Autofill and turn this off.

    The freeze-up seems to be caused by a dialog that Autofill attempts to bring up (Save password, etc.) while the connection process is proceeding.

    I think that on the iPad the Safari Autofill defaults to ON while on the iPhone and iPod Touch it defaults to OFF. Someone can correct me if I'm wrong. This would explain why this works on your iPhone and iPod Touch but not the iPad.

    Try this out.
  • hannor Level 1 Level 1 (0 points)
    I tried this. Doesn't seem to help.
  • Alan Abentrod Level 1 Level 1 (45 points)
    apple has been having all kinds of problems with ipad wi-fi
    they are working on a fix till then your stuck
  • JimHdk Level 7 Level 7 (28,240 points)
    hannor wrote:
    I tried this. Doesn't seem to help.


    You sort of jumped in. My response was directed to the original poster. Do you have more detail as to what network you are attempting to login to and what screen is being presented? Exactly what happens, etc.?
  • Cluto Level 1 Level 1 (0 points)
    This is another example of the fact that there is something wrong with the iPad's wifi. It runs iPhone OS but the iPhone will use wifi flawlessly while the iPad will not. I just saw that in Singapore again. Guy sitting next to me on his iPhone using free wifi, my iPad would not connect.
  • JimHdk Level 7 Level 7 (28,240 points)
    Cluto wrote:
    This is another example of the fact that there is something wrong with the iPad's wifi. It runs iPhone OS but the iPhone will use wifi flawlessly while the iPad will not. I just saw that in Singapore again. Guy sitting next to me on his iPhone using free wifi, my iPad would not connect.


    Did you try any of the advice offered here, i.e., turn off Safari Autofill and clear Safari before connecting? I believe that the iPhone defaults to Autofill off while the iPad defaults to Auto fill on. This could account for problems connecting on one but not the other.

    There is also an App explicitly for connecting to the Singapore airport WiFi. If nothing else works you could try that. Perhaps that's what your fellow traveler was using.

    If you feel that the iPad has a problem here please report the problem to Apple via their official channel (they do not surf these forums looking for bug report. These are primarily user-to-user forums). Give as much detail as you can in your report.

    See: http://www.apple.com/feedback/ipad.html
  • b2 Level 1 Level 1 (0 points)
    I have also been unable to connect to ATT hotspot at Barnes and Noble. Autofill is off on Safari settings. When you attempt to join network, either through Settings or in Safari, a window slides up and you have to check of to accept terms of service. On my iPhone 4 this is done with no problem at all. On the iPad the window slides up but doesn't finish loading and so I cannot connect.
  • JimHdk Level 7 Level 7 (28,240 points)
    You are responding to a thread that has been inactive for more than 7 months. You would do better if you started a new thread on your topic.

    That being said I haven't had this problem at Barnes & Noble. Perhaps you could give a bit more detail on the steps you took to connect? What browser? Etc.