14 Replies Latest reply: Sep 27, 2013 2:51 PM by Jayefromct
Calvin LaBauve Level 1 Level 1 (60 points)
I can't send email with my cox.net email account on my iPad. I have SMTP set up as smtp.east.cox.net, but it says the sender address is invalid. I have the same problem with my iPhone 3GS, but I can use the AT&T smtp server cwmx.com to send mail. Anyone have a fix for this?

iMac 2009 24 in., 3.06 GHz, 4g RAM, 1 Tb HD, Mac OS X (10.5.6), MB Alum 2.4gHz, 4g Ram, iPod 160G, iPhone 3GS 32G, Nano 8G, iTouch 32G
  • Jerryb Level 3 Level 3 (870 points)
    I don't have an iPad (yet) but on my iPhone 3gs I also encountered this problem. I'm a Cox user on the West server.

    Verify under your account settings, advanced, that your are using port 995. That is the way it is set on my Mac Mail and iPhone mail.
  • MacMonster76 Level 1 Level 1 (0 points)
    I am having the exact same problem using Cox. I can receive mail fine, however I cannot send mail to anyone. I have been on the phone with cox, they verified settings. Now Apple for a half hour with no resolution as of yet. I'll try to keep posted.
  • Jerryb Level 3 Level 3 (870 points)
    If you are using Cox (east) then make sure you use port 557, I think it is, and turn on SSL with password authentication. Also make sure your outgoing server is smtp.east.cox.net.
  • virtualgeo Level 2 Level 2 (245 points)
    What are ALL your settings for Cox? Are you using port 995? Do you have any other Mail accounts on your iPad? If so, when you click on the SMTP server button for Cox, what does it show under "Other SMTP Servers" (they better be "OFF")?
  • MacMonster76 Level 1 Level 1 (0 points)
    After calling Mac support they resolved the issue, it was a port issue. Thanks.
  • Old Toad Level 10 Level 10 (121,045 points)
    And the port you ended up using?
  • tsc4164 Level 1 Level 1 (0 points)
    Please tell us what settings worked. This is very frustrating.
  • Jerryb Level 3 Level 3 (870 points)
    Here is a link to another discussion on exactly the same subject by the same person. You should be able to get good results by following the thread.

    http://discussions.apple.com/thread.jspa?messageID=11328518&#11328518
  • tsc4164 Level 1 Level 1 (0 points)
    still can't get the mail to work correctly. I've tried every port and other change possible and still can't send mail on the iPad or iPhone even though the cox mail works fine on the pc and the iMac. Please help!
  • Jerryb Level 3 Level 3 (870 points)
    Okay. Let's try this by the numbers.

    1. your incoming server should be (assuming you are in the Cox east region) "pop.east.cox.net"
    2. your outgoing server should be "smtp.east.cox.net"
    3. SSL should be "on"
    4. authentication should be "password"
    5. port - now here is where I have seen differences - I use "995" on my cox west. The east port I have seen recommended is "587". I think you have to ensure that whatever port you use that you aren't using it for another mail acct. For me I use 995 for my Cox acct and 993 for my Mac mail acct.
    6. I would suggest that after you change the settings, you "reset" the device.

    All the above works for my iPhone. I do not have an iPad yet. If this doesn't help then I'm afraid you have tapped all my knowledge.

    Good luck.
  • Jerryb Level 3 Level 3 (870 points)
    Forgot to begin by saying that you should start by deleting the Cox acct that you currently have set up (the one that isn"t working). Then do the setup.
  • John Wardlaw Level 1 Level 1 (5 points)

    We also have an ipad 2 and are on Cox west using smtp.west.cox.net for outgoing server. Tried the solutions above including deleting first. So far no luck. Same problem on  the iphone, though only on wifi, it works fine on 3g. Dont have that on our ipad 2.

     

    We have the same issue on vacation at a place that uses Hughesnet satelite internet service, checks mail fine, cant send. But my old g4 laptop sends fine with the same settings.

  • John Wardlaw Level 1 Level 1 (5 points)

    double checked all our outgoing cox settings and changed the port to 25 and our smtp outgoing cox west account now works for sending mail on the ipad 2.

  • Jayefromct Level 1 Level 1 (0 points)

    To Jerryb and anyone else tearing their hair out because they can receive emails on their iphone but cannot send them:  I just solved this problem quite by accident after spending two days prowling online for every scrap of information I could fine.  First of all I don't know if everyone has a cox.net address.  Mine ends in necoxmail.com.  the smtp.coxmail.com was not working.  I tried adding the ne then tried cox.net just in case but nothing worked.  However I was using instructions found on the cox website for configuring email on your iphone.  When it didn't work I began to modify my entries based on information found on the Apple website including trying the At&t outgoing server.  That didn't work either so I went back to using coxmail.com but still kept modifying the other options based on different suggestions I found online.  Eventually what ended up working is this:

    Outgoing server: smtp.coxmail.com (I assume if your email address is cox.net, then you would use cox.net).  No user name or password, ssl off, authentication password on (although the check mark next to password seems to keep going away so not sure how important this is).  Finally and most importantly of all, PORT 25.  Every scrap of information provided by cox and apple all say port 465.  It wasn't until I changed it to 25 that everything that was piled up in my outbox went.  I sent a few more after that to make sure it would keep on working and it has.

     

    Hope this helps someone out there.