Previous 1 2 3 4 Next 58 Replies Latest reply: Dec 17, 2011 12:15 PM by joe268 Go to original post
  • wwalkersd Level 1 Level 1
    Some more info: the problem is not just dropping the connection, there's also a problem with throughput.

    I ran the network speed test at on each of our three laptops, each sitting in the same place, with all other computers asleep, Time Machine turned off, verified nothing else happening with Activity Monitor.

    MacBook Core 2 Duo 2.16 GHz 10.5.8
    19623 Kbps download/1502 Kbps upload/36 ms latency

    MacBook Pro 17" Core 2 Duo 2.33 GHz 10.5.8
    17300 Kbps download/1213 Kbps upload/32 ms latency

    MacBook Pro Core i7 2.66 GHz 10.6.4
    2876 Kbps download/1464 Kbps upload/31 ms latency

    I ran the test on the i7 a couple of times for consistency. But, yeah, the hot new i7 can only download at about 17% of the speed of the MacBook Pro 17 it replaced.
  • wwalkersd Level 1 Level 1
    Some good news here. I took my wife's 'book to the Genius Bar last night, and they found a solution I hadn't seen elsewhere: trash everything in 'Mac HD/Library/Preferences/SystemConfiguration' and then restart.

    For anybody reading this who doesn't get Unix directory notation, here are the steps:

    1) Open a window at the top level of your hard disk (often called Mac HD). It'll either be on the desktop, or in the Finder window sidebar.
    2) Double-click on the "Library" folder.
    3) Double-click on the "Preferences" folder.
    4) Double-click on the "SystemConfiguration" folder.
    5) Drag all the files in that folder to the trash.
    6) Restart your computer.

    While it's true we've got way less than 24 hours of use on this fix, so far it's working great.

    Oh, and the Apple Store has a wicked-fast internet connection. reported download speeds approaching 40 Mbps!
  • Nypher Level 1 Level 1
    Exactly the same problem here. I have a MBP 17'' running 10.6.4, today a friend of mine (with a MBP 13'') had the same trouble too.

    I believe is system update related since I've been in the same network (at home) without changes and only recently the wifi drops have started.
  • recordista Level 1 Level 1
    I believe I may have the same issue here. Connection with our WRT54G (running OpenWRT) started getting unreliable so I swapped in a Ubiquiti NS2 (much better radio) which seemed to solve the problem but over time the connection got less and less reliable. Three other computers in the building (one IonITX running Ubuntu 10.4 LTS, one Dell laptop running XP, one Compaq running Vista) work perfectly with the same AP, even when my MBP is unable to connect. When I click on the Airport icon and it starts scanning, it frequently sees several other APs but not ours, which has a far stronger signal and is using an unoccupied channel. When I do see our SSID and select it, I usually receive a password prompt, even though the (WPA2/PSK) credentials are stored in my keychain (in fact, that's where I go to look up the long, high entropy key used.)
  • Gmejias76 Level 1 Level 1
    Hello all! I'd like to add myself to the list of people having wireless problems. I bought my Macbook Pro 15 2 weeks ago and have yet achieve a successful connection to the internet. I had a Netgear Wireless-N 150 router provided by my ISP and switched to a Linksys E-2000. Two windows laptops are also connected and work like a charm, connect at fast speeds. However, my macbook drops the connection every 2 minutes and when it does connect its awfully slow. I thought it was my router til my friends Macbook Pro could not connect to my network either! First Mac I ever own but I was definately dissapointed :/. Any word from Apple on the subject??
  • recordista Level 1 Level 1
    Deleting /Library/Preferences/SystemConfiguration/ and restarting fixed the issue here. Still working well after 2 weeks.

    Some kind of cruft appears to accumulate in that .plist
  • Klatox Level 1 Level 1
    I tried this, but it seemed to only work for about 1/2 a day, now I'm back to turning on/off airport...
  • bonzaisushi Level 1 Level 1
    I am having the same issue as well unibody 15 running the latest snow leopard. The Internet will drop, so I turn my airport off then back on and it won't even pick up a wireless network list. When it does it will time out. God this is frustrating. I can't even get it to connect now and I tried deleting the plist. Seems like it got bad after the latest SL update. I can't even use a wifi stumbler to pick up networks. G/fs MacBook is not having this issue. Could my airport card be dead?
  • Skonk Level 1 Level 1
    Hi all.

    I'd kinda forgot about this post but having being sat here trying to have a conversation with a friend over MSN (mac version) but getting 8 WIFI disconnections in the space of about 30 minutes it remind me

    So as you may guess, I still have the issue.

    The thing is, I'm currently booted up into Windows 7, running on bootcamp and have been for over an hour and not had a disconnection.

    It's just so **** frustrating that clearly this is an issue with the Mac operating system since Windows running on the exact same hardware has never and I repeat NEVER dropped my WIFI connection.

    I would love to just dump MacOS altogether and run nothing but Windows on here purely because of this WIFI issue but sadly I spend a lot of time in Final Cut Pro so need to be in MacOS.

    I appreciate everyone who has made suggestions as to causes and offered potential fixes but nothing really seems to work (other than running Windows).

    The thing is, pretty much any suggestion of what could be wrong can be answered with "but it works fine on windows".

    Dodgy router? -> Works fine in Windows
    Faulty Mac? -> Works fine in Windows
    Interferance from neighbours (i.e change channel)? -> Works fine in Windows


    I guess all we can hope is that at some point apple sneak a fix into some minor os update.
  • soopadrive Level 1 Level 1
    I didn't see any resolution to this topic so I thought I might try posting a link that may attempt to resolve this widespread issue. ate-a-simple-fix/

    This link describes a potential fix (establishing a new network location that uses your preferred network name and settings, and saves those settings), as well as a detailed log in Terminal that displays the error why the network connection drops.

    I will attempt this fix later today and share my results.
  • Dazzerc Level 1 Level 1
    After having this issue for many weeks and trying various solutions to no avail on my MBP, buying a new TP-Link router to replace my old Belkin one, solved my problem entirely. Connection is now strong and stable.
  • Oliver Jobson Level 1 Level 1
    Trashing the airport config file (/Library/Preferences/SystemConfiguration) works for me for about a week.

    I've noticed when the problem comes up, the preferences.plist file in the location has been recently modified (in the last last minute or two), however the airport one has not(?). I have made a copy of thse files during the current working state, and will compare it to the files during when the problem is occuring to see if I can see any changes/incorrect settings/corruption.
  • RamGuy Level 1 Level 1
    I might as well confirm this problem.. I've been using my very first MacBook Pro for about a year now, I'm sitting on the MacBook Pro 17" with 1920x1200 screen, Intel Core i5 and have upgraded it with 2x 4GB Corsair DDR3 1066MHz RAM and Intel X25-M 80GB SSD Gen2 drive.

    My problem is my connection dropping randomly every now and then, it's not like I need to restart the AirPort Utility or anything, it's not like I'm connected to the router but not getting Internet access, it's simply my MacBook Pro dropping the entire connection and for the next few seconds I'm not able to see any of the four wireless networks within range at all, then after like 1-2min it auto re-connects to my home network and I'm good to go again. It's not that critical as things happens so fast, the problem is when things like this start happening in the middle of some kind of uploading or important remote session of any kind, or even during TimeMachine backups and things like that resulting in things taking much longer time than it should, and worst case scenario being loss of important data while uploading..

    It feels silly that notebooks in this price range and of this high quality are facing major issues with basic things like the stability of the wireless connection. I suspect it's the dreadful Broadcom wireless NIC that's to blame, the drivers and software is obviously not flawless and even though these issues don't occur when using Windows7 64bit through BootCamp there is really no doubt that Broadcom has record of bad software and drivers for both Mac, Linux and Windows so why Apple have decided to stick with Broadcom in the first place is hard to say.

    But no matter whom's to blame the fact still remains that my MacBook Pro 17" 2010 model isn't able to keep an steady and stable wireless connection for extended periods of time and that's simply not good enough in todays market. We are talking like random drop outs at least once every two hours, that's worse than my girlfriends cheap Acer TimeLineX 4820TG with it's Atheros AR9285 wireless NIC.

    And no it has nothing to do with your wireless router, this has been happening both at home and at work for me the past year and at home I've been using different routers this year, from D-Link DVG-5802S @ 802.11n 2.4GHz @ 40Hz, same issues on a Linksys WRT320N on both 802.11n 2.4GHz @ 40Hz and 802.11n 5.0GHz @ 40Hz not to mention I've tried with the Netgear WNDR3700 on both 2.4GHz and 5.0GHz band both utilizing 40Hz of course for optimal performance. Now I'm on a D-Link DAP-2553 Business Access Point and running 5.0GHz @ 40Hz only and I'm facing the same exact issues this time around. At work we've had both the D-Link DIR-655 on 2.4GHz @ 40Hz and now we're using the Asus RT-16N running 2.4GHz @ 40Hz and the same dropouts keep happening no matter what network and router I connect to.

    It has nothing to do with wireless encryption either as I've tried running without encryption just for the sake of testing and it still keeps having random dropouts. And it has nothing to do with interference as there is no other 5.0GHz wireless network in range of my house and how could anyone explain how things are steady and stable through BootCamp and Windows7 64bit and not within Mac OSX 10.6.6? I did even try going 10.6.7 build 858 but no improvement on this issue to be seen.

    Let's hope Apple comes to their senses and replace their Broadcom wireless NIC's with something more useful, going back to Atheros would be better and the best would be to make a deal with Intel and use their Centrino wireless NIC's like the 6200 and 6300 series that are way better than this.. At least go for the newest Broadcom 3x3 NIC's and lets hope they work better.
  • joe268 Level 1 Level 1

    This guy saved my life.  Solution works!

Previous 1 2 3 4 Next