Previous 1 2 3 Next 44 Replies Latest reply: Jan 23, 2015 6:35 PM by bananas13 Go to original post
  • myth0s Level 1 Level 1 (0 points)

    JD, that was an excellent, informative answer, thank you!

     

    It would be great if there was a plugin for the Finder to show Picture Transfer Protocol (PTP) devices.

     

    I am fine using Image Capture to transfer the photos and movies off of the SD Card, but it is less convenient than manually manipulating the SD card (for me). And I definitely do not want Yet Another Device like a USB card reader to deal with. The camera itself ought to be sufficient as a reader.

  • Kimm Tynan Level 1 Level 1 (0 points)

    Thank you so much!  I had hundreds of photos on my Rebel that I have not been able to download for the longest time, I was afraid they were lost forever. I used Image Capture and, admittedly after lots of futzing around, they are now safely downloaded.  Hooray!

  • Jay Warner1 Level 1 Level 1 (20 points)

    Clearly, I am not alone in wondering how Canon image files get onto my machine.  My solution was to bypass the camera aspect – I bought a 'universal' card reader for relatively few bucks, and it always mounts the chip as a USB 'device' that automatically invokes LightRoom or iPhoto, as I specify in the prefs. 

     

    I have since added two more Canon point-and-shoot cameras, and both of them behave the same way.  They must all use the PictureTransfer Protocol (PTP) (thanks, J D McIninch, for the info), since they do _not_ show up as mounted devices.  When I do not use the universal card reader, I attach the camera, wait a while, then tell LightRoom to import; it finds the correct files.  _Sometimes_ it will find them automatically, but I'm never sure if it will.

     

    Meanwhile, I recommend that you use a good cable (as per Csound1), and a card reader, or simply wait 2X as long as usual for mounting USB devices, then proceed with your choice of photo software.

  • atmatm Level 1 Level 1 (0 points)

    I am having the same issue.  I have a 2009 canon eos rebel xti and a brand new 2013 imac ios mountain lion, and the imac does not even see the camera. this camera was not cheap.  This just adds up to time and money wasted. So fustrating.  But my cheap 2008 canon pocket camera is seen by the imac. go figure.

  • atmatm Level 1 Level 1 (0 points)

    OMG, I saw some advicce a few posts up that said: "use the same usb cable that came with your camera"  Luckily I am an organized packrat, found the white usb cable, and all the new pics from the rebel xti are there on my imac. The usb from my cheap pocket powershot canon (which i always used to use for both canon cameras) although works for the powershot, does not work with the eos rebel xti.

  • atmatm Level 1 Level 1 (0 points)

    My USB cable that came with my 2009  canon eos rebel xti is allowing me to view pics from the camera on my 2013 imac.  The USB that came with my 2008 canon power shot does not allow me to access the files on the rebel xti.  On my old imac from 2009, the cheap USB worked for both cameras, but not anymore.  This forum really helped. I would never have thought to try a different USB. THANKS!

  • philsampson Level 1 Level 1 (0 points)

    Running 10.4.11 OS, so software included with my T3i won't install (wants 10.5) - however, the image capture solution works for me! Thanks so much! As an aside, card reader came with my SD card and while the system recognizes the device and even gives it a name, the thing won't mount or in any way perform as it should.

  • _beowulf Level 1 Level 1 (0 points)

    I know this thread is pretty old, but I want to update it with a recent experience. My wife purchased a Canon Elph 135, which exhibited all of the connection problems mentioned here: didn't show up on the desktop, didn't show up in iPhoto or Image Capture, and I installed the Canon camera software and that didn't help either. finally I saw some people mention cable-related solutions, and in particular, that using the Canon cable instead of the non-Canon cable solved their problems. Our experience was just the opposite. I had to jettison the Canon cable that came with the camera and use an old 3rd party USB cable that I just happened to have leftover from some product or another that I bought years ago. Once I connected the Elph 135 and MacBook (OS X 10.8.5) with the old cable, suddenly everything was working as expected. Now I just need to uninstall the crappy Canon software and we're good to go. Hope this helps.

  • fictionalbeing Level 1 Level 1 (0 points)

    As a further update. I have a Canon EOS 70D. My apple mac pro won't even recognize that it is attached (in the system profiler). Using the USB cable that came with the camera.

  • _beowulf Level 1 Level 1 (0 points)

    Ours worked once we used a NON-Canon cable. To be absolutely clear, the USB cable that came with our Canon camera was the problem. HTH.

  • dsavvas Level 1 Level 1 (0 points)

    For what its worth, I have a Canon MP490 printer.  I stuck the memory in it, and I was able to use the printer to download pictures.  Acts just like a reader.

  • alexsps Level 1 Level 1 (0 points)

    I have an iMac and I had the same problem. I was connecting my camera to one of the USB ports on the keyboard.

    Then I tried one of the ports in the back of the Mac, and the camera was recognized!

  • CptHollywood Level 1 Level 1 (0 points)

    It is now late Oct 2014.

    I have several Canon Cameras.  All worked and transferred the files fine when I plugged in the USB.  I use mostly video files.

    I updated to the newest OS.   Now the computer won't detect them at all.

     

    The cables are fine...tried numerous ones...all the same result.  And they work fine on my PC.

    I don't want to "get a card reader" option, because I shouldn't have to.  It worked perfectly before...why not now?

     

    If anyone gets anywhere with a solution...please enlighten us! 

  • angriabeavis Level 1 Level 1 (0 points)

    Hi CptHollywood

    SAME PROBLEM and I've been at it all day!!

    I've tried two USB cords, two different Canon's 7D and 30D) I've tried the iMac, the MacBook Air (new) and about 5 CF cards and even tried updating Canon Utilities (the programs within) and my cameras nor cards still won't show.

    I believe the solution is to upgrade the Firmware of the CF Cards, the only problem is (besides having to first 'format' the card which has the photos you haven't downloaded yet!) - you have to download it to computer then install it to the CF card....and that's impossible if the card is not showing. I have emailed Canon Australia and now await for response, will let you know if they solve the problem.

    I have searched and searched all day (then came across this forum) I am thinking of going backwards to OS 10.8 as a last resort?

    I'm just reading into it to see what's involved.

    OK let me know if you've since found a solution. Cheers,

  • bananas13 Level 1 Level 1 (0 points)

    I had this problem and it was driving me nuts. I tried everything suggested in forums. Was at Office Depot today and lo and behold there was a card reader for $4.99 at the checkout so I got it.

     

    WORKS LIKE A CHARM. I know it doesn't FIX the problem, but it is the easiest workaround ever. The kind I got is really cute and made by Ativa.

     

    Good luck!

    Anna

Previous 1 2 3 Next